Quantcast

Jump to content

» «
Photo

[GTA4][Alice] ~ Skyburst coloured Fireworks ~

30 replies to this topic
ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#1

Posted 09 May 2009 - 04:39 PM Edited by ZAZ, 16 January 2010 - 08:26 PM.




Skyburst coloured Fireworks
place the Skyburst rocket and fire up the sensational coloured Fireworks

**************** update version 22.12.2009

**************** works with alice version 0.9

**************** for GTAIV 5.patch 1.0.0.4


Download GTA4_Fireworks 2010

---------------------------------------------------------------------------------------------------------------------------------------------

old version/alice 0.32/gta4 patch 1.0.3.0
Download

---------------------------------------------------------------------------------------------------------------------------------------------

user posted image
Free Image Hosting by ImageBam.com


1. first install Alice
How to do, look at: www.gtaforums.com/index.php?showtopic=386816
It requires to install an asi loader like xliveless: www.gtaforums.com/index.php?showtopic=388658

2.
copy Fireworks.lua into GTA IV\Alice folder


--->press R to place the fireworks rocket
--->optional: hold C pressed after lift off to view from overhead cam
--->optional: press again R after lift off to blow up the fireworks rocket earlier



credits fly out to Alexander Blade 2008 & Adhome # http://alexander.sannybuilder.com/ for Alice.asi
Listener for xliveless, GooD-NTS # http://openiv.com/
also credits to Seemann, Bart Waterduck, Patric W., spaceeinstein
and much thanks to Chamber and oinkoink




McLovin2404
  • McLovin2404

    Homeboy

  • Members
  • Joined: 18 Mar 2009

#2

Posted 09 May 2009 - 04:48 PM Edited by McLovin2404, 09 May 2009 - 04:56 PM.

The file name is "Fireworks.lua".

Do I really need Alice asi loader since I already have other asi loader?

AdanRyder
  • AdanRyder

    Square Civilian

  • Members
  • Joined: 14 May 2008

#3

Posted 09 May 2009 - 04:53 PM

QUOTE (McLovin2404 @ May 9 2009, 16:48)
The file name is "Fireworks.lua".

Where do I insert this file kind sir?

You need ALICE.

ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#4

Posted 09 May 2009 - 05:01 PM

QUOTE (McLovin2404 @ May 9 2009, 16:48)
The file name is "Fireworks.lua".

Do I really need Alice asi loader since I already have other asi loader?

Alice is not the asi loader. Alice is a plugin which gets started from an asi loader.
I used only xliveless which includes an asi loader. Other asi loader should also work.

McLovin2404
  • McLovin2404

    Homeboy

  • Members
  • Joined: 18 Mar 2009

#5

Posted 09 May 2009 - 05:38 PM

Ok...just read the Alice post. This fireworks script won't work in MP?

Nice work on the script though

abcadgfawghaeheheahaeh
  • abcadgfawghaeheheahaeh

    Hustler

  • Awaiting Authorization
  • Joined: 16 May 2008
  • None

#6

Posted 09 May 2009 - 05:40 PM

beatiful mod icon14.gif icon14.gif

oinkoink
  • oinkoink

    Weekend Modder

  • Members
  • Joined: 11 Dec 2008

#7

Posted 09 May 2009 - 06:01 PM

How romantic! inlove.gif

No, seriously that's really awsome...like always! cookie.gif ł

Peace!
o!nko!nk

illdan
  • illdan

    Amazingly stupid

  • Members
  • Joined: 13 Dec 2008

#8

Posted 09 May 2009 - 06:28 PM Edited by Dutchy3010, 09 May 2009 - 06:45 PM.

Really Awesome Mod! Here is the article about it in
just remove "-"

Link deleted, you are very well aware that linking to that site is prohibited. -- Dutchy3010

coin-god
  • coin-god

    High Roller

  • $outh $ide Hoodz
  • Joined: 18 Mar 2007
  • None

#9

Posted 09 May 2009 - 07:07 PM

Nice work icon14.gif

Added to the MisMods list wink.gif

Fabio206
  • Fabio206

    GTA-Expert.it Webmaster

  • Members
  • Joined: 20 Oct 2006

#10

Posted 10 May 2009 - 12:45 PM

Great smile.gif

275646707
  • 275646707

    Player Hater

  • Members
  • Joined: 10 May 2009

#11

Posted 13 May 2009 - 11:00 AM

can 1.02 use it? angry.gif

ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#12

Posted 13 May 2009 - 08:05 PM Edited by ZAZ, 14 May 2009 - 03:51 AM.

QUOTE (275646707 @ May 13 2009, 11:00)
can 1.02 use it? angry.gif

The script requires Alice version 0.30 and higher
I recomand 0.31 I think it should work for 1.0.0.2

Little Psycho
  • Little Psycho

    Unofficial supporter of ms.cooldude mods, lolz

  • BUSTED!
  • Joined: 14 Mar 2009

#13

Posted 15 May 2009 - 10:49 PM

Nice, but ZAZ, please make so useful mods. I dunno, somethin' like property buying etc. It would be awesome to have Majestic hotel or any rich house from Alderney.

ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#14

Posted 16 May 2009 - 03:16 AM

QUOTE (Little Psycho @ May 15 2009, 22:49)
Nice, but ZAZ, please make so useful mods. I dunno, somethin' like property buying etc. It would be awesome to have Majestic hotel or any rich house from Alderney.

Yes, save ability at Majestics. I want it too. It needs time to understand all this new scripts.
The using of particle effects and animations is really simple, same as in SA

Little Psycho
  • Little Psycho

    Unofficial supporter of ms.cooldude mods, lolz

  • BUSTED!
  • Joined: 14 Mar 2009

#15

Posted 17 May 2009 - 12:27 PM

QUOTE (ZAZ @ May 16 2009, 03:16)
QUOTE (Little Psycho @ May 15 2009, 22:49)
Nice, but ZAZ, please make so useful mods. I dunno, somethin' like property buying etc. It would be awesome to have Majestic hotel or any rich house from Alderney.

Yes, save ability at Majestics. I want it too. It needs time to understand all this new scripts.
The using of particle effects and animations is really simple, same as in SA

You now, someone already made script like this, I even used it, but it's for .net scripthook which is outdated and doesn't works at gta iv 1.3 at all.

ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#16

Posted 17 May 2009 - 01:14 PM

QUOTE (Little Psycho @ May 17 2009, 12:27)
QUOTE (ZAZ @ May 16 2009, 03:16)
QUOTE (Little Psycho @ May 15 2009, 22:49)
Nice, but ZAZ, please make so useful mods. I dunno, somethin' like property buying etc. It would be awesome to have Majestic hotel or any rich house from Alderney.

Yes, save ability at Majestics. I want it too. It needs time to understand all this new scripts.
The using of particle effects and animations is really simple, same as in SA

You now, someone already made script like this, I even used it, but it's for .net scripthook which is outdated and doesn't works at gta iv 1.3 at all.

You mean the hubsters Majestics script for NetscriptHook
I can not test it with my 1.0.0.3 version.
As far I know does it make a fading by each gameload and teleports the player into the hotel.
The spawn locations of gameload are fix defined in the main.sco.
I can write a savescript but I can not change the spawn locations.
The main.sco is not editable yet.

Little Psycho
  • Little Psycho

    Unofficial supporter of ms.cooldude mods, lolz

  • BUSTED!
  • Joined: 14 Mar 2009

#17

Posted 17 May 2009 - 02:43 PM

QUOTE (ZAZ @ May 17 2009, 13:14)
QUOTE (Little Psycho @ May 17 2009, 12:27)
QUOTE (ZAZ @ May 16 2009, 03:16)
QUOTE (Little Psycho @ May 15 2009, 22:49)
Nice, but ZAZ, please make so useful mods. I dunno, somethin' like property buying etc. It would be awesome to have Majestic hotel or any rich house from Alderney.

Yes, save ability at Majestics. I want it too. It needs time to understand all this new scripts.
The using of particle effects and animations is really simple, same as in SA

You now, someone already made script like this, I even used it, but it's for .net scripthook which is outdated and doesn't works at gta iv 1.3 at all.

You mean the hubsters Majestics script for NetscriptHook
I can not test it with my 1.0.0.3 version.
As far I know does it make a fading by each gameload and teleports the player into the hotel.
The spawn locations of gameload are fix defined in the main.sco.
I can write a savescript but I can not change the spawn locations.
The main.sco is not editable yet.

SCO files are editable with newest spark IV

ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#18

Posted 17 May 2009 - 03:37 PM

QUOTE (Little Psycho @ May 17 2009, 14:43)
QUOTE (ZAZ @ May 17 2009, 13:14)
QUOTE (Little Psycho @ May 17 2009, 12:27)
QUOTE (ZAZ @ May 16 2009, 03:16)
QUOTE (Little Psycho @ May 15 2009, 22:49)
Nice, but ZAZ, please make so useful mods. I dunno, somethin' like property buying etc. It would be awesome to have Majestic hotel or any rich house from Alderney.

Yes, save ability at Majestics. I want it too. It needs time to understand all this new scripts.
The using of particle effects and animations is really simple, same as in SA

You now, someone already made script like this, I even used it, but it's for .net scripthook which is outdated and doesn't works at gta iv 1.3 at all.

You mean the hubsters Majestics script for NetscriptHook
I can not test it with my 1.0.0.3 version.
As far I know does it make a fading by each gameload and teleports the player into the hotel.
The spawn locations of gameload are fix defined in the main.sco.
I can write a savescript but I can not change the spawn locations.
The main.sco is not editable yet.

SCO files are editable with newest spark IV

Really? With Spark0.6.2 I can only view the script but not edit.

Little Psycho
  • Little Psycho

    Unofficial supporter of ms.cooldude mods, lolz

  • BUSTED!
  • Joined: 14 Mar 2009

#19

Posted 17 May 2009 - 09:13 PM

QUOTE (ZAZ @ May 17 2009, 15:37)
QUOTE (Little Psycho @ May 17 2009, 14:43)
QUOTE (ZAZ @ May 17 2009, 13:14)
QUOTE (Little Psycho @ May 17 2009, 12:27)
QUOTE (ZAZ @ May 16 2009, 03:16)
QUOTE (Little Psycho @ May 15 2009, 22:49)
Nice, but ZAZ, please make so useful mods. I dunno, somethin' like property buying etc. It would be awesome to have Majestic hotel or any rich house from Alderney.

Yes, save ability at Majestics. I want it too. It needs time to understand all this new scripts.
The using of particle effects and animations is really simple, same as in SA

You now, someone already made script like this, I even used it, but it's for .net scripthook which is outdated and doesn't works at gta iv 1.3 at all.

You mean the hubsters Majestics script for NetscriptHook
I can not test it with my 1.0.0.3 version.
As far I know does it make a fading by each gameload and teleports the player into the hotel.
The spawn locations of gameload are fix defined in the main.sco.
I can write a savescript but I can not change the spawn locations.
The main.sco is not editable yet.

SCO files are editable with newest spark IV

Really? With Spark0.6.2 I can only view the script but not edit.

Damn, sorry, mistake. However it's strange it isn't possible to edit it yet, because nothing must be cracked.

olek7881
  • olek7881

    Player Hater

  • Members
  • Joined: 12 May 2009

#20

Posted 15 July 2009 - 09:21 AM

I am from Polish. I know English not for very. I ask you explain me how to install this? I pull off mod and I lightone's cigarette alice gre and game shows that I have the unsuitable version of game. and I updated patch 1.3


--PO POLSKU--
jestem z polski. nie za bardzo umiem angielski. proszę was wytłumaczcie mi jak to zainstalować? ściągam mod i alice odpalam gre i gra pokazuje że mam nieodpowiednią wersję gry. a zaktualizowałem patchem 1.3

ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#21

Posted 16 July 2009 - 06:05 AM

QUOTE (olek7881 @ Jul 15 2009, 09:21)
I am from Polish. I know English not for very. I ask you explain me how to install this? I pull off mod and I lightone's cigarette alice gre and game shows that I have the unsuitable version of game. and I updated patch 1.3


--PO POLSKU--
jestem z polski. nie za bardzo umiem angielski. proszę was wytłumaczcie mi jak to zainstalować? ściągam mod i alice odpalam gre i gra pokazuje że mam nieodpowiednią wersję gry. a zaktualizowałem patchem 1.3

1. first install Alice
How to do and get the files at: www.gtaforums.com/index.php?showtopic=386816
It requires to install an asi loader like xliveless, get it here: www.gtaforums.com/index.php?showtopic=388658

it works on gta4 patchversion 1.0.0.3
(not tested on 1.0.0.4)

2.
copy Fireworks.lua into GTA IV\Alice folder

gtaloversa6o
  • gtaloversa6o

    Im Niko Bellic. Y L0Lz

  • Members
  • Joined: 02 Jan 2008

#22

Posted 19 December 2009 - 06:37 PM Edited by gtaloversa6o, 19 December 2009 - 06:44 PM.

I can't get it to work.My Alice log says this:

18:33:52 | Initialization started
18:33:52 | - Addresses ...Ok
18:33:52 | - Natives loading ...Ok
18:33:52 | - Main hook creating ...Ok
18:33:52 | - Native caller ...Ok
18:33:52 | - Natives preinit ...Ok
18:33:52 | - Natives ...Ok
18:33:52 | Initialization successful
18:34:09 | Main hook installed
18:35:27 | Loading *.ext script plugins ...
18:35:27 | Loading *.lua scripts ...
18:35:27 | Loading lua script "Fireworks.lua" ...loaded
18:35:27 | Loading finished, 1 scripts and plugins loaded
18:35:27 | Lua script executing error. Script "Fireworks.lua", Error "SYNTAX/LOGIC ERROR !!!"

Extra Info:
Game Version :1.0.3.0
ASI Loader: XliveLess (Latest Version)
Alice: (Latest Version)
I also have NET. Scripthook but i dont know if it will affect the mod.

ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#23

Posted 19 December 2009 - 06:51 PM

QUOTE (gtaloversa6o @ Dec 19 2009, 18:37)
I can't get it to work.My Alice log says this:

18:33:52 | Initialization started
18:33:52 | - Addresses ...Ok
18:33:52 | - Natives loading ...Ok
18:33:52 | - Main hook creating ...Ok
18:33:52 | - Native caller ...Ok
18:33:52 | - Natives preinit ...Ok
18:33:52 | - Natives ...Ok
18:33:52 | Initialization successful
18:34:09 | Main hook installed
18:35:27 | Loading *.ext script plugins ...
18:35:27 | Loading *.lua scripts ...
18:35:27 | Loading lua script "Fireworks.lua" ...loaded
18:35:27 | Loading finished, 1 scripts and plugins loaded
18:35:27 | Lua script executing error. Script "Fireworks.lua", Error "SYNTAX/LOGIC ERROR !!!"

Extra Info:
Game Version :1.0.3.0
ASI Loader: XliveLess (Latest Version)
Alice: (Latest Version)
I also have NET. Scripthook but i dont know if it will affect the mod.


actually the fireworks lua script works only with alice version 0.32 for GTAIVpatch 1.0.0.3
it's so sad
it won't work for new alice version 0.9
and it seems not possible to do with alice version 0.9
It have problems with codes which worked on alice 0.32

gtaloversa6o
  • gtaloversa6o

    Im Niko Bellic. Y L0Lz

  • Members
  • Joined: 02 Jan 2008

#24

Posted 19 December 2009 - 06:56 PM

QUOTE (ZAZ @ Dec 19 2009, 18:51)
QUOTE (gtaloversa6o @ Dec 19 2009, 18:37)
I can't get it to work.My Alice log says this:

18:33:52 | Initialization started
18:33:52 |  - Addresses  ...Ok
18:33:52 |  - Natives loading  ...Ok
18:33:52 |  - Main hook creating  ...Ok
18:33:52 |  - Native caller  ...Ok
18:33:52 |  - Natives preinit  ...Ok
18:33:52 |  - Natives  ...Ok
18:33:52 | Initialization successful
18:34:09 | Main hook installed
18:35:27 | Loading *.ext script plugins ...
18:35:27 | Loading *.lua scripts ...
18:35:27 | Loading lua script "Fireworks.lua"  ...loaded
18:35:27 | Loading finished, 1 scripts and plugins loaded
18:35:27 | Lua script executing error. Script "Fireworks.lua", Error "SYNTAX/LOGIC ERROR !!!"

Extra Info:
Game Version :1.0.3.0
ASI Loader: XliveLess (Latest Version)
Alice: (Latest Version)
I also have NET. Scripthook but i dont know if it will affect the mod.


actually the fireworks lua script works only with alice version 0.32 for GTAIVpatch 1.0.0.3
it's so sad
it won't work for new alice version 0.9
and it seems not possible to do with alice version 0.9
It have problems with codes which worked on alice 0.32

Oh well sad.gif . I was planning on using it on christmas along with the snow mod. Thats too bad. Would have been quite nice snowing with fireworsk at night at time square. Try to make it so it works if possible in any way. Looks like a fantastic mod.

ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#25

Posted 19 December 2009 - 07:05 PM

QUOTE (gtaloversa6o @ Dec 19 2009, 18:56)
QUOTE (ZAZ @ Dec 19 2009, 18:51)
QUOTE (gtaloversa6o @ Dec 19 2009, 18:37)
I can't get it to work.My Alice log says this:

18:33:52 | Initialization started
18:33:52 |  - Addresses  ...Ok
18:33:52 |  - Natives loading  ...Ok
18:33:52 |  - Main hook creating  ...Ok
18:33:52 |  - Native caller  ...Ok
18:33:52 |  - Natives preinit  ...Ok
18:33:52 |  - Natives  ...Ok
18:33:52 | Initialization successful
18:34:09 | Main hook installed
18:35:27 | Loading *.ext script plugins ...
18:35:27 | Loading *.lua scripts ...
18:35:27 | Loading lua script "Fireworks.lua"  ...loaded
18:35:27 | Loading finished, 1 scripts and plugins loaded
18:35:27 | Lua script executing error. Script "Fireworks.lua", Error "SYNTAX/LOGIC ERROR !!!"

Extra Info:
Game Version :1.0.3.0
ASI Loader: XliveLess (Latest Version)
Alice: (Latest Version)
I also have NET. Scripthook but i dont know if it will affect the mod.


actually the fireworks lua script works only with alice version 0.32 for GTAIVpatch 1.0.0.3
it's so sad
it won't work for new alice version 0.9
and it seems not possible to do with alice version 0.9
It have problems with codes which worked on alice 0.32

Oh well sad.gif . I was planning on using it on christmas along with the snow mod. Thats too bad. Would have been quite nice snowing with fireworsk at night at time square. Try to make it so it works if possible in any way. Looks like a fantastic mod.

I'm too and maybe I make a more simple and smaller script without rocket
basicly the effects are working just the placement is difficult

Gta Fishhead
  • Gta Fishhead

    Strive to be different

  • Members
  • Joined: 29 Aug 2009

#26

Posted 19 December 2009 - 09:23 PM

Woah, niccce mod ZAZ, could you make this mod for San Andreas biggrin.gif biggrin.gif

ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#27

Posted 22 December 2009 - 04:44 PM Edited by ZAZ, 22 December 2009 - 04:51 PM.

Skyburst coloured Fireworks
place the Skyburst rocket and fire up the sensational coloured Fireworks

**************** update version 22.12.2009

**************** works with alice version 0.9

**************** for GTAIV 5.patch 1.0.0.4


Download GTA4_Fireworks 2010


Update Alice to alice 0.9
get it at: www.gtaforums.com/index.php?showtopic=386816
It contains also asiloader:dsound.dll
alternativ asi loader xliveless: www.gtaforums.com/index.php?showtopic=388658






Skyburst coloured Fireworks
place the Skyburst rocket and fire up the sensational coloured Fireworks

**************** update version 22.12.2009

**************** works with alice version 0.9

**************** for GTAIV 5.patch 1.0.0.4


Download GTA4_Fireworks 2010


Update Alice to alice 0.9
get it at: www.gtaforums.com/index.php?showtopic=386816
It contains also asiloader:dsound.dll
alternativ asi loader xliveless: www.gtaforums.com/index.php?showtopic=388658






Skyburst coloured Fireworks
place the Skyburst rocket and fire up the sensational coloured Fireworks

**************** update version 22.12.2009

**************** works with alice version 0.9

**************** for GTAIV 5.patch 1.0.0.4


Download GTA4_Fireworks 2010


Update Alice to alice 0.9
get it at: www.gtaforums.com/index.php?showtopic=386816
It contains also asiloader:dsound.dll
alternativ asi loader xliveless: www.gtaforums.com/index.php?showtopic=388658






gtaloversa6o
  • gtaloversa6o

    Im Niko Bellic. Y L0Lz

  • Members
  • Joined: 02 Jan 2008

#28

Posted 22 December 2009 - 07:07 PM

To everyone who will try the mod on version 1.0.3.0:


The mod works perfectly. Get the latest Alice.



Thank you ZAZ.
Heres your feedback mate, 10/10 for the mod smile.gif

gorgonut
  • gorgonut

    Snitch

  • Members
  • Joined: 21 Feb 2009

#29

Posted 23 December 2009 - 12:10 AM

Nice mod!Happy one! biggrin.gif Could you make an ini file for the next version, so that we ll be able to adjust the keys? Thanks.

ZAZ
  • ZAZ

    Kernlochbohrer

  • Feroci
  • Joined: 10 Jan 2005
  • European-Union
  • Contribution Award [Mods]
    Helpfulness Awards [Mods]

#30

Posted 23 December 2009 - 09:24 AM Edited by ZAZ, 23 December 2009 - 09:26 AM.

QUOTE (gorgonut @ Dec 23 2009, 00:10)
Nice mod!Happy one! biggrin.gif Could you make an ini file for the next version, so that we ll be able to adjust the keys? Thanks.

you can open the lua file with notepad and change the keynumbers you like

the script includes 3 keypress checks

one for the start, at script end/ 82 = R
CODE
if (IsKeyPressed(82) == 1) then    --key_press R


one to let the rocket blow up ealier/ 82 = R
CODE
if  (LOCATE_OBJECT_3D(objector.a, x.b, y.b, z.b, itof(2.0), itof(2.0), itof(2.0), 0) == 1) or (IsKeyPressed(82) == 1) then


and one to change camera view/ 67 = C
CODE
if (IsKeyPressed(67) == 1) then

it's really easy to change the key_press number, you should just know the virtual key code list.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users