Quantcast

Jump to content

» «
Photo

How to use -memrestrict to fix stuttering

414 replies to this topic
evanwier
  • evanwier

    Player Hater

  • Members
  • Joined: 02 Apr 2009

#61

Posted 05 April 2009 - 09:06 PM

QUOTE (LukeDuke3 @ Mar 28 2009, 19:38)
This game is amazing. I just found a way how to make game run allmost perfect smooth.. fresh install xp sp3 and gta 4
pc is: gtx 260, q6600, 4g ram
screenshot settings suicidal.gif

user posted image

The point is... you have a quad core and a gtx 260 and have to run on all-low to get it to 'almost' run smooth. I bet you can run crysis a hell of a lot better than this, and it works a world better. There seriously needs to be a patch instead of command lines

CHILLI
  • CHILLI

    Playa

  • Members
  • Joined: 25 Nov 2007

#62

Posted 05 April 2009 - 09:49 PM

sorry if this have been answered already. but how to use these commandline things on the steam verson? I've tried a few in the properties screen > set launch options, but none have seemed to work. for another game I have the commandline looks like following: +r_hunkalloclightmaps 0
should I use + instead of - in the line? please answer ASAP.

DaveC2003
  • DaveC2003

    DC

  • Members
  • Joined: 15 Jan 2009

#63

Posted 05 April 2009 - 10:13 PM

QUOTE (Rockstar Toronto @ Mar 23 2009, 16:47)
If you are experiencing frame speed fluctuations, please update to the latest video drivers, then use the -memrestrict commandline. Please do not use any other commandlines as they may override the effects of this one. Start at the lowest number based on your texture setting (ie. try them one at a time) You can try to increase the number until you notice stuttering again.

-memrestrict 188743680 LOW TEXTURES (256M Video Cards)
-memrestrict 209715200
-memrestrict 230686720
-memrestrict 262144000 MED TEXTURES (512M Video Cards)
-memrestrict 293601280
-memrestrict 314572800
-memrestrict 629145600 HIGH TEXTURES (1Gig+ Video Cards)
-memrestrict 650117120
-memrestrict 681574400

If you still notice stuttering with the lowest number, there may be a seperate issue with your system configuration.

Also update the BIOS, I did this and the game runs much faster.

GameGuy360
  • GameGuy360

    Player Hater

  • Members
  • Joined: 05 Apr 2009

#64

Posted 05 April 2009 - 10:36 PM

this helped a lot, thanks. i would go from 15-40fps randomly without this. now with -memrestrict 293601280 my 1gb 9800gt (medium settings) i get 30-40fps.

dafour
  • dafour

    Car Crasher

  • Members
  • Joined: 02 Dec 2008

#65

Posted 06 April 2009 - 10:52 AM Edited by dafour, 14 April 2009 - 09:51 AM.

I've been playing IV since it came out without any tweaks and such..After 1.0.3.0 it really ran like sh*t...
added this -memrestrict 262144000 to the commandline and it runs smooth now !!! ty toronto

PharmacisT-
  • PharmacisT-

    Snitch

  • Members
  • Joined: 11 Dec 2008

#66

Posted 06 April 2009 - 11:04 AM

Help me R*,
Is this for Stuttering after a time playing or stuttering while drive in a car or what kind of stutters?

truehighroller
  • truehighroller

    Hustler

  • Members
  • Joined: 14 Dec 2008

#67

Posted 06 April 2009 - 11:12 AM

QUOTE (PharmacisT- @ Apr 6 2009, 06:04)
Help me R*,
Is this for Stuttering after a time playing or stuttering while drive in a car or what kind of stutters?

This is to jerry rig the whole damn game. lol.gif lol.gif icon13.gif icon13.gif

Sorry had to say that, Just stutters in general.

ThatsCool
  • ThatsCool

    Mark Chump

  • Members
  • Joined: 11 Dec 2008

#68

Posted 07 April 2009 - 04:54 PM

it doenst help tried all commands. its already stuttering after some time

CHILLI
  • CHILLI

    Playa

  • Members
  • Joined: 25 Nov 2007

#69

Posted 08 April 2009 - 02:10 AM

people say that the Steam version cant use commandline things are wrong. just replace the - with a + so a code could be for example: +nolagline or +lagspike01. and btw, it's in the launch command thingy and not in that commandline.txt file since what I know it doesnt work. but you could always try ^^

thr0tt
  • thr0tt

    Player Hater

  • Members
  • Joined: 14 Dec 2008

#70

Posted 11 April 2009 - 07:20 PM

QUOTE (Rockstar Toronto @ Mar 23 2009, 16:47)

If you still notice stuttering with the lowest number, there may be a seperate issue with your system configuration.

Nope your game is faulty. None of the values fix the issue, I do get a little delay on when the fault occurs when I change the values, didn't get the issue with 1.0.2, this patch appeared to run better but after 2-5 mins then the game grinds to a halt, surely you have seen this when testing ?

moonlitmagik
  • moonlitmagik

    Roman's Secretary

  • Members
  • Joined: 12 Apr 2009

#71

Posted 12 April 2009 - 12:32 AM

Hey everyone, ATI has a new driver out, Catalyst 9.4!!!

Just released a few days ago!

hoolio22g
  • hoolio22g

    Rat

  • Members
  • Joined: 05 Mar 2009

#72

Posted 12 April 2009 - 12:51 AM

QUOTE (thr0tt @ Apr 11 2009, 19:20)
QUOTE (Rockstar Toronto @ Mar 23 2009, 16:47)

If you still notice stuttering with the lowest number, there may be a seperate issue with your system configuration.

Nope your game is faulty. None of the values fix the issue, I do get a little delay on when the fault occurs when I change the values, didn't get the issue with 1.0.2, this patch appeared to run better but after 2-5 mins then the game grinds to a halt, surely you have seen this when testing ?

Give up myself,but yea excat same question from me mr rockstar.Nothing wrong in my system,its only a couple months old all new drivers,built it from scratch myself for playing high-end games.Which it does apart from....yup you guessed it GTAIV.

So any word when ya gonna fix it,or is there a lotta faulty systems out there???

polosistealth
  • polosistealth

    grandtheftauto.RO

  • Members
  • Joined: 15 Jul 2008
  • Romania

#73

Posted 12 April 2009 - 11:27 AM

i have a GTX 260 with 896mb , 3GB DDR2 800mhz , E8400 3.6ghz
with -memrestrict 629145600 i get after 30minutes stuterings....
help cryani.gif

pigs18
  • pigs18

    Player Hater

  • Members
  • Joined: 17 Mar 2009

#74

Posted 13 April 2009 - 02:20 PM

Thx! biggrin.gif It's working for me pretty good!

Stuttering is almost gone!
It's very helpful for me!


My computer Spec
Intel E2160 [email protected]
ATI HD3850 512MB

Using option in GTA4
Texture Medium
Reflection high
water high
Shadow high
Render Medium

22/10/26/0

Rockstar Toronto
  • Rockstar Toronto

    Rockstar Games Technical Support

  • Members
  • Joined: 04 Dec 2008
  • None

#75

Posted 13 April 2009 - 02:59 PM

QUOTE (polosistealth @ Apr 12 2009, 06:27)
i have a GTX 260 with 896mb , 3GB DDR2 800mhz , E8400 3.6ghz
with -memrestrict 629145600 i get after 30minutes stuterings....
help cryani.gif

Your supposed to start with a low number and then increase until you notice a problem. As well, you should try Medium textures.

Nick the Newb
  • Nick the Newb

    Snitch

  • Members
  • Joined: 23 Jan 2009

#76

Posted 14 April 2009 - 02:24 AM

Why is this post stickied? Why not sticky the hundreds of other solved stuttering problems?

This is just a generic method. Restrict memory, yeah great. What about the true failures of GTA 4 that cause the game to stutter?

This thread= blame stuttering on our video cards. Rarely fixes ANY stuttering for MANY users, except those who has BAD graphic cards (meaning LOTS of mem leak)

polosistealth
  • polosistealth

    grandtheftauto.RO

  • Members
  • Joined: 15 Jul 2008
  • Romania

#77

Posted 14 April 2009 - 04:32 PM

setup: 1440x900x75hz
textures high

works with -memrestrict 650117120
smile.gif

GEXY1
  • GEXY1

    Player Hater

  • Members
  • Joined: 02 Sep 2004

#78

Posted 15 April 2009 - 09:17 AM Edited by GEXY1, 15 April 2009 - 09:23 AM.

So here's what I have:
Gigabyte GA-MA790GP-UD4H
Phenom II 940 BE @3.7 Ghz
2X2 gig Kingston HyperX @1066
Sapphire Radeon 4870 X2
SB XF-I Extreme 7.1 PCI-E
Windows Vista Ultimate 32-bit

Here is my settings:
Vid. mode- 1152x864 (85 hz) My monitor sucks!
Aspect- 4:3
Texture- High
Reflect- High
Water- Very High
Shadows- Very High
Texture Filter- Highest
View Distance- 39
Detail Distance- 100
Vehicle Density- 100
Shadow Density- 8
Def.- On
Vsync- Off
Resource Usage- 1001/1015 mb

I also have the "All Controllers WORKING!!!" fix because I hated my Xbox 360 controller and wanted to use my Logitech Cordless Rumblepad.

I've tried all of the so called "memrestrict" and the one that works the best is -memrestrict 629145600.
I still get stuttering happening. Not as bad as it was without the memrestrict but it is definately not as good with 1.0.3.0 installed. Those setting made the game play almost perfect with version 1.0.2.0 so I should very well be able to play it properly with the new patch installed right? WRONG! Now I CBDT about 30 minutes into a stutering pile of a game. The error reads:

GTA IV FATAL ERROR: Out of video memory-
Please reboot your system
667352640 731217920

I never had a crash AT ALL with version 1.0.2.0. I have 2 gigs of video memory on this graphics card. How is it possible that I'm out of video memory? Up on my Resource Usage it says 1001/1015 mb. Is there a problem there? Shouldn't it read 1001/2000 mb or something higher? I'm just guessing here. I really don't know. That's why I'm asking the question.

Could someone at R* please help me? I would really appreciate it!

YoungGun
  • YoungGun

    Thug

  • Members
  • Joined: 04 Jun 2007

#79

Posted 17 April 2009 - 03:20 AM

my experience..
any of the 182 drivers cause stuttering..
went back to 181.22 drivers and games seems to run best with these.

zBobG
  • zBobG

    Mark Chump

  • Members
  • Joined: 04 Dec 2008

#80

Posted 17 April 2009 - 09:29 AM

QUOTE (GEXY1 @ Apr 15 2009, 09:17)
So here's what I have:
Sapphire Radeon 4870 X2

I have 2 gigs of video memory on this graphics card. How is it possible that I'm out of video memory? Up on my Resource Usage it says 1001/1015 mb. Is there a problem there? Shouldn't it read 1001/2000 mb or something higher?

If you had read enough threads in this forum or if you had used the search function you might have already had your answer.

I'll repeat it: You have a dual core GPU, it has 2Gb of memory installed, 1Gb is installed for each GPU. Windows or your game will only ever report that you have 1Gb of memory, that's because the memory is mirrored to each GPU which means that everything that is seen by one GPU is seen by the other GPU, the contents of each 1Gb is identical. That's how dual core GPUs work, you cannot change that behavior. Even if you turn off one GPU you will still only see the 1Gb that is assigned to the active GPU, you cannot assign all 2Gb to one GPU.

The only advantage to a dual core GPU is that it can run in SLI mode which actually does not work very good for GTA4 if you can get it to run at all. SLI mode can somewhat increase FPS and will permit larger framebuffer sizes (display resolution) but it does little or nothing for any application that is not optimized to effectively use SLI, many users have reported that GTA4 does not effectively use SLI.

Regarding your out of memory error: You must be exceeding the recommended memory restriction. The only solution to that is to turn down some of your graphics settings. Note that this out of memory error seems to be especially prevalent on ATI videocards and may be related to the particular video driver being used. So... Maybe try a different video driver, there are several threads with info about the various available ATI drivers.

GEXY1
  • GEXY1

    Player Hater

  • Members
  • Joined: 02 Sep 2004

#81

Posted 17 April 2009 - 10:11 AM Edited by GEXY1, 17 April 2009 - 10:16 AM.

I call shenanigans on that because it only happenned since 1.0.3.0 was installed. I NEVER had a problem with the game at these setting before 1.0.3.0. How bout R* just admit that the update broke a bunch of systems and appologize. At least then they could get some of my respect back. Oh right, they don't want my respect, they want my money. Well, they already got that so whats left? Let's just hope that R* does a better job than GFWL ever did. What a joke that thing is!

I've already reverted back to 1.0.2.0 and have had no issues since. I'll just stick with that solution for now. I'm not playing MP anyway. Why would I? GFWL? Really? That was just the first of R*'s mistakes!

Hey zBobG, thanks for answering my question. It was helpfull. I didn't know how to actually put it when I was using the search so it got frustrating when I couldn't find the answer. I never meant for you to repeat yourself. I hate it when I have to!

TheHarvesteR
  • TheHarvesteR

    Player Hater

  • Members
  • Joined: 20 Dec 2006

#82

Posted 18 April 2009 - 12:00 PM

GFWL is just M$'s way of implying everyone should be playing on an XboX instead of the PC... they can go to hell for all i care...

other than that, I hear the latest Nvidia drivers might cause stutters, and reverting back to version 181.22 would fix it... I'm downloading them now to see if it makes a difference...

although the stuttering doesn't seem to be GPU-related... it appears to be some kind of RAM problem... the way the stutters are building up after a few minutes of play... it seems the memory isn't clearing as it should... Also, restarting the game seems to clear the stutters for a while, then it mounts up again... feels an awful lot like RAM trouble

Well, let's see what happens with the driver...

Cheers

TheHarvesteR
  • TheHarvesteR

    Player Hater

  • Members
  • Joined: 20 Dec 2006

#83

Posted 18 April 2009 - 09:30 PM Edited by TheHarvesteR, 18 April 2009 - 09:36 PM.

Ok, just to follow up on the driver issue...

I downgraded from version 182.50 (latest) to 181.22 (january 2009)...

Next I stress tested the game for over an hour (meaning I played nonstop for that length of time tounge2.gif )
So far, NO STUTTERS... AT ALL

Performance held stable during the whole session... frame rate was high, and not even the rain, which usually lags my system, made a dent smile.gif

Worked for me, might work for others... let me know if it works for you


Here are specs, if you're interested:

GTA IV 1.0.3
Win XP 64 bit
Geforce 8800GTX 768MB, running @ 3072x768 in-game resolution (triple screen)
Intel Core i7 920 CPU
6GB DDR3 1600mhz RAM
Intel DX58SO Mobo


Because of the high resolution, I usually leave my graphic settings at medium-ish... textures, water and reflections are medium, shadows are high, sliders set at around 25%. definition OFF, Vsync ON
Running this rig at a more normal resolution might give enough headroom to push the sliders much farther forward, but playing on 3 screens is well worth it wink.gif

Cheers

StepanKing7
  • StepanKing7

    °•Respect•°

  • Members
  • Joined: 23 Sep 2007

#84

Posted 18 April 2009 - 11:52 PM

Is there any fix for something like this?


The game runs well, at 20 FPS, after 10mins playing, it starts to freeze at 1 fps, and go up, for 10 secs, freeze again and go on, and so on and so on... Just like in the video, the guy who recorded that got the same problem I do.

DAV1D90
  • DAV1D90

    Snitch

  • Members
  • Joined: 03 Dec 2008

#85

Posted 19 April 2009 - 05:45 AM Edited by DAV1D90, 19 April 2009 - 10:18 AM.

i have same problem, i have 9600GTit runs all time above 30FPS, but this stuttering issue make me sick. Maybe we need more RAM or faster CPU.
QUOTE
Statistics
Average FPS: 53.80
Duration: 37.14 sec
CPU Usage: 91%
System memory usage: 77%
Video memory usage: 76%

Graphics Settings
Video Mode: 1280 x 720 (75 Hz)
Texture Quality: Medium
Texture Filter Quality: Medium
View Distance: 22
Detail Distance: 10

Hardware
Systém Microsoft Windows XP Professional
Service Pack 3
Video Adapter: NVIDIA GeForce 9600 GT
Video Driver version: 178.24
Audio Adapter: Realtek HD Audio output
Procesor Intel Pentium III Xeon


2GB RAM
C2D E8200 2,66GHz

before i had 8600GTS and with same setting i ran this game on 1024x768, FPS were bad, but I had not stuttering issues. So WHY?

DAV1D90
  • DAV1D90

    Snitch

  • Members
  • Joined: 03 Dec 2008

#86

Posted 19 April 2009 - 04:20 PM Edited by DAV1D90, 19 April 2009 - 04:23 PM.

I updated my ForceWare to newest one, but it run even worse. It stutters even whit low textures and lowest resolution. I am starting to think that its because of patch 1.0.3. Before with 8600GTS i had only 1.0.2. (and 1.0.0, 1.0.1) and i never noticed this problem So please fix it!

I bought that Game on 3.12.2008, I have played it so much time with crap FPS on 8600GTS, now I ve bought new graphic card and it runs worse.

Ohhh I forgot to say that it stutters only when I am driving around the city. When I walk, or playing mission on one location it runs great. Before I had problem with FPS in rain or evening.

cultofnone
  • cultofnone

    Player Hater

  • Members
  • Joined: 25 Apr 2009

#87

Posted 25 April 2009 - 04:25 AM

QUOTE (Krycek @ Mar 25 2009, 00:27)
K guys I hope this will help you,the memrestrict didn't do sh*t in my case,I had terrible stutter issues after 20-30 minutes with Gta IV 1.2 and the same story with 1.3,what it worked for me was to downgrade my drivers to 181.22 and it fixed all the stuttering in my case.I can play for hours without any slowdowns now and the game works great with the latest patch.
So if you have an Nvidia card and 182.08 drivers try to downgrade them,181.22 worked the best for me.
It's a temporarily solution but right now although Rockstar is to blame for this I also think Nvidia has a part of the blame.

Patch 1.0.3 introduced stuttering at autoconfigured settings on my rig (8800 GTS 512, E6750, 4GB DDR2), with Nvidia drivers 182.50. Reverting to 181.22 fixed it, with no stuttering at all now, so thanks for the tip off Krycek!

DAV1D90
  • DAV1D90

    Snitch

  • Members
  • Joined: 03 Dec 2008

#88

Posted 28 April 2009 - 03:04 PM

i have still stuttering because of patch 1.0.3. hope you are working on patch 1.0.4. R* Toronto...

my PC
C2D E8200
2GB DDR2
9600GT 512MB

Rockstar Toronto
  • Rockstar Toronto

    Rockstar Games Technical Support

  • Members
  • Joined: 04 Dec 2008
  • None

#89

Posted 29 April 2009 - 02:40 PM

QUOTE (DAV1D90 @ Apr 28 2009, 10:04)
i have still stuttering because of patch 1.0.3. hope you are working on patch 1.0.4. R* Toronto...

my PC
C2D E8200
2GB DDR2
9600GT 512MB

For XP use this driver:

http://www.nzone.com..._downloads.html

DAV1D90
  • DAV1D90

    Snitch

  • Members
  • Joined: 03 Dec 2008

#90

Posted 29 April 2009 - 06:04 PM

Thanks. It runs much better now.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users