Quantcast

Jump to content

» «
Photo

How to use -memrestrict to fix stuttering

419 replies to this topic
Rockstar Toronto
  • Rockstar Toronto

    Rockstar Games Technical Support

  • Members
  • Joined: 04 Dec 2008
  • None

#1

Posted 23 March 2009 - 04:47 PM

If you are experiencing frame speed fluctuations, please update to the latest video drivers, then use the -memrestrict commandline. Please do not use any other commandlines as they may override the effects of this one. Start at the lowest number based on your texture setting (ie. try them one at a time) You can try to increase the number until you notice stuttering again.

-memrestrict 188743680 LOW TEXTURES (256M Video Cards)
-memrestrict 209715200
-memrestrict 230686720
-memrestrict 262144000 MED TEXTURES (512M Video Cards)
-memrestrict 293601280
-memrestrict 314572800
-memrestrict 629145600 HIGH TEXTURES (1Gig+ Video Cards)
-memrestrict 650117120
-memrestrict 681574400

If you still notice stuttering with the lowest number, there may be a seperate issue with your system configuration.

FlyFR
  • FlyFR

    Player Hater

  • Members
  • Joined: 27 Jan 2009

#2

Posted 23 March 2009 - 06:02 PM

yessss
it's OK for me

thank you

Mazda6
  • Mazda6

    Crackhead

  • Members
  • Joined: 12 Dec 2008

#3

Posted 23 March 2009 - 06:18 PM

Sorry. I can't understand. Why is it propose limits of memory if IV should to use all system resources for performance increase? dozingoff.gif

ifoxhound
  • ifoxhound

    Player Hater

  • Members
  • Joined: 23 Mar 2009

#4

Posted 23 March 2009 - 07:25 PM

I've tried that - doesn't work even with the lowest number. To be 100% clear - the stuttering has appeared a little bit later than usual but still ended up freezing my system and hard reboot. With the 1020 patch everything went smooth.

I've tried to reinstall Windows, updated all the drivers, I've even flashed my MB BIOS to the latest version. Nothing helped.
I don't know what else I could do to be able to play this game properly.. Any other ideas?

My PC specs: C2D E8400, ATi HD4850 512MB DDR3, 2GB DDR2 RAM 1066MHZ, WinXP SP3

Thanks in advance!

Rockstar Toronto
  • Rockstar Toronto

    Rockstar Games Technical Support

  • Members
  • Joined: 04 Dec 2008
  • None

#5

Posted 23 March 2009 - 07:56 PM

QUOTE (ifoxhound @ Mar 23 2009, 14:25)
I've tried that - doesn't work even with the lowest number. To be 100% clear - the stuttering has appeared a little bit later than usual but still ended up freezing my system and hard reboot. With the 1020 patch everything went smooth.

I've tried to reinstall Windows, updated all the drivers, I've even flashed my MB BIOS to the latest version. Nothing helped.
I don't know what else I could do to be able to play this game properly.. Any other ideas?

My PC specs: C2D E8400, ATi HD4850 512MB DDR3, 2GB DDR2 RAM 1066MHZ, WinXP SP3

Thanks in advance!

Which ATi driver are you using?

ifoxhound
  • ifoxhound

    Player Hater

  • Members
  • Joined: 23 Mar 2009

#6

Posted 23 March 2009 - 08:00 PM

QUOTE (kvic @ Mar 23 2009, 19:48)
im afraid to install the patch i tried it once and had to reinstall the game ,is it possible to revert back to the 2nd patch without reinstalling it takes so dam long to install and everytime it does those checks i get nervous with my luck it will fail.

I've been forced to revert to the second patch. I've downgraded the patch without having to reinstal the game and it works okay for me so far.. However, I'm missing all the various objects in the game again plus those texture popups annoy me a little bit.

Waiting for some other solutions to make the latest patch running stable on my rig...

ifoxhound
  • ifoxhound

    Player Hater

  • Members
  • Joined: 23 Mar 2009

#7

Posted 23 March 2009 - 08:02 PM

QUOTE (Rockstar Toronto @ Mar 23 2009, 19:56)
QUOTE (ifoxhound @ Mar 23 2009, 14:25)
I've tried that - doesn't work even with the lowest number. To be 100% clear - the stuttering has appeared a little bit later than usual but still ended up freezing my system and hard reboot. With the 1020 patch everything went smooth.

I've tried to reinstall Windows, updated all the drivers, I've even flashed my MB BIOS to the latest version. Nothing helped.
I don't know what else I could do to be able to play this game properly.. Any other ideas?

My PC specs: C2D E8400, ATi HD4850 512MB DDR3, 2GB DDR2 RAM 1066MHZ, WinXP SP3

Thanks in advance!

Which ATi driver are you using?

I'm currently running on 9.3 as you advised but I've also tried 9.2 and 8.12.
Neither of them helped.

Rockstar Toronto
  • Rockstar Toronto

    Rockstar Games Technical Support

  • Members
  • Joined: 04 Dec 2008
  • None

#8

Posted 23 March 2009 - 08:06 PM

What settings are you trying to use? Are you using any other command lines?

ifoxhound
  • ifoxhound

    Player Hater

  • Members
  • Joined: 23 Mar 2009

#9

Posted 23 March 2009 - 08:11 PM

QUOTE (Rockstar Toronto @ Mar 23 2009, 20:06)
What settings are you trying to use? Are you using any other command lines?

Nope, just the single line from your post. Tried with and without the commandline file.
The video settings in the game is all auto setup. Meaning everything in green. I can go and look up the details if you are interested.

Rockstar Toronto
  • Rockstar Toronto

    Rockstar Games Technical Support

  • Members
  • Joined: 04 Dec 2008
  • None

#10

Posted 23 March 2009 - 08:23 PM

Are you using medium textures?

ifoxhound
  • ifoxhound

    Player Hater

  • Members
  • Joined: 23 Mar 2009

#11

Posted 23 March 2009 - 08:28 PM

QUOTE (Rockstar Toronto @ Mar 23 2009, 20:23)
Are you using medium textures?

Yes. The command line I've been trying is the following one:

-memrestrict 262144000 (lowest value for medium textures)

Rockstar Toronto
  • Rockstar Toronto

    Rockstar Games Technical Support

  • Members
  • Joined: 04 Dec 2008
  • None

#12

Posted 23 March 2009 - 08:30 PM

Try going lower.

ifoxhound
  • ifoxhound

    Player Hater

  • Members
  • Joined: 23 Mar 2009

#13

Posted 23 March 2009 - 08:54 PM

QUOTE (Rockstar Toronto @ Mar 23 2009, 20:30)
Try going lower.

Okay! I was not sure if I can combine the lower values with medium textures because the game doesn't actually allow me to change the textures to low. I've now played for about 10 mins with the lowest memrestrict value and the game is stable so far. It actually does the texture popups in distance like after the second patch again but at least I've got the world objects back smile.gif

I will be testing the game longer and will let you know if it stays stable.

Thank you very much for your help and time so far!

Looks like the ATi card users are experiencing this issue more often than the NVIDIA folks..

[VcG]Adam
  • [VcG]Adam

    Crackhead

  • Members
  • Joined: 08 Jun 2008

#14

Posted 23 March 2009 - 09:08 PM

I know this sounds like its in the wrong topic but why is it i now have to the disc in again and cant use any performance optimizations,i think to fix this multiplayer problem have more dev's online and this wouldn't happen,once again,thanks for patch 1.0.3.0 i will certainly try this fix.

eXs-jack
  • eXs-jack

    Player Hater

  • Members
  • Joined: 21 Mar 2009

#15

Posted 23 March 2009 - 09:09 PM Edited by eXs-jack, 23 March 2009 - 09:11 PM.

I was using the ATI catalyst 8.12 drivers and was experiencing the stuttering/memory leak problem, so i followed your advice, Rocktar Toronto. I put the follwing code in commandline.txt:

QUOTE ("Rockstar Toronto")
-memrestrict 262144000


The game was running in a more stable manner but with occasional jerkiness and after an hour or so the game did eventually freeze up as i tried to car-jack someone.

So i followed the rest of your advice and installed, after sweeping my computer of old drivers, the most up-to-date ATI drivers - 9.3.

I launched the game again and it started playing fine, but after a very short while, 5 minutes or so, it began to freeze up for intervals of upto 30seconds, textures and world objects began to disappear and the radio stations started to cut to static. However it didn't completely freeze up, i could wait out each lock-up and did finally exit the game, without the need to reboot my whole system.

It does seem that this problem is related to the ATI cards only - I'm yet to see an Nvidia user complain of this particular problem since the 1.0.3.0 update - yet i didn't suffer from this problem before the update. Anyway, I'll try lowering the memrestrict value later on and see where that gets me.

Captain_Obvis456
  • Captain_Obvis456

    you're about to be inadequate

  • Members
  • Joined: 22 Nov 2008

#16

Posted 23 March 2009 - 10:26 PM

Can you go into more detail as to how to use the memrestrict commandlines? I've never had to do use these before.
I've had the game since it came out and never had any issues with the game until this latest patch. The game ran great before. I'm using the 9.3 drivers and here are the rest of my specs.
Q9550
Gygabyte P45 Mobo
2GB RAM
3870 Sapphire Radeon
Windows XP
BTW since this patch I can play a little and I really like not seeing anyone cheating in MP. If I can get this sorted out it will make MP so much better. And I play a lot.

Rockstar Toronto
  • Rockstar Toronto

    Rockstar Games Technical Support

  • Members
  • Joined: 04 Dec 2008
  • None

#17

Posted 23 March 2009 - 10:49 PM

Create a .txt file in the root directory of the game (C:\Program files\Rockstar Games\Grand Theft Auto IV) called "commandline". Within this file type

-memrestrict 188743680

and save. When you run the game by pressing the "PLAY" button in RGSC the command line will be read. With this number you should notice no stuttering but you might notice some texture popping. Quit the game, then try the next number up in the sequence. Continue raising the number until you see stuttering again, and then go back to the number prior to seeing any stuttering. The value you use will be different than anyone else based on your hardware setup, video driver, and personal tolerance for texture popping/stuttering.

eXs-jack
  • eXs-jack

    Player Hater

  • Members
  • Joined: 21 Mar 2009

#18

Posted 23 March 2009 - 11:02 PM

-memrestrict 230686720

this value seems to be working fine for me and my 512MB card. i notice more textures changing than i used to but at least it's playable now. Maybe in the near future there'll be either a GTA or an ATI-driver update to remove the need for the memrestrict command.

thanks a lot though.

sallino
  • sallino

    Crackhead

  • Members
  • Joined: 19 Dec 2008

#19

Posted 24 March 2009 - 12:06 AM

I will try this solution thank you.

Indi
  • Indi

    "Party's over, kid!"

  • Andolini Mafia Family
  • Joined: 22 Nov 2008
  • None

#20

Posted 24 March 2009 - 12:10 AM Edited by Indi., 24 March 2009 - 12:20 AM.

R*, is it a must you have to upgrade to the new drivers? The 185.20 are the best for me and I really don't want to lose FPS

Edit: Never mind, tried the command line, can't f*cking beleive it, it worked. It worked, happy.gif thank you R* my game is finally playable without that horrible stuttering thanks!

zBobG
  • zBobG

    Mark Chump

  • Members
  • Joined: 04 Dec 2008

#21

Posted 24 March 2009 - 01:06 AM Edited by zBobG, 24 March 2009 - 01:18 AM.

XP SP3 + GTA4 v1.0.3.0 + no Mods at the moment
All settings medium, no reflections, shadows off or on doesn't matter. Does not exceed recommended resource use.

Using the highest 512Mb setting (-memrestrict 314572800) the game runs fine for about one hour or two, then it begins to stall for several seconds at a time. About one half hour after stalling begins the game becomes a slideshow. I can usually quit the game without crashing, restart it and continue where I left off but of course this behavior completely kills multiplayer. In single player mode using alt-tab sometimes helps but usually only for a few minutes more gametime, only useful when it is desirable to finish a mission.

It's just my opinion that the problem is not a memory leak (by proper definition) but is rather a memory fragmentation problem or more specifically a heap fragmentation problem. I've never trusted the C++ memory manager as it is implemented in most common compilers for x86 code, it is commonly the source of any number of bugs and errors. As evidence of this I need only mention Microsoft Patch Tuesdays.

cpu: INTEL C2Q6600 @ 3.20 GHz
ram: 4GB OCZ DDR2 @ 1067MHz
gpu: BFG 9800 GTX-OC 512Mb @ 1680x1050, 60Hz
m-b: GIGABYTE GA-P965-DS3

sallino
  • sallino

    Crackhead

  • Members
  • Joined: 19 Dec 2008

#22

Posted 24 March 2009 - 01:42 AM

Tried now, works a bit. But didn't resolve the bug with the shadows off. Everytime I put off shadows the game start to stutters... heavy stuttering
Anyway I lost many frames since the new patch

ionC2
  • ionC2

    Player Hater

  • Members
  • Joined: 19 Feb 2008

#23

Posted 24 March 2009 - 02:36 AM

Still becomes jerky. I'll be downgrading to 1.0.2.0.

ifoxhound
  • ifoxhound

    Player Hater

  • Members
  • Joined: 23 Mar 2009

#24

Posted 24 March 2009 - 06:50 AM

QUOTE (eXs-jack @ Mar 23 2009, 23:02)
-memrestrict 230686720

this value seems to be working fine for me and my 512MB card. i notice more textures changing than i used to but at least it's playable now. Maybe in the near future there'll be either a GTA or an ATI-driver update to remove the need for the memrestrict command.

thanks a lot though.

Yes, I can confirm the -memrestrict 230686720 is the highest possible value before the game starts freezing again.

ifoxhound
  • ifoxhound

    Player Hater

  • Members
  • Joined: 23 Mar 2009

#25

Posted 24 March 2009 - 08:12 AM

QUOTE (ifoxhound @ Mar 24 2009, 06:50)
QUOTE (eXs-jack @ Mar 23 2009, 23:02)
-memrestrict 230686720

this value seems to be working fine for me and my 512MB card. i notice more textures changing than i used to but at least it's playable now. Maybe in the near future there'll be either a GTA or an ATI-driver update to remove the need for the memrestrict command.

thanks a lot though.

Yes, I can confirm the -memrestrict 230686720 is the highest possible value before the game starts freezing again.

Well, need to correct myself... after about an hour of playing, the game has frozen again.. It just happend all of the sudden. No stuttering whatsoever before the crash. The textures have suddenly dissapeared and the game just died.

Guess I need to lower the value a little bit more again..

ShamelessPie
  • ShamelessPie

    Secret Agent Pie!

  • Members
  • Joined: 09 Jan 2009

#26

Posted 24 March 2009 - 08:46 AM Edited by ShamelessPie, 24 March 2009 - 09:29 AM.

I've used the first line for low textures -memrestrict 188743680. It still dies.

I can play for 30 minutes to an hour in singleplayer
0-10 minutes in multiplayer.

Runs fine then suddenly frames drop to 0. The last time I got an error when it happened during multiplayer. SMPA50.

Windows XP SP3
AMD Athlong 64 X2 2.2ghz @ 2.8ghz stable.
2GB DDR2 800 (pc2600)
nVidia 8600GT PCI-E 256mb latest drivers.
30GB free HDD space.
GTA IV patched to 1.0.3.0 (duh)

Used to work on medium settings in previous versions of GTA IV.

Don't know what else to try. It's kind of annoying.

EDIT: That's it. I'm done. It's not even playable now. You can have this pile of crap back.

Xenolah
  • Xenolah

    Player Hater

  • Members
  • Joined: 24 Mar 2009

#27

Posted 24 March 2009 - 08:52 AM Edited by Xenolah, 24 March 2009 - 08:55 AM.

I'm having this stutter issue (after around 5 minutes). Game runs nice, then all of a sudden it starts to stutter heavily. Memrestrict command didn't help. The game was fine before the 1.0.3.0 patch.

Video Mode: 1680x1050
Texture: Med
Reflection Res: Med
Water: Med
Shadow: Med
Texture Filter: High

View Distance: 1
Detail Distance 1
Vehicle Density: 26
Shadow Density: 0

Definition: On
VSync: Off

Specs:
Q6600 @ 2.67ghz
HD3870 512mb
2GB OCZ Ram
Windows XP SP3
Catalyst 9.3

Vichello
  • Vichello

    00001110101011101

  • Members
  • Joined: 23 Mar 2009

#28

Posted 24 March 2009 - 09:14 AM

What do you guys suggest for a 8800GTS 640 VRAM ?

_CP_
  • _CP_

    Group: Vice City Stories team

  • Members
  • Joined: 27 Dec 2007
  • Poland

#29

Posted 24 March 2009 - 04:17 PM Edited by City_Poke912, 24 March 2009 - 04:23 PM.

To R* Toronto

This can help with textures?

What -memrestrict will be the best for my computer?

Intel Pentium 4 2,40Ghz, ATI Radeon X1650 512MB, 1280MB RAM GoodRAM.

PS. Why I can't login to RGSC? (Could not Connect to Rockstar Games Social Club. Please check your network connection)

Rockstar Toronto
  • Rockstar Toronto

    Rockstar Games Technical Support

  • Members
  • Joined: 04 Dec 2008
  • None

#30

Posted 24 March 2009 - 04:55 PM

Try -memrestrict 230686720 first, if that works fine you can try the next one up (using medium textures).

I don't know why you can't sign into RGSC. Sometimes the server goes down and needs to be reset but right now it is working fine.
  • SkyReaper2014 likes this




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users