Quantcast

Jump to content

» «
Photo

[III] Xbox Version HD

2,271 replies to this topic
AdusPL
  • AdusPL

    obrzygane rzygi

  • Feroci
  • Joined: 06 Jun 2013
  • Poland

#1621

Posted 09 July 2014 - 03:23 PM

but pirates playing with a cracked exe are having their fun? Yarr, I guess?

Oh, maybe those 'pirates' just bought the game in a shop?

Stop this nonsense conversation. It doesn't lead to anything good.


ZaxxerDog
  • ZaxxerDog

    Player Hater

  • Members
  • Joined: 09 Jul 2014
  • Hungary

#1622

Posted 09 July 2014 - 03:34 PM Edited by ZaxxerDog, 09 July 2014 - 03:45 PM.

 

 

 

Did everything how it was written in the instructions: fresh install of GTA 3 (Steam version), it ran okay, then I installed the mod and now it crashes. Why? Only the mod's creator knows because I sure as sh*t don't.

So why it works perfectly to me? Maybe it's Steam version problem. I don't know.

 

That's nice: the Steam version has problems (installed all the Steam fixes btw.) but pirates playing with a cracked exe are having their fun? Yarr, I guess?

 


Seriously, just leave this forum if you're going to talk like an absolute c*nt. If you're having problems with the Steam version, go whine to R* and nobody else.

 

Did a full re-install of everything (game + mod) and now all the cars are dark again. :DDDDDDDD A Rebuild Archive process with IMG Tool 2.0 doesn't solve it. Great.

 

I give up, I've already wasted 2 hours trying to get this piece of garbage to work so guess it's original GTA 3 with the perfectly working widescreen fix installed (props to that guy, he actually knows what he is doing). It's a shame I didn't spent those two hours playing the game.

 

Another message to the mod's creator: if you promise it will work with the Steam version next time make sure it does.

 

 

 

Stop this nonsense conversation. It doesn't lead to anything good.

Well if my harsh criticism manages to get through the message of "God, I f*cked something up!" to the mod's dev and he fixes that problem then it already led to some good. :D It's time to realize that people have problems and that the mod is not "finished". It's a shame when a large amount of work goes to waste because of problems like that.


Ash_735
  • Ash_735

  • Members
  • Joined: 15 Nov 2005
  • None
  • Contribution Award [Mods]
    Most Knowledgeable [GTA] 2013
    Best Map 2013 "ViceCityStories PC Edition"

#1623

Posted 09 July 2014 - 03:59 PM

You know you never answered the question on if you installed the 2.1 fix for Steam. ;)

ZaxxerDog
  • ZaxxerDog

    Player Hater

  • Members
  • Joined: 09 Jul 2014
  • Hungary

#1624

Posted 09 July 2014 - 04:03 PM

You know you never answered the question on if you installed the 2.1 fix for Steam. ;)

Yes, I did. Read back a bit where I wrote "installed all the Steam fixes btw". The mod just doesn't work as it should, plain and simple and I don't want to mess around with my old CDs or a pirated torrent.


AdusPL
  • AdusPL

    obrzygane rzygi

  • Feroci
  • Joined: 06 Jun 2013
  • Poland

#1625

Posted 09 July 2014 - 04:07 PM

Well if my harsh criticism manages to get through the message of "God, I f*cked something up!" to the mod's dev and he fixes that problem then it already led to some good. :D It's time to realize that people have problems and that the mod is not "finished". It's a shame when a large amount of work goes to waste because of problems like that.

Well, if it doesn't work for you, it doesn't mean it's not finished.


G The Generous
  • G The Generous

    Hibernating

  • Members
  • Joined: 08 Sep 2007
  • None

#1626

Posted 11 July 2014 - 04:50 AM Edited by badboy_zay, 11 July 2014 - 04:51 AM.

 

You know you never answered the question on if you installed the 2.1 fix for Steam. ;)

Yes, I did. Read back a bit where I wrote "installed all the Steam fixes btw". The mod just doesn't work as it should, plain and simple and I don't want to mess around with my old CDs or a pirated torrent.

 

no one has problem with this mod, the only problem we have is the f*cked up gta3.exe on Steam

so before blaming someone for something and run around whinning about it, go stick a cactus in your arse instead


Rim
  • Rim

    Thug

  • Members
  • Joined: 14 Sep 2008
  • None

#1627

Posted 11 July 2014 - 01:13 PM Edited by Rim, 11 July 2014 - 01:16 PM.

I have the latest updates and all but when I start a new game I get:

 

Unhandled Exception

Unhandled exception: c0000005

At address: 005b3bda

 

Please help I really wanna play GTA III again!  :(

 

EDIT: I get the error when the game is configuring the textures or something.

 

Try this:

 

 1) Install Grand Theft Auto 3
 2) Start the game
 3) Set your graphics settings and then start a new game at least once
 4) Play for a while and then exit the game
 5) Delete gta3.set file in Documents/GTA3 User Files
 6) Install Xbox Version mod
 7) Change your graphics setting again
 
 

 

First and foremost excuse me for being a bit harsh but I don't really like if I have to register to a board I totally don't want to because I get some weird error. Frankly, if the guide for this mod wasn't written like "Install this, install that, play, yay, so simple!" I wouldn't even have started installing this sh*t.

 

First my problem was that all the cars were dark. I fixed that by rebuilding the IMG archives manually with IMG tools. Now, the game just crashes when I start a new game the second I enter the car where Eightball is. How to fix this?

 

A message to the mod's creator: if your sh*t doesn't work, fix it or just delete it from the face of the Earth. People don't have time to fix your mistakes.

 

Change your attitude, because you sound like a spoiled twelve year-old brat (and I bet you are).

 

Try deleting iiigfx.flt from GTA3 root folder. If it doesn't help, get yourself different .exe and it should work, although Steam version is compatible with Xbox mod, dunno why you're the only one who can't get this mod working properly. Also, black cars bug is Rockstar's fault, so go blame them, not me.


ZaxxerDog
  • ZaxxerDog

    Player Hater

  • Members
  • Joined: 09 Jul 2014
  • Hungary

#1628

Posted 11 July 2014 - 02:51 PM Edited by ZaxxerDog, 11 July 2014 - 02:54 PM.

 

I have the latest updates and all but when I start a new game I get:

 

Unhandled Exception

Unhandled exception: c0000005

At address: 005b3bda

 

Please help I really wanna play GTA III again!  :(

 

EDIT: I get the error when the game is configuring the textures or something.

 

Try this:

 

 1) Install Grand Theft Auto 3
 2) Start the game
 3) Set your graphics settings and then start a new game at least once
 4) Play for a while and then exit the game
 5) Delete gta3.set file in Documents/GTA3 User Files
 6) Install Xbox Version mod
 7) Change your graphics setting again
 
 

 

First and foremost excuse me for being a bit harsh but I don't really like if I have to register to a board I totally don't want to because I get some weird error. Frankly, if the guide for this mod wasn't written like "Install this, install that, play, yay, so simple!" I wouldn't even have started installing this sh*t.

 

First my problem was that all the cars were dark. I fixed that by rebuilding the IMG archives manually with IMG tools. Now, the game just crashes when I start a new game the second I enter the car where Eightball is. How to fix this?

 

A message to the mod's creator: if your sh*t doesn't work, fix it or just delete it from the face of the Earth. People don't have time to fix your mistakes.

 

Change your attitude, because you sound like a spoiled twelve year-old brat (and I bet you are).

 

Try deleting iiigfx.flt from GTA3 root folder. If it doesn't help, get yourself different .exe and it should work, although Steam version is compatible with Xbox mod, dunno why you're the only one who can't get this mod working properly. Also, black cars bug is Rockstar's fault, so go blame them, not me.

 

Well you've lost your bet but who cares?

 

I've tried out a lot of stuff so far and the only thing that managed to solve my black cars issue was to replace your particle.txd with the one from the SilentPatch. Maybe the bug occurs because of Rockstar but based on my experience you'll be the primary suspect of doing something that made it appear on my computer (never had this bug before, not even once). The crash at the beginning was caused by the headlight.asi file, it was my fault that after reinstalling update 2 I forgot to re-apply the Steam fix.

 

Before trying all this stuff out I downloaded a 1.1 gta3.exe from GamecopyWorld: the game simply crashed on startup with that. Anyway my point is that your mod if very far from finished if you actually care about the millions of people using the Steam version. You disabled some of the features and what remained is a buggy mess: reflections are all around the place and cars just go black. What's even worse is that the super flashy Xbox menu is not compatible with the widely used widescreen fix and it seems to just bug out (the big Xbox logo and the version number appears for half a second on startup, then goes away).

 

So excuse my manners but from my experience your mod seemed like a mess (and it still seems like that sadly). I want to believe the people who say that the mod works okay with the Steam version but the thing is that my conclusion is based on what I personally have seen. And just to wrap things up:

 

- I've tried with vanilla installs multiple times

- my computer is nothing special

- my operating system is nothing special (Win 7 64bit) 


TJGM
  • TJGM

    Boss

  • Members
  • Joined: 14 Jun 2011
  • Ireland
  • Helpfulness Award
    Contribution Award [Mods]

#1629

Posted 11 July 2014 - 02:54 PM Edited by TJGM, 11 July 2014 - 03:55 PM.

You're an idiot.

 

Have you ever thought that maybe the widescreen fix isn't compatible with the Xbox menu? Which is that mods fault, not this.

 

Keep up your c*ntish attitude much longer and you won't be around very long. Learn about GTA modding before you come onto these forums and start blaming others for stupid reasons.

  • -DP- likes this

ZaxxerDog
  • ZaxxerDog

    Player Hater

  • Members
  • Joined: 09 Jul 2014
  • Hungary

#1630

Posted 11 July 2014 - 03:02 PM Edited by ZaxxerDog, 11 July 2014 - 03:08 PM.

You're an idiot.

 

Have you ever thought that maybe the widescreen fix isn't compatible with the Xbox menu? Which is that mods fault, not this.

 

Keep up you're c*ntish attitude much longer and you won't be around very long. Learn about GTA modding before you come onto these forums and start blaming others for stupid reasons.

Okay, so I don't have much time left here yet you're starting with the name calling? :D Look, I don't care who's fault it is, all I care about is that stuff that worked before stopped working exactly after I've installed the mod. Anyway no biggie, I just wanted to try this out but actually the original GTA3 graphics are mighty fine for me.

 

And I don't want to learn about GTA3 modding because:

 

- I don't care

- I'm not a modder and I have zero intention to make mods for GTA3.

 

P.S.: Just to say something positive: the HQ radio stations kick ass and in my restless dreams I see something similar for Vice City! :D


Rim
  • Rim

    Thug

  • Members
  • Joined: 14 Sep 2008
  • None

#1631

Posted 11 July 2014 - 05:08 PM

You do know that SilentPatch crashes on Steam version of GTA3? I think we found your problem.


Silent
  • Silent

    Chief Vision™ Alterer

  • GTA Mods Staff
  • Joined: 01 Feb 2010
  • Poland
  • Most Helpful [Modding] 2016
    Contribution Award [Mods]
    Best Script/Plugin 2014 [SilentPatch]
    Most Respected 2014
    Most Helpful [Mods] 2014
    Most Helpful [GTA] 2013
    Most Helpful [Mods] 2013
    Most Talented [Modding] 2013
    Best Map 2013 [ViceCityStories PC Edition]
    Best Vehicle 2013 [III Aircraft]
    Most Helpful [Mods] 2012
    Modder of the Year 2012

#1632

Posted 11 July 2014 - 06:53 PM

You do know that SilentPatch crashes on Steam version of GTA3? I think we found your problem.


There is a fixed ASI somewhere in the topic.

ZaxxerDog
  • ZaxxerDog

    Player Hater

  • Members
  • Joined: 09 Jul 2014
  • Hungary

#1633

Posted 12 July 2014 - 12:33 AM Edited by ZaxxerDog, 12 July 2014 - 12:33 AM.

You do know that SilentPatch crashes on Steam version of GTA3? I think we found your problem.

No, headlight.asi crashes the game as I've already stated a few posts back.


Rim
  • Rim

    Thug

  • Members
  • Joined: 14 Sep 2008
  • None

#1634

Posted 12 July 2014 - 04:51 PM

In that case, game crashing was definitely your fault. I suggest you to stop blaming others if you can't even read installation instructions properly.


KonyPL
  • KonyPL

    Player Hater

  • New Members
  • Joined: 13 Jul 2014
  • Poland

#1635

Posted 13 July 2014 - 09:33 AM Edited by KonyPL, 13 July 2014 - 11:16 AM.

this mod has become my essential mod for GTA 3, there is a problem though: whenever a model is imported to 3DS Max by Kam's script, it goes unsmoothed and will look blocky ingame, many modders haven't aware of this and GTA 3 XBOX mod is one of the victim. so I eventually have to reimport,smoothed pretty much every character models from the mod by myself.

so, I think it's a good idea to share my "unofficial patch" here, sadly vehicles is not my field so I can't do anything about that

http://www.mediafire...oxPedPatch1.rar

would be great if someone can make comparison screenshot, I just don't have much time for it, but here are some pics:

 

[images]

Hi! Where to put these files? I was looking for they in-game equivalents, but i didn't found anything just peds.dff Do I need to open this?


Rim
  • Rim

    Thug

  • Members
  • Joined: 14 Sep 2008
  • None

#1636

Posted 13 July 2014 - 11:59 AM

 

this mod has become my essential mod for GTA 3, there is a problem though: whenever a model is imported to 3DS Max by Kam's script, it goes unsmoothed and will look blocky ingame, many modders haven't aware of this and GTA 3 XBOX mod is one of the victim. so I eventually have to reimport,smoothed pretty much every character models from the mod by myself.

so, I think it's a good idea to share my "unofficial patch" here, sadly vehicles is not my field so I can't do anything about that

http://www.mediafire...oxPedPatch1.rar

would be great if someone can make comparison screenshot, I just don't have much time for it, but here are some pics:

 

[images]

Hi! Where to put these files? I was looking for they in-game equivalents, but i didn't found anything just peds.dff Do I need to open this?

 

You need to open up gta3.img file with IMG tool and replace files with provided ones.


KonyPL
  • KonyPL

    Player Hater

  • New Members
  • Joined: 13 Jul 2014
  • Poland

#1637

Posted 13 July 2014 - 12:19 PM Edited by KonyPL, 13 July 2014 - 12:36 PM.

 

 

this mod has become my essential mod for GTA 3, there is a problem though: whenever a model is imported to 3DS Max by Kam's script, it goes unsmoothed and will look blocky ingame, many modders haven't aware of this and GTA 3 XBOX mod is one of the victim. so I eventually have to reimport,smoothed pretty much every character models from the mod by myself.

so, I think it's a good idea to share my "unofficial patch" here, sadly vehicles is not my field so I can't do anything about that

http://www.mediafire...oxPedPatch1.rar

would be great if someone can make comparison screenshot, I just don't have much time for it, but here are some pics:

 

[images]

Hi! Where to put these files? I was looking for they in-game equivalents, but i didn't found anything just peds.dff Do I need to open this?

 

You need to open up gta3.img file with IMG tool and replace files with provided ones.

 

I need to just add them or replace? Because I cant replace all of them at the same time.


ZaxxerDog
  • ZaxxerDog

    Player Hater

  • Members
  • Joined: 09 Jul 2014
  • Hungary

#1638

Posted 13 July 2014 - 01:29 PM Edited by ZaxxerDog, 13 July 2014 - 01:32 PM.

In that case, game crashing was definitely your fault. I suggest you to stop blaming others if you can't even read installation instructions properly.

I suggest you stop being an a**hole ("oh noes, some dude thinks my mod is not good, now I'll be all rude and stuff because people on the internet!" - are you five?) and pay attention to my posts instead. I specifically stated that crashing was my fault because when I re-installed the mod once I forgot to re-apply update 2.1 so thanks for saying nothing new. I think I'll just stop this discussion now because so far basically I've learned these things:

 

- I'm an idiot, an arsehole and 5 or 6 years young

- Steam GTA3 sucks because it sucks

- the XBOX mod is perfect and its creator is a god

 

Grow up people!


TJGM
  • TJGM

    Boss

  • Members
  • Joined: 14 Jun 2011
  • Ireland
  • Helpfulness Award
    Contribution Award [Mods]

#1639

Posted 13 July 2014 - 01:33 PM

 

In that case, game crashing was definitely your fault. I suggest you to stop blaming others if you can't even read installation instructions properly.

I suggest you stop being an a**hole ("oh noes, some dude thinks my mod is not good, now I'll be all rude and stuff because people on the internet!" - are you five?) and pay attention to my posts instead. I specifically stated that crashing was my fault because when I re-installed the mod once I forgot to re-apply update 2 so thanks for saying nothing new.

 

I suggest you stop being an asshole ("oh noes, I can't install a mod and that makes the mod bad! So I'm going to be rude and blame the mods author for me being an idiot!" - are you like five?).


ZaxxerDog
  • ZaxxerDog

    Player Hater

  • Members
  • Joined: 09 Jul 2014
  • Hungary

#1640

Posted 13 July 2014 - 01:54 PM

 

 

In that case, game crashing was definitely your fault. I suggest you to stop blaming others if you can't even read installation instructions properly.

I suggest you stop being an a**hole ("oh noes, some dude thinks my mod is not good, now I'll be all rude and stuff because people on the internet!" - are you five?) and pay attention to my posts instead. I specifically stated that crashing was my fault because when I re-installed the mod once I forgot to re-apply update 2 so thanks for saying nothing new.

 

I suggest you stop being an asshole ("oh noes, I can't install a mod and that makes the mod bad! So I'm going to be rude and blame the mods author for me being an idiot!" - are you like five?).

 

I admit I was harsh and I'm sorry for that but you know what? Sometimes people are harsh and you just have to deal with it. Also my anger was not directed at the mod's developer but at the mod and you guys instantly started to launch personal attacks which is not exactly the most mature thing to do.

 

Also let me just say that the mod's installation instructions were not too clear for me at first as a newcomer to GTA modding: at update 2's readme it just writes as a last step to rebuild both archives. At first I was like wtf and I had to do some digging into what exactly that means. Since that I've rebuilt the archives with 2 programs and the dark cras problem still remains so at this point I'm sure it was not my fault but Rockstar's or the mod's dev's.


Kalvin
  • Kalvin

  • Daily Globe
  • Joined: 06 Apr 2011
  • United-Kingdom
  • Best GTAGarage Staff 2017
    Most Talented [Graphics] 2016
    Best Crew 2016 [The Daily Globe]
    Crew Poster Battle Winner 2016
    Best Conversion 2016 [GTA: Underground] [Contribution]
    Best Workshop 2016 [Honorable mention]
    Most Desperate Campaign Poster 2015
    April Fools Winner 2015
    Champion Guinea Pig [GTAFMC]
    Most Annoying Member [All Time]
    Biggest Asskisser 2014
    Contribution Award [Mods]
    Best Total Overhaul 2014 [GTA SA Beta Edition]
    Biggest Asskisser 2013

#1641

Posted 13 July 2014 - 07:21 PM Edited by Kalvin, 13 July 2014 - 07:21 PM.

Also my anger was not directed at the mod's developer but at the mod


A message to the mod's creator: if your sh*t doesn't work, fix it or just delete it from the face of the Earth. People don't have time to fix your mistakes.

?

  • TJGM, Mega and Sprunkadelic like this

Mega
  • Mega

    Smartass/Joker (Freelancer)

  • Members
  • Joined: 01 Jan 2012
  • Brazil

#1642

Posted 13 July 2014 - 07:27 PM

 

Also my anger was not directed at the mod's developer but at the mod


A message to the mod's creator: if your sh*t doesn't work, fix it or just delete it from the face of the Earth. People don't have time to fix your mistakes.

?

 

serie_touche-13.jpg

  • ClaudX likes this

ZaxxerDog
  • ZaxxerDog

    Player Hater

  • Members
  • Joined: 09 Jul 2014
  • Hungary

#1643

Posted 14 July 2014 - 05:47 AM Edited by ZaxxerDog, 14 July 2014 - 06:58 AM.

 

Also my anger was not directed at the mod's developer but at the mod


A message to the mod's creator: if your sh*t doesn't work, fix it or just delete it from the face of the Earth. People don't have time to fix your mistakes.

?

 

Sure, that's exactly what I was talking about, yet you guys just launch personal attacks on me wthout any justification whatsoever. You think that sentence shows that I have personal problems with the mod's developer? How the hell would I make a conversation with the mod itself? "Oh mod, why don't you go fix yourself?" :DD Sir, you are so stupid I have some serious business propositions for you.

 

But anyway, who am I to judge people? Who am I to take your primitive methods of fun away? Carry on, continue saying how I don't know s*it and how perfect the mod is! That will really put me back to my place!

 

Edit: Okay, don't want to get the discussion more heated than it already is so here's a tutorial for my comments to people who like to overreact things: don't take my words more seriously than what some dude who is whining about something that's not working for him says. And just to be sure, I say this for the third time: the crashing was my fault, the black cars weren't. So in order to get a constructive discussion in motion I'd like to make the humble proposition of asking people who are using the Steam version of GTA3 with the Xbox mod perfectly fine to say a few words (and let's get something out of the way: if you actually know about a non-Steam exe the Steam version is not crashing with, please share that info with me). It would be good to have this sorted so that Rim could fix the issue if he wants to. I'm sure as s*it no one will say that the Steam fix is working because I've seen a lot of people reporting the black cars bug but it's worth a try, maybe there's a solution or a workaround people don't know about. All I can say is that I will try the mod out on 2 more computers.

 

Also just to educate people on how the Steam version works: it will never do the old "optimizing stuff for your computer" process, not even on first launch, not even after deleting the settings profile file, NEVER. Dig into stuff before you are suggesting something.


MrMateczko
  • MrMateczko

    ~yay!

  • Members
  • Joined: 10 Dec 2011
  • Poland
  • Helpfulness Award [Chain Game]

#1644

Posted 14 July 2014 - 10:04 AM

The file that causes the "optimizing stuff for your computer" process not launching is CAPS.DAT in data folder, not settings profile file. Try deleting it.

Unless you've tried that before.


davb37
  • davb37

    Player Hater

  • Members
  • Joined: 02 Aug 2006

#1645

Posted 14 July 2014 - 11:41 AM

Hi all!

I got a problem with stats menu.

Some of the texts are overwriting:

http://i.imgur.com/5RWjJDV.png

 

Compared to original:

http://i.imgur.com/7wyKNS9.jpg

 

I tried to remplace fonts.txd and menu.txd, but it just changes the background:

http://i.imgur.com/D3in8mA.png

 

I would like to know if there's a way to modify menu (maybe fonts size?) to see all texts.


ZaxxerDog
  • ZaxxerDog

    Player Hater

  • Members
  • Joined: 09 Jul 2014
  • Hungary

#1646

Posted 14 July 2014 - 05:20 PM Edited by ZaxxerDog, 14 July 2014 - 05:20 PM.

The file that causes the "optimizing stuff for your computer" process not launching is CAPS.DAT in data folder, not settings profile file. Try deleting it.

Unless you've tried that before.

Thanks, that actually worked and led me to a solution!

 

The thing is that with the Steam version everything is pre-created for you so the optimization part never shows up because it's not supposed to. If you delete the CAPS.DAT file the game will do the optimization and that will break the Steam version (car textures become all messed up and the game stutters like hell). But what that actually means is that you've got all the old stuff in the game back, the original setup of the textures so now if you replace your Steam exe with the original exe the game won't crash (if you just replace your exe without doing the optimization the game will crash on startup) and everything will work fine. So by doing the optimization process and replacing the Steam exe you basically just converted your game back to "normal". After this you can install the Xbox mod (WITHOUT the Steam fixes) and it will work perfectly with ENB and all the other fine stuff!

 

So the point is that Rim, please just accept that the Steam fixes you provided for the mod simply don't work with the Steam version so if a Steam user wants to install your mod first he HAS TO convert the game back to its original state.


Rim
  • Rim

    Thug

  • Members
  • Joined: 14 Sep 2008
  • None

#1647

Posted 14 July 2014 - 07:44 PM Edited by Rim, 14 July 2014 - 08:08 PM.

 

 

 

this mod has become my essential mod for GTA 3, there is a problem though: whenever a model is imported to 3DS Max by Kam's script, it goes unsmoothed and will look blocky ingame, many modders haven't aware of this and GTA 3 XBOX mod is one of the victim. so I eventually have to reimport,smoothed pretty much every character models from the mod by myself.

so, I think it's a good idea to share my "unofficial patch" here, sadly vehicles is not my field so I can't do anything about that

http://www.mediafire...oxPedPatch1.rar

would be great if someone can make comparison screenshot, I just don't have much time for it, but here are some pics:

 

[images]

Hi! Where to put these files? I was looking for they in-game equivalents, but i didn't found anything just peds.dff Do I need to open this?

 

You need to open up gta3.img file with IMG tool and replace files with provided ones.

 

I need to just add them or replace? Because I cant replace all of them at the same time.

 

You need to manually replace each file one by one. After you are done, click Rebuild archive and you are good to go.

 

 

 

The file that causes the "optimizing stuff for your computer" process not launching is CAPS.DAT in data folder, not settings profile file. Try deleting it.

Unless you've tried that before.

Thanks, that actually worked and led me to a solution!

 

The thing is that with the Steam version everything is pre-created for you so the optimization part never shows up because it's not supposed to. If you delete the CAPS.DAT file the game will do the optimization and that will break the Steam version (car textures become all messed up and the game stutters like hell). But what that actually means is that you've got all the old stuff in the game back, the original setup of the textures so now if you replace your Steam exe with the original exe the game won't crash (if you just replace your exe without doing the optimization the game will crash on startup) and everything will work fine. So by doing the optimization process and replacing the Steam exe you basically just converted your game back to "normal". After this you can install the Xbox mod (WITHOUT the Steam fixes) and it will work perfectly with ENB and all the other fine stuff!

 

So the point is that Rim, please just accept that the Steam fixes you provided for the mod simply don't work with the Steam version so if a Steam user wants to install your mod first he HAS TO convert the game back to its original state.

 

I was unaware of this issue, because I never experienced any problems installing the mod on Steam version. It is tough to fix a problem that you can't even reproduce, you know.

 

About the black car glitch. I was sure that newest update fixed this problem, but you are not the only one who complaint about cars being black again. I'll try to look at this issue when I have enough free time. And again, my copy of GTA3 works just fine. Strange..

 

There is one thing I want to tell you. Next time you have problems don't rage and diss everyone around you. Instead, ask politely for help and explain the problem that you are having. People here are always ready to help you.

 

EDIT

 

About the menu. Yes, this is definitely a bug. Good news is, editing menu text scale should be really easy. I added this issue to my bucket list ;)

 

Actually, I'd like to re-code all menu related stuff, because I'm not satisfied with the current result. Too bad I don't have the source code anymore, that means I have to rewrite everything from scratch and it would take a lot of time and effort.


RussianFighter
  • RussianFighter

    Hater Player

  • Members
  • Joined: 09 Jan 2006
  • Argentina

#1648

Posted 18 July 2014 - 02:05 AM Edited by MerolaC, 18 July 2014 - 02:06 AM.

Thank you a lot for this awesome mod!

The game graphics really changes with it. Specially character models!

 

Sadly... I Can back him on the "Black cars problem" with the Steam version. If I use the originally fixed particle.txd the cars are not black, if I use the one in this mods, it does not.


DalekCaan
  • DalekCaan

    Player Hater

  • Members
  • Joined: 20 Aug 2014
  • Brazil

#1649

Posted 26 August 2014 - 09:35 PM Edited by DalekCaan, 26 August 2014 - 09:41 PM.

To everyone who's bitching about the Steam version having issues, just patch it up to the original version. 

 

I don't get the hate over something so small, I have a pretty slow internet but even I don't mind downloading 680mbs of game again. 

 

PS: You're a hero for this mod, Rim.

 

PPS: For god's sake, people. Make a backup before installing mods!


Naroon
  • Naroon

    Saturday Night Beaver

  • Members
  • Joined: 25 Sep 2014
  • United-States

#1650

Posted 04 October 2014 - 08:04 AM

Just want some clarification here so I don't screw anything up. I've installed the mod and the updates, but the readme for update2 says "Go to GTAIII\models folder and manually rebuild both IMG archives."

 

I went and got the IMG Tool program, but what exactly am I supposed to do with the two IMG files? I read elsewhere that you have to "replace the files with the provided files one by one" whatever that means. Does anyone have a concise, step-by-step explanation on wtf I'm supposed to do here, lol?





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users