Quantcast

Jump to content

» «
Photo

GTA IV GrabScript!

  • This topic is locked This topic is locked
265 replies to this topic
13-37
  • 13-37

    ♫ ♪ ♫ ♪ ♫ ♪ ♫

  • Members
  • Joined: 14 Dec 2008

#241

Posted 02 May 2010 - 11:51 AM

QUOTE (HazardX @ May 2 2010, 10:44)
NEW VERSION:

GTAIV GrabScript! v1.4

Changes in Version 1.4:
- It works on GTA IV v1.0.6.0 and EFLC 1.1.1.0 now!

How to update:
- Install .Net Framework 4
- Install .Net ScriptHook v1.6.1.1
- Install GTAIV GrabScript! v1.4

Thank you wink.gif icon14.gif cookie.gif cookie.gif

Superpowermind
  • Superpowermind

    Kill the King

  • Members
  • Joined: 08 Jan 2008

#242

Posted 02 May 2010 - 12:00 PM

Works like a charm now. Thanks HazardX.

HazardX
  • HazardX

    pedestrian mangler

  • Members
  • Joined: 13 Dec 2008

#243

Posted 02 May 2010 - 12:18 PM

In case anyone still gets the "MSVCR100.dll not found" error:
Try installing the Microsoft Visual C++ 2010 Redistributable Package!

gordon21
  • gordon21

    Player Hater

  • Members
  • Joined: 07 Mar 2010

#244

Posted 04 May 2010 - 03:47 PM

hey some reason i cant get the mod to work i got a asi loader and got the hook script and the grab script anything im missing can anyone help me pls

Pantheon
  • Pantheon

    is barrel rolling

  • Members
  • Joined: 27 Dec 2008

#245

Posted 06 May 2010 - 01:28 PM

It's still not working properly in multiplayer, I guess? I mean that other people see you while hanging on a car in ragdoll mode?

steryman
  • steryman

    Player Hater

  • Members
  • Joined: 08 Aug 2008

#246

Posted 22 August 2010 - 05:51 PM Edited by steryman, 23 August 2010 - 07:09 AM.

Guys I have a problem: I am using this mod on EFLC (TBoGT) and after loading game doesn't work it says "Error in script "Grabscript.EveryoneGrabMeScript"" and "Error in script "Grabscript.Grabscript"".... can someone help me make it work please?

2010-08-23 10:02:02 - Error in constructor of script 'GrabScript.GrabScript':
System.MissingMethodException: Method not found: 'Void GTA.Script.set_RequiredVersion(Single)'.
at GTA.ScriptThread.LoadScriptNow()
2010-08-23 10:02:02 - Error in constructor of script 'GrabScript.EveryoneGrabMeScript':
System.MissingMethodException: Method not found: 'Void GTA.Script.set_RequiredVersion(Single)'.
at GTA.ScriptThread.LoadScriptNow()

geokes
  • geokes

    Square Civilian

  • Members
  • Joined: 25 Apr 2007

#247

Posted 03 September 2010 - 06:59 PM

Any chance you'll release a 1.0.7.0 version? (sorry I have the steam version of GTA 4 sad.gif )

Maxord
  • Maxord

    Player Hater

  • Members
  • Joined: 06 Jan 2009

#248

Posted 06 October 2010 - 06:18 AM

HazardX, I beg you to release 1.0.7.0 version of this great mod.

Muvono
  • Muvono

    Player Hater

  • Members
  • Joined: 07 Nov 2010

#249

Posted 07 November 2010 - 03:00 AM

Hazard, please update this for 1.0.7.0 please. Or maybe i can have source so i can see if i can get it to work? or something. I want to use this so bad but if i downgrade my steam gta 4 i lose all my text in game and I can't play it like that. Please try to make it work for 1.0.7.0
the only reason i've made a account on this website is to post this and ask for you to make it work for 1.0.7.0
please

-NightStalker-
  • -NightStalker-

    Player Hater

  • Members
  • Joined: 24 Jan 2011

#250

Posted 24 January 2011 - 08:11 PM Edited by -NightStalker-, 24 January 2011 - 08:40 PM.

I installed everything to need and mod. Im pressing "b" but nothing happening. I reinstalled mod, game, scriphook etc. but not working. Ive got .NET Framework 4.0 Can you help me HazardX?

Sorry about my English. Im still learning smile.gif

todlich
  • todlich

    Player Hater

  • Members
  • Joined: 13 Feb 2011

#251

Posted 15 February 2011 - 04:33 AM

Hello Hazard... Please please reply back soon. I have been trying to get grabscript to work with my gta v1.0.4.0 and whenever I press the B button nothing happens. I have tried it in patches 1.0.2.0, 1.0.3.0, 1.0.4.0, 1.0.6.0 and 1.0.7.0 but to no avail. I have looked through this entire tread and have made sure to download all of the .net scripthooks, .net frameworks, I have the newest ASI loader (Xliveless), and I have downloaded the 1.4 Grabscript. I have tried creating a "Scripts" folder and extracting to that in the GTA root install folder, then I have tried extracting it to the common/data/script directory which still didnt work. I have even tried just extracting it to the root folder with out the "scripts" subfolder... Please help me. I just want to be able to be dragged across the liberty city highway. I will be sure to check back everyday to reply to your replies. (<-- Hopefully) Thank you in advance.

HazardX
  • HazardX

    pedestrian mangler

  • Members
  • Joined: 13 Dec 2008

#252

Posted 15 February 2011 - 10:03 AM Edited by HazardX, 15 February 2011 - 10:05 AM.

Is there a ScriptHookDotNet.log file in your GTA installation folder? Post it's content, please. If it isn't there you should try to start the game by rightclicking the link and selecting "Run as Administrator". If it still isn't there then you are for sure missing one of the requirements of the .Net ScriptHook. (most likely the Microsoft Visual C++ 2010 x86 Redistributable Package)

todlich
  • todlich

    Player Hater

  • Members
  • Joined: 13 Feb 2011

#253

Posted 16 February 2011 - 12:31 AM

QUOTE (HazardX @ Feb 15 2011, 10:03)
Is there a ScriptHookDotNet.log file in your GTA installation folder? Post it's content, please. If it isn't there you should try to start the game by rightclicking the link and selecting "Run as Administrator". If it still isn't there then you are for sure missing one of the requirements of the .Net ScriptHook. (most likely the Microsoft Visual C++ 2010 x86 Redistributable Package)

Thank you so much Hazard! The problem was the C++ package. Thanks for the help! biggrin.gif

tr0ubl3mak3r
  • tr0ubl3mak3r

    Player Hater

  • Members
  • Joined: 21 Feb 2011

#254

Posted 21 February 2011 - 12:58 AM Edited by tr0ubl3mak3r, 22 February 2011 - 10:30 PM.

QUOTE (HazardX @ Feb 15 2011, 10:03)
Is there a ScriptHookDotNet.log file in your GTA installation folder? Post it's content, please. If it isn't there you should try to start the game by rightclicking the link and selecting "Run as Administrator". If it still isn't there then you are for sure missing one of the requirements of the .Net ScriptHook. (most likely the Microsoft Visual C++ 2010 x86 Redistributable Package)

Heya.. I'm having problems getting the script to run also. The ASI loader runs fine, but soon as it gets to your scriptloader, it dies on me. Running Win7 Ultimate 64, fresh install. GTA IV 1.0.7.0 fresh install. I have the Visual C++ redist installed (via your link, just in case). And I'm running LaunchGTA as an administrator. Here's the contents of the ScriptHookDotNet.log..

CODE
Log start: Sun Feb 20 16:35:00 2011
-----------------------------------------------
[INFO] GTA IV Script Hook 0.5.1 - (C) 2009, Aru - Initialized
[INFO] Process base address: 0x12a0000
[INFO] Auto detecting game version
[INFO] Using game version 1.0.7
[INFO] Script Hook - Shutdown


I've tried 2 ASI loaders (Yaasil and xliveless), I made sure I'm using grabber 1.4 and have it in the scripts folder. ScriptHook.dll is in the root folder while I've tried ScriptHookDotNet.asi in both the root and the plugins folder. And I've run out of ideas. mercie_blink.gif

If it helps diagnose it in any way, when I load the game, as soon as I get passed the social club pop up (I click play offline), I get an error box saying that GTAIV.exe has crashed. Yet if I don't click the error box, the game will continue to run. If I click the box, it closes out of the game even though the game is fully functioning (I can start a game, run around, mash my B button attempting to grab only to fail, etc). And the details of the error box mention a .dll named kernelbase.dll.

Anyway, thanks for reading. Hope I can figure this out as.. since I can't car surf on anything over 3 mph, grabbing on will be the next best thing!

Edit: Just wanted to add, I've definitely narrowed it down to being ScriptHookDotNet.asi causing the crash. Other mods work fine. And I've been also attempting to use native trainer for it's grab function.. but it kinda sucks. Launches you around.. only works if you're basically right at the bumper.. etc etc.

matu700
  • matu700

    Player Hater

  • Members
  • Joined: 13 Jun 2011

#255

Posted 16 June 2011 - 08:08 AM Edited by matu700, 16 June 2011 - 10:39 AM.

Help it's not working for me!

My scripthook says it's 0.5.1.0 when i look at the file.

Also i have ragdoll mod and Simple native trainer 6.3

I have gta 4 version 1.0.7.0

Log start: Thu Jun 16 11:07:59 2011
-----------------------------------------------
[INFO] GTA IV Script Hook 0.5.1 - 2009, Aru - Initialized
[INFO] Process base address: 0x400000
[INFO] Auto detecting game version
[INFO] Using game version 1.0.7
[INFO] [CustomThread] Thread started
[INFO] [CustomFiberThread] Thread started
[INFO] [SimpleTrainer] Thread started
[INFO] [SimpleTrainer_TBOGT] Thread started
[INFO] [SimpleTrainer_TLAD] Thread started
[INFO] [SimpleTrainer_TLAD] Thread killed
[INFO] [SimpleTrainer_TBOGT] Thread killed
[INFO] [SimpleTrainer] Thread killed
[INFO] [CustomFiberThread] Thread killed
[INFO] [CustomThread] Thread killed
[INFO] Script Hook - Shutdown


Thanks for help!




FIXED!!!

krok
  • krok

    Player Hater

  • Members
  • Joined: 25 Jun 2011

#256

Posted 04 July 2011 - 02:49 PM

Hey, i have been wanted this grabscript a really long time now. I have try get it to work very many times but still not working!
I wonder if there is any very kind person who would like to send me the exactily things needed for grabscript.
I also installed version 1.0.4.0 to try, but failed. =(

nightwalker83
  • nightwalker83

    Don't mind me

  • Members
  • Joined: 10 Oct 2004

#257

Posted 15 July 2011 - 05:49 AM

Damn! Using the GrabScript doesn't make getting it to the heli on the final mission any easier. sad.gif

sniper_sniper2011
  • sniper_sniper2011

    Player Hater

  • Members
  • Joined: 30 Mar 2011

#258

Posted 21 July 2011 - 09:43 AM

when the game starts the scripthook says:error loading grabscript.everyone grab me script
what should i do??? sad.gif sad.gif

Donrenegade
  • Donrenegade

    Player Hater

  • Members
  • Joined: 03 Aug 2009

#259

Posted 10 August 2011 - 11:22 AM

It works great untill it crashes... this is what my log says:

QUOTE
2011-08-09 23:28:39 - Error during Tick in script 'GrabScript.EveryoneGrabMeScript':
                      GTA.NonExistingObjectException: Invalid call to an object that doesn't exist anymore!
                        at GTA.Ped.get_Velocity()
                        at GrabScript.EveryoneGrabMeScript.a(Object A_0, EventArgs A_1)
                        at GTA.Script.TryTick()
                        at GTA.Script.DoTick()
                        at GTA.ScriptThread.OnTick()
2011-08-09 23:28:49 - SCRIPTS TERMINATED!


Can it be fixed? biggrin.gif

CrazyRaisin
  • CrazyRaisin

    Consoles suck, yeah I be hatin, problem?

  • Members
  • Joined: 20 Aug 2012

#260

Posted 20 August 2012 - 07:56 PM

Just fun grabbing cars sly.gif

MyPCSucks
  • MyPCSucks

    ---Commando---

  • Members
  • Joined: 06 Jun 2012

#261

Posted 25 September 2012 - 10:33 PM

This refuses to work for me. I press B and nothing happens, although it worked before... I did exactly what the instructions said.

Darlyn
  • Darlyn

    Keyboard & mouse

  • Members
  • Joined: 22 Apr 2006

#262

Posted 02 December 2012 - 09:03 PM

Can someone modify this so that I can drag pedetrians/dead bodies?

Darlyn
  • Darlyn

    Keyboard & mouse

  • Members
  • Joined: 22 Apr 2006

#263

Posted 25 January 2013 - 05:41 PM

bump.......

Witchking Of Angmar
  • Witchking Of Angmar

    One Ring to rule them all.

  • Members
  • Joined: 06 Jan 2013
  • None

#264

Posted 27 April 2013 - 12:54 PM

does this work with 1.0.7.0

yoloman
  • yoloman

    Player Hater

  • Members
  • Joined: 21 Jul 2014
  • None

#265

Posted 31 October 2014 - 02:19 PM

This mod doesn't work for me.


Silent
  • Silent

    Moderating Cookie Monster

  • Feroci
  • Joined: 01 Feb 2010
  • Poland
  • Most Helpful [GTA] 2013
    Most Helpful [Modding] 2013
    Most Talented [Modding] 2013
    Best Map 2013 "ViceCityStories PC Edition"
    Best Vehicle 2013 "III Aircraft"
    Most Helpful [Modding] 2012
    Modder of the Year 2012

#266

Posted 31 October 2014 - 03:32 PM

Nice bump.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users