Quantcast

Jump to content

» «
Photo

Won't Quit / Exit Back To Windows

17 replies to this topic
Akolade
  • Akolade

    Player Hater

  • Members
  • Joined: 26 Jan 2009

#1

Posted 26 January 2009 - 04:18 PM

Hi, I have GTA4PC, and when I to go the Menu->Game and Quit the game, it appears to be working. It goes black and there is no sound for a few seconds (about 10 or 15 seconds).
Then, the screen is still black, and the background music for the menu screen comes on. It never returns to the Windows desktop. No matter what I do I can't get it to quit. I can even hit the Windows key and you can tell Windows is trying to take control (the music will stop until you hit escape) but there is no way to get out of the black screen+music. I tried ALT-F4, Ctrl-Alt-Del, etc.
The only real "unique" thing about my setup is that I'm using Windows XP 64bit, but I don't know if that's the problem.
Anyone else experienced this?? It's really annoying, I have to reset the machine every time I stop playing.

My specs:
-OS: Windows XP 64bit
-AMD Phenom X4
-nVideo Geforce 9800GT
-4gigs Ram

Thanks!

Stardog
  • Stardog

    You can't eat the venetian blinds!

  • Members
  • Joined: 07 Dec 2008

#2

Posted 26 January 2009 - 05:33 PM

Exit the game with CTRL-ALT-DEL from now on.

When going from the video editor back to the singleplayer my game hangs like this too. So I just ctrl-alt-del out before clicking exit.

Akolade
  • Akolade

    Player Hater

  • Members
  • Joined: 26 Jan 2009

#3

Posted 26 January 2009 - 05:42 PM

CTRL-ALT-DEL instead of using "quit"? Good idea, I will try that! I will report my success. Thanks for the tip.
Hope they fix it. Strange that I haven't seen anyone else with this problem.

onepark
  • onepark

    Player Hater

  • Members
  • Joined: 26 Jan 2009

#4

Posted 26 January 2009 - 11:06 PM

QUOTE (Stardog @ Jan 26 2009, 17:33)
Exit the game with CTRL-ALT-DEL from now on.

When going from the video editor back to the singleplayer my game hangs like this too. So I just ctrl-alt-del out before clicking exit.

is this some sort of bug?
coz i got same issue too,
and when there is black screen i cant even CTRL-ALT-DEL.

this does some times when i load game too..

synister
  • synister

    Player Hater

  • Members
  • Joined: 06 Feb 2009

#5

Posted 06 February 2009 - 03:29 AM

QUOTE (onepark @ Jan 26 2009, 23:06)
QUOTE (Stardog @ Jan 26 2009, 17:33)
Exit the game with CTRL-ALT-DEL from now on.

When going from the video editor back to the singleplayer my game hangs like this too. So I just ctrl-alt-del out before clicking exit.

is this some sort of bug?
coz i got same issue too,
and when there is black screen i cant even CTRL-ALT-DEL.

this does some times when i load game too..

Me too, even when i goto multiplayer. I found somewhere online i could add a comandline.txt file to the root directory and it would fix it. But that doesnt work either.

Computer
Computer Type ACPI Uniprocessor PC
Operating System Microsoft Windows XP Professional
OS Service Pack Service Pack 3
Internet Explorer 7.0.5730.13 (IE 7.0)
DirectX 4.09.00.0904 (DirectX 9.0c)
Computer Name SYNISTER
User Name Mike
Logon Domain SYNISTER
Date / Time 2009-02-05 / 22:25

Motherboard
CPU Type AMD Athlon 64, 2222 MHz (11 x 202) 3500+
Motherboard Name Asus A8N5X (3 PCI, 2 PCI-E x1, 1 PCI-E x4, 1 PCI-E x16, 4 DDR DIMM, Audio, Gigabit LAN)
Motherboard Chipset nVIDIA nForce4, AMD Hammer
System Memory 1536 MB (PC3200 DDR SDRAM)
DIMM1: Kingston K 512 MB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz) (2.5-3-3-7 @ 166 MHz) (2.0-2-2-6 @ 133 MHz)
DIMM2: Kingston K 512 MB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz) (2.5-3-3-7 @ 166 MHz) (2.0-2-2-6 @ 133 MHz)
DIMM4 512 MB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz) (2.5-3-3-7 @ 166 MHz) (2.0-2-2-6 @ 133 MHz)
BIOS Type Award (07/27/05)
Communication Port Communications Port (COM1)
Communication Port ECP Printer Port (LPT1)

Display
Video Adapter NVIDIA GeForce 9600 GT (512 MB)
3D Accelerator nVIDIA GeForce 9600 GT
Monitor Plug and Play Monitor [NoDB] (H9NQ910856)

Multimedia
Audio Adapter Realtek ALC850 @ nVIDIA nForce4 (CK8-04) - Audio Codec Interface

Partitions
C: (NTFS) 76308 MB (36847 MB free)
E: (NTFS) 149.0 GB (110.9 GB free)
Total Size 223.6 GB (146.9 GB free)

Input
Keyboard Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
Mouse PS/2 Compatible Mouse
Game Controller Microsoft PC-joystick driver
Game Controller Microsoft PC-joystick driver

Peripherals
Printer Microsoft XPS Document Writer
FireWire Controller NEC uPD72874 IEEE1394 OHCI 1.1 3-port PHY-Link Controller
USB1 Controller nVIDIA nForce4 (CK8-04) - OHCI USB 1.1 Controller
USB2 Controller nVIDIA nForce4 (CK8-04) - EHCI USB 2.0 Controller
USB Device Logitech Dual Action USB
USB Device USB Human Interface Device
USB Device USB Mass Storage Device
USB Device Xbox 360 Controller for Windows

DMI System Manufacturer System manufacturer
DMI System Product System Product Name
DMI System Version System Version
DMI System Serial Number System Serial Number
DMI Motherboard Manufacturer ASUSTeK Computer INC.
DMI Motherboard Product A8N5X
DMI Motherboard Version 1.XX
DMI Chassis Manufacturer Chassis Manufacture
DMI Chassis Version Chassis Version
DMI Chassis Serial Number EVAL
DMI Chassis Asset Tag 123456789000
DMI Chassis Type Desktop Case
DMI Total / Free Memory Sockets 4 / 1

Aldakoopa
  • Aldakoopa

    Player Hater

  • Members
  • Joined: 21 Mar 2010

#6

Posted 22 March 2010 - 12:01 AM

It took me forever searching on the internet to find somebody having the same problems! I can not quit or load a new or saved game without the computer going into a never-ending black or loading screen with the game's music playing in the background. I don't have the best of systems but I have above the minimum requirements:

Windows XP 32 bit SP3
3GHz AMD Athlon 64 X2 dual core processor 6000+
512MB NVIDIA GeForce 9500 GT
2GB RAM

I used to be playing the game with a 2.3GHz single core processor and I blamed it on that, but after upgrading the processor and still having the same problem, I have no clue what the problem is other than the game itself!

Also, I can not join an existing multiplayer game, I can only create my own, but I can't quit that either or I get the never-ending loading screen.

viometrix
  • viometrix

    Mildly Aggravating

  • BUSTED!
  • Joined: 01 Sep 2009

#7

Posted 22 March 2010 - 01:57 AM

try turning off vsync

WTFX
  • WTFX

    Trick

  • Members
  • Joined: 28 Jan 2009

#8

Posted 22 March 2010 - 06:07 PM

this happens to me too, but for me the cause is xliveless which has this bug. after crash tho i can just ctrl-alt-del and esc (not always needed) and get the not responding prompt which i then close. done.
if it happens to u guys w/o it, idk. could be anything. cheap port.

Aldakoopa
  • Aldakoopa

    Player Hater

  • Members
  • Joined: 21 Mar 2010

#9

Posted 22 March 2010 - 11:01 PM

QUOTE (viometrix @ Mar 22 2010, 01:57)
try turning off vsync

Turned off Vsync and it works perfectly now. biggrin.gif Thank you! I suggest everyone else having this problem try the same thing.

viometrix
  • viometrix

    Mildly Aggravating

  • BUSTED!
  • Joined: 01 Sep 2009

#10

Posted 23 March 2010 - 02:15 PM

QUOTE (Aldakoopa @ Mar 22 2010, 23:01)
QUOTE (viometrix @ Mar 22 2010, 01:57)
try turning off vsync

Turned off Vsync and it works perfectly now. biggrin.gif Thank you! I suggest everyone else having this problem try the same thing.

i only have vsync on during actual gameplay, otherwise loading takes forever and the game crashes on close. the minor inconvenience of turning it off and on is much much less then the loading times. especially for people like me that have this game almost 100% maxed out, with vsync on loading is almost 3 minutes, with it off it is 20 - 30 seconds at most.

i am glad i could help you out.

Aldakoopa
  • Aldakoopa

    Player Hater

  • Members
  • Joined: 21 Mar 2010

#11

Posted 24 March 2010 - 11:12 PM

QUOTE (viometrix @ Mar 23 2010, 14:15)
QUOTE (Aldakoopa @ Mar 22 2010, 23:01)
QUOTE (viometrix @ Mar 22 2010, 01:57)
try turning off vsync

Turned off Vsync and it works perfectly now. biggrin.gif Thank you! I suggest everyone else having this problem try the same thing.

i only have vsync on during actual gameplay, otherwise loading takes forever and the game crashes on close. the minor inconvenience of turning it off and on is much much less then the loading times. especially for people like me that have this game almost 100% maxed out, with vsync on loading is almost 3 minutes, with it off it is 20 - 30 seconds at most.

i am glad i could help you out.

Well, a little update on that, it doesn't work EVERY time, but it's much better than it was before. At least I can enjoy the game a little better now.

viometrix
  • viometrix

    Mildly Aggravating

  • BUSTED!
  • Joined: 01 Sep 2009

#12

Posted 25 March 2010 - 01:08 AM

are you running any mods?

Aldakoopa
  • Aldakoopa

    Player Hater

  • Members
  • Joined: 21 Mar 2010

#13

Posted 26 March 2010 - 12:37 AM

No, I am not running any mods.

mkey82
  • mkey82

    Keep riding hard, son

  • Members
  • Joined: 14 Feb 2008

#14

Posted 26 March 2010 - 06:07 AM

Sometimes DEP seems to cause this issue, go to advanced tab on system properties applet and under performance you'll find the option to add an application to DEP exclusion list, so add GTAIV there.

Also, you could try using memrestrict, it's a bit far fetched, but worth a try.

Billy Idol
  • Billy Idol

    Player Hater

  • Members
  • Joined: 31 Oct 2005

#15

Posted 25 April 2010 - 01:07 AM

I am having a similar problem - I have a Logitech G15 keyboard and most / sometimes, works fine. However, sometimes, it goes crazy and the ESC key dumps me back to the desktop (GTA4 / TLATD still running in background). Click back on it, goes to the map (as it should have done in the first place). However, press ESC again and it dumps me back to the desktop again (instead of leaving the map).

What is going on ?! Haven't knowingly installed any other drivers etc. for Logitech in a long time, so I am baffled.

REALLY annoying.

jazzbazz420
  • jazzbazz420

    Player Hater

  • Members
  • Joined: 20 Sep 2013

#16

Posted 20 September 2013 - 04:04 PM

What is this vsync? :cry:


jazzbazz420
  • jazzbazz420

    Player Hater

  • Members
  • Joined: 20 Sep 2013

#17

Posted 20 September 2013 - 04:14 PM

I too have the same problem but i press ctrl+alt+del and quit will it 

effect my game? :panic:


luceberg
  • luceberg

    Homeboy

  • Members
  • Joined: 27 Dec 2008

#18

Posted 20 September 2013 - 05:16 PM

Probably best to manually save your game progress before using ctrl+alt+del.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users