Quantcast

Jump to content

» «
Photo

GTA1 railway limited

2 replies to this topic
Interdictor
  • Interdictor

    Player Hater

  • Members
  • Joined: 02 May 2006

#1

Posted 21 January 2009 - 09:08 PM

Greetings!

I'd like to inform you about a limitation in building railways in GTA1. The whole problem consists in the fact that you are limited by a certain amount of cubes you can set or define as "railway". I discovered it when trying to extend the public transport system in original NYC.cmp. When you exceed the limit, you'll encounter error 134.142 saying "Railway invalid". At first, I thought there was a leftover, a railway cube which was forgotten and left adjacent to the new track, thus causing an error since GTA1 railway needs a complete loop with a clear, undoubtful path to be followed in order to function properly (single railway cubes left apart from the track - i.e. not neighbouring - are considered or treated as unfinished railways and, therefore, do not cause any errors although trains don't generate not only on them - albeit they are set to produce trains - but also on ANY complete and otherwise properly created route). So I checked the loop in GTAcops and there was no mentioned leftover. Then I thought I caused an error due to a collision with another feature in the game, such as TL junction. After a lengthy struggle I discovered there is an in-game limit for building railways. I focused on this hypothesis, testing it from several points of view using various methods. I won't describe them all but as an example: I created a small loop (an additional route to the original one) and it functioned normally (no errors, trains spawned and serviced the route normally). Then, I enlarged the track slightly and checked whether it was still correct. By using this step-by-step method I finally came to a point where the error occured. So I searched for any conflicts it could cause at that place but everything seemed to be right. To test it a bit more, I created a small loop at the same place but this route was perfect and no error appeared. Then I shortened the original route, sparing some 22 railway cubes. I tried if it would help and it helped! I could enlarge the additional route but not more than by that 22 railway cubes. I counted the maximum allowable amount of railway cubes and the result is as follows:

the original route in the original NYC.cmp consists of 662 railway cubes. By testing I found out that I am unable to build an additional loop greater than 218 (maybe 219) cubes. It can be derived that your railway may be composed of max. 880 (maybe 881) cubes regardless of how many loops you created. Logically, the more loops (routes) you create, the smaller the biggest of them must be. The original railway in the original MIAMI.cmp consists of 782 cubes, so it seems to be more efficient to edit this original route than create another.

No matter what is behind this limitation (perhaps game performance of then-existing hardware), it is a significant drawback. It might be removed from .exe where it is probably stored (the very check of that limit surely) but I am not experienced in it. Perhaps, someone could do that.




_Silent.Bob_
  • _Silent.Bob_

    Player Hater

  • Members
  • Joined: 17 Dec 2007

#2

Posted 31 March 2009 - 08:40 PM

Hi Interdictor!

Just read your post and altough i won't be able to help you remove the 880 limit, i wanted to say i think i might have encountered a similar limit on my San Andreas map and so i'm frustrated too. The original map is 410 ko big, and i have the feeling that as soon as i save my junction25 modified map and it's over 706 ko, the game won't work any more after ca. 30 seconds of playing. I get MGL fatal error 74.84 invalid case: 57

When i load my backup San Andreas map that is precisely 706 ko, it will run fine. As soon as i change anything (i tried various things, adding a road, removing some fences and so on) and it gets to 707 or 708 ko, i'll get the mgl fatal error.

I'll try posting this in a new topic, maybe someone knows something. At the moment it just sukks that i can't continue modifying my San Andreas map, just like it must sukk for you to be limited to 880 railways.

Cheers,

Silent Bob.

Derfel Link
  • Derfel Link

    Player Hater

  • Members
  • Joined: 17 Jul 2003

#3

Posted 22 August 2009 - 09:36 AM

Now that might be the reason why it wasn't working for me either!
Thanks for pointing it out.
Cheers




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users