Quantcast

Jump to content

» «
Photo

[REL | GTAIV]Simple Trainer for GTAIV

7,652 replies to this topic
Skroting
  • Skroting

    Rocket surgeon

  • Members
  • Joined: 03 Dec 2008

#61

Posted 26 January 2009 - 08:41 AM

QUOTE (FFxSTALKERx @ Jan 25 2009, 23:02)
awesome trainer. Pain to remember 20+ useful key combinations though

That's where a netbook comes in very handy! I always keep it on my desk with various info, maps and such. It's a good investment.

sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#62

Posted 26 January 2009 - 10:20 AM Edited by sjaak327, 26 January 2009 - 10:24 AM.

QUOTE (longboardskier @ Jan 26 2009, 04:40)
Ok, here's something crazy.  When I dropped in the newer version that you uploaded today where all the keys were customizable (replaced the older trainer.asi file AND trainer.ini with the new ones), my FPS was suddenly half of what it normally is.  So just to make sure I exited the game, went to the folder and took out the trainer.ini file and loaded the game back up.  Sure enough, my FPS were back to normal!

So with the newer one you put up today, my FPS is about 17 on average.  With the older one (where the only customizable one was the health), my FPS was 30!  There's something about the new .ini file with all the customization that the game doesn't like.

EDIT:  The only difference I could think of is the amount of data in the new .ini file, so I deleted all the other key bindings except the ones I remapped since if it wasn't there it would just go to default (I only edited 4 of them), but I still got a much lower FPS.

Well, the strange thing is that the method of getting the keys is exactly the same, but indeed I guess because of the large number of keys to be written, this is causing a drop in framerates.

Now I'm going to try and fix, for the time being indeed, making sure trainer.ini isn't in your game directory, should get you back to normal. (of course this will set you back to default keybindings).

I have to add though, that the ingame benchmark, is the same for me, only fraps is showing about 5 fps lower, even though the game doesn't feel lagging or slower to me.

lostcity666
  • lostcity666

    Player Hater

  • Members
  • Joined: 11 Jan 2009

#63

Posted 26 January 2009 - 12:16 PM Edited by lostcity666, 26 January 2009 - 12:21 PM.

Great mod!

I was just wondering, can I bind an action to my mouse? (say MMB or a button I have on the side)
And is it possible to make that bind for Car Speedup.

sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#64

Posted 26 January 2009 - 12:36 PM

QUOTE (lostcity666 @ Jan 26 2009, 12:16)
Great mod!

I was just wondering, can I bind an action to my mouse? (say MMB or a button I have on the side)
And is it possible to make that bind for Car Speedup.

Yes you can do, I guess I forgot to include the mouse keys into the list at the top of trainer.ini:

Left mouse button 1
Right mouse button 2
Middle mouse button 4

So if you want to assing this to the speedup car function, just scroll down until you find the entry, and change the value there to one of the above values.



neomatt
  • neomatt

    Player Hater

  • Members
  • Joined: 12 Jan 2009

#65

Posted 26 January 2009 - 01:19 PM Edited by neomatt, 26 January 2009 - 01:22 PM.

QUOTE (sjaak327 @ Jan 25 2009, 23:58)
@sjaak327
Well, I changed the rar archive about 30 minutes ago.

the dates of trainer.ini and trainer.asi should be:

trainer.ini 25-1-2009 20.20
trainer.asi 26-1-2009 1.08


It was my Firefox, I don;t know why it gives me the old version to download. I downloaded the trainer via Explorer 7 and I got the newest trainer.

Thanks so much!

Isaackungfu
  • Isaackungfu

    Player Hater

  • Members
  • Joined: 05 Jan 2009

#66

Posted 26 January 2009 - 07:42 PM

Great trainer!
Can you add always Unlimited Ammo and never reload?
Thank you!

HomeInmyHEad
  • HomeInmyHEad

    Player Hater

  • Members
  • Joined: 03 Dec 2008

#67

Posted 27 January 2009 - 04:48 AM

How to you unbind codes i want to unbind the F8 player changer since i already have another player selecter i got to trainer.ini and set the set code to 0 does nothing still binded i delete the F8 from the key section and the code is still binded i cant get rid of it.

I must be not understanding something help thanks

Szajoli
  • Szajoli

    Player Hater

  • Members
  • Joined: 27 Jan 2009

#68

Posted 27 January 2009 - 05:19 AM

QUOTE (longboardskier @ Jan 26 2009, 04:40)
Ok, here's something crazy. When I dropped in the newer version that you uploaded today where all the keys were customizable (replaced the older trainer.asi file AND trainer.ini with the new ones), my FPS was suddenly half of what it normally is. So just to make sure I exited the game, went to the folder and took out the trainer.ini file and loaded the game back up. Sure enough, my FPS were back to normal!

So with the newer one you put up today, my FPS is about 17 on average. With the older one (where the only customizable one was the health), my FPS was 30! There's something about the new .ini file with all the customization that the game doesn't like.

EDIT: The only difference I could think of is the amount of data in the new .ini file, so I deleted all the other key bindings except the ones I remapped since if it wasn't there it would just go to default (I only edited 4 of them), but I still got a much lower FPS.

I have this problem too ! i tried whit 2 asi loader sad.gif

sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#69

Posted 27 January 2009 - 10:39 AM

QUOTE (Szajoli @ Jan 27 2009, 05:19)
QUOTE (longboardskier @ Jan 26 2009, 04:40)
Ok, here's something crazy.  When I dropped in the newer version that you uploaded today where all the keys were customizable (replaced the older trainer.asi file AND trainer.ini with the new ones), my FPS was suddenly half of what it normally is.  So just to make sure I exited the game, went to the folder and took out the trainer.ini file and loaded the game back up.  Sure enough, my FPS were back to normal!

So with the newer one you put up today, my FPS is about 17 on average.  With the older one (where the only customizable one was the health), my FPS was 30!  There's something about the new .ini file with all the customization that the game doesn't like.

EDIT:  The only difference I could think of is the amount of data in the new .ini file, so I deleted all the other key bindings except the ones I remapped since if it wasn't there it would just go to default (I only edited 4 of them), but I still got a much lower FPS.

I have this problem too ! i tried whit 2 asi loader sad.gif

Yes, I'm aware of this problem, and working on it, I hope to have something tomorrow, for now, just leave trainer.ini out of the GTAIV directory.


sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#70

Posted 27 January 2009 - 10:42 AM

QUOTE (HomeInmyHEad @ Jan 27 2009, 04:48)
How to you unbind codes i want to unbind the F8 player changer since i already have another player selecter i got to trainer.ini and set the set code to 0 does nothing still binded i delete the F8 from the key section and the code is still binded i cant get rid of it.

I must be not understanding something help thanks

To unbind the F8:

ChangeModel2Key1=163 //Change Models 2, Default RCTRL
ChangeModel2Key2=119 //Change Models 2, Default F8

change either the first or the second key to 0

ChangeModel2Key1=0 //Change Models 2, Default RCTRL
ChangeModel2Key2=119 //Change Models 2, Default F8


buzbegone
  • buzbegone

  • Members
  • Joined: 27 Jun 2007

#71

Posted 27 January 2009 - 12:27 PM Edited by buzbegone, 27 January 2009 - 01:06 PM.

Yeah, I want to unbind F6 but I didn't understand a thing you said
Do I copy and paste that code somewhere in the trainer.ini or do I put 0 value next to F6?

Also, does anyone have the cooridinates to the top of Rotterdam Tower, I mean the very top

sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#72

Posted 27 January 2009 - 02:20 PM

QUOTE (buzbegone @ Jan 27 2009, 12:27)
Yeah, I want to unbind F6 but I didn't understand a thing you said
Do I copy and paste that code somewhere in the trainer.ini or do I put 0 value next to F6?

Also, does anyone have the cooridinates to the top of Rotterdam Tower, I mean the very top

Maybe I'm not entirely clear.

Let me try and explain it more clearly smile.gif

First of all, this trainer doesn't have a function binded to F6, if you use another mod that uses F6 directly, there is nothing you have to do. Both this trainer and the other mod will work fine.

The bindings that involve F6 are RCTRL+F6 and RALT+F6.

to change that, go into the trainer.ini file, don't copy paste anything, just:

NeverTiredKeyOn1=163 //NeverTired On, Default RCTRL
NeverTiredKeyOn2=117 //NeverTired On, Default F6
NeverTiredKeyOff1=165 //NeverTired On, Default RALT
NeverTiredKeyOff2=117 //NeverTired On, Default F6

Only change the numeric values after =. for instance to change the RCTRL+F6 to RCTRL+F5 you would do:

NeverTiredKeyOn1=163 //NeverTired On, Default RCTRL
NeverTiredKeyOn2=116 //NeverTired On, Default F6

so you change the value of the second key from 117 to 116. If you want to change the RCTRL, of course you change the 163 value to something else. To disable the RCTRL+F6 option (it will not be usable in the game anymore) change one value to 0 or both, same result.

buzbegone
  • buzbegone

  • Members
  • Joined: 27 Jun 2007

#73

Posted 27 January 2009 - 02:27 PM Edited by buzbegone, 27 January 2009 - 02:32 PM.

Actually, there is a direct key for F6

QUOTE
F6 Always Run On/Off


By the way, the mod I'm using simply enables ragdoll mode by pressing F6 so you can attach yourself to a car and let it keelhaul you beside or behind it

sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#74

Posted 27 January 2009 - 02:32 PM

QUOTE (buzbegone @ Jan 27 2009, 14:27)
Actually, there is a direct key for F6

QUOTE
F6 Always Run On/Off

That has been changed, it's now RCTRL+6 to enable and RALT+F6 to disable, that was changed last sunday.

See also the OP (first post of this thread).


buzbegone
  • buzbegone

  • Members
  • Joined: 27 Jun 2007

#75

Posted 27 January 2009 - 02:32 PM Edited by buzbegone, 27 January 2009 - 02:46 PM.

Must have an old version, thanks

After adding the new version of your trainer, my framerate started suffering greatly
What's going on?

sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#76

Posted 27 January 2009 - 02:52 PM

QUOTE (buzbegone @ Jan 27 2009, 14:32)
Must have an old version, thanks

After adding the new version of your trainer, my framerate started suffering greatly
What's going on?

Yes I know, it's because of the trainer.ini, for now just delete it from the GTAIV directory, there are just too much keybindings that the program needs to read, I'm in the process of changing this.


buzbegone
  • buzbegone

  • Members
  • Joined: 27 Jun 2007

#77

Posted 27 January 2009 - 03:30 PM

Alright, framerate's much better
Thanks again for all your help and your quick responses

buddhaken
  • buddhaken

    Player Hater

  • Members
  • Joined: 27 Jan 2009

#78

Posted 27 January 2009 - 05:45 PM Edited by buddhaken, 27 January 2009 - 06:03 PM.

the trainer works...up to a point.
it worked last night with god mode. but playing today it doesnt work.
is there anything i need to do?

using the xliveless dll file. because the asiloader wouldn't allow the game to boot up. the dsound.dll file that is.

but like carspawn works just fine. have any ideas?

edit - seemed like it worked when i enabled the trainer outside of the apartment, and god mode worked. but when i start playing the mission where you go to the boat yard to steal the drugs, it stops working. the unlimited ammo cheat works. but not god mode. whats going on?

HomeInmyHEad
  • HomeInmyHEad

    Player Hater

  • Members
  • Joined: 03 Dec 2008

#79

Posted 27 January 2009 - 06:19 PM

QUOTE (sjaak327 @ Jan 27 2009, 10:42)
QUOTE (HomeInmyHEad @ Jan 27 2009, 04:48)
How to you unbind codes i want to unbind the F8 player changer since i already have another player selecter i got to trainer.ini and set the set code to 0 does nothing still binded i delete the F8 from the key section and the code is still binded i cant get rid of it.

I must be not understanding something help thanks

To unbind the F8:

ChangeModel2Key1=163 //Change Models 2, Default RCTRL
ChangeModel2Key2=119 //Change Models 2, Default F8

change either the first or the second key to 0

ChangeModel2Key1=0 //Change Models 2, Default RCTRL
ChangeModel2Key2=119 //Change Models 2, Default F8

sorry to bother sjaak but i still can't seem to get it working
i bind

ChangeModel2Key1=163 //Change Models 2, Default RCTRL
ChangeModel2Key2=0 //Change Models 2, Default F8

into the [key bindings] section right?

i tryed both
ChangeModel2Key1=0 //Change Models 2, Default RCTRL
ChangeModel2Key2=0 //Change Models 2, Default F8

and

ChangeModel2Key1=0 //Change Models 2, Default RCTRL
ChangeModel2Key2=116 //Change Models 2, Default F8

still keeps switching characters when i press F8
i have the grab mod so i can grab onto cars and i want F8 free for that script.








sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#80

Posted 27 January 2009 - 06:24 PM

QUOTE (buddhaken @ Jan 27 2009, 17:45)
the trainer works...up to a point.
it worked last night with god mode. but playing today it doesnt work.
is there anything i need to do?

using the xliveless dll file. because the asiloader wouldn't allow the game to boot up. the dsound.dll file that is.

but like carspawn works just fine. have any ideas?

edit - seemed like it worked when i enabled the trainer outside of the apartment, and god mode worked. but when i start playing the mission where you go to the boat yard to steal the drugs, it stops working. the unlimited ammo cheat works. but not god mode. whats going on?

There are two godmodes, one is the normal godmode, (RCTRL+F1) this works unless there is a cutscene (as in a mission), then the game itself is disabling the god mode.

To keep the godmode active all the time, use the =+ key (the key next to the backspace key). It is called always godmode for a reason smile.gif


sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#81

Posted 27 January 2009 - 06:31 PM Edited by sjaak327, 27 January 2009 - 06:38 PM.

QUOTE (HomeInmyHEad @ Jan 27 2009, 18:19)
sorry to bother sjaak but i still can't seem to get it working
i bind

ChangeModel2Key1=163  //Change Models 2, Default RCTRL
ChangeModel2Key2=0  //Change Models 2, Default F8

into the [key bindings] section right?

i tryed both
ChangeModel2Key1=0 //Change Models 2, Default RCTRL
ChangeModel2Key2=0  //Change Models 2, Default F8

and

ChangeModel2Key1=0  //Change Models 2, Default RCTRL
ChangeModel2Key2=116  //Change Models 2, Default F8

still keeps switching characters when i press F8
i have the grab mod so i can grab onto cars and i want F8 free for that script.

I think you somehow have an old version of trainer.asi, as the game isn't binding F8, it binds to RCTRL+F8.

If you press F8 in the game, nothing should happen (at least not caused by the trainer). Otherwise delete trainer.asi from the GTAIV directory, and redownload, or put it back into the directory from the archive.

If you do have an old version of the trainer.asi, then changing things in trainer.ini won't have any affect. But surely pressing F8 alone will not change models on the latest trainer.asi.

You might be aware that there is a problem with the trainer.ini file at the moment (I'm working on a fix) so if you only need to unbind F8, then just download the newest trainer.asi, and don't put trainer.ini in the GTAIV directory.

Or wait a few hours, as I think I have fixed the issue smile.gif

I have greatly reduced the number of configurable keybindings, as I had over 230 !. Now it will still be highly configurable, but it won't cause any fps slowdown. Give me a few hours to properly test it and I will release it.


HomeInmyHEad
  • HomeInmyHEad

    Player Hater

  • Members
  • Joined: 03 Dec 2008

#82

Posted 27 January 2009 - 08:45 PM

Ahh that might be the problem
but either way you have a disable key that took me awhile find out that you had monocle.gif
it kinda deludes the purpose of disabling the key
for me that is lol.gif

ill be sure to download the updated ini file tho
thanks a bunch : biggrin.gif

*idea* a simple ingame menu (shows you the keys and codes) would make the trainer fly with soaring colors

sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#83

Posted 27 January 2009 - 09:11 PM

Okay, I have fixed the problem with lower framerates due to reading of the trainer.ini file.

I would urge every one that downloaded this trainer between 26-1 at around 1 am CET and 27-1 around 10 PM CET to redownload the trainer, delete trainer.asi, trainer.ini from the GTAIV directory, and copy the new files back in.

@HomeInmyHEad

Yes you can also disable the trainer, by pressing RCTRL+RALT+D, but again you can redifine the keys if needed. Just make sure to download the new version, and replace the files properly.

I don't think an ingame menu is in the works, This trainer uses all native commands, there is no directx hook or anything, and to be honest, I kind of like it this way.

That's why this is a simple trainer smile.gif

topeira
  • topeira

    Playa

  • Members
  • Joined: 16 Jun 2005

#84

Posted 27 January 2009 - 11:16 PM

hey everyone.

for an easier use of this mod i made a DOC file (word document) that is easy to read and easy to print (2 pages with 2 columns).
basically i made it for myself but i am sure many of u are mind bogled with the key combinations and would like to have a comfortable list of key.

DL it here:

List of options

http://www.mediafire...mjmc2cmxfx/List of options.doc

sjaak, if u want to add this to your archive - feel free to do so.

buzbegone
  • buzbegone

  • Members
  • Joined: 27 Jun 2007

#85

Posted 28 January 2009 - 07:34 AM

I thought my framrate would be better but it isn't
Disregard what I said before because I deleted the trainer.ini and my framerate is still suffering, what's going on?

sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#86

Posted 28 January 2009 - 07:53 AM Edited by sjaak327, 28 January 2009 - 07:57 AM.

QUOTE (buzbegone @ Jan 28 2009, 07:34)
I thought my framrate would be better but it isn't
Disregard what I said before because I deleted the trainer.ini and my framerate is still suffering, what's going on?

Like I said, the version before V 1.0 had a problem with framerates dropping, deleting trainer.ini from GTAIV directory would result in an instant framerate boost, as the reason for the drop was the reading of that file, if it can't read the file, it would simply replace the vaules with default values, hence not doing the work that resulted in the drop.

The trainer with version 1.0 (uploaded yesterday evening, doesn't have this problem, and your framerate shouldn't dorp, I have tested this yesterday evening on my rather dated machine. My framerates are consistent with the ones I would get when not running the trainer at all.

So simply redownload, making sure both trainer.asi and trainer.ini have the date 27-1-2009, making sure they are properly replaced in the GTAIV folder, should not have an influence on your framerates.

Auxrilla
  • Auxrilla

    GTA 4 Life

  • Members
  • Joined: 12 Oct 2008

#87

Posted 28 January 2009 - 04:12 PM

i have a problem, the god mode dont work for me i see a message that it is enable but if a car hit me or a bullet my life goes down ?

sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#88

Posted 28 January 2009 - 05:02 PM

QUOTE (Auxrilla @ Jan 28 2009, 16:12)
i have a problem, the god mode dont work for me i see a message that it is enable but if a car hit me or a bullet my life goes down ?

There are two godmodes, one is the normal god mode, this is not permanent, ie. if you do missions it will get reset by the game. Therefore use always god mode =+ key.


Auxrilla
  • Auxrilla

    GTA 4 Life

  • Members
  • Joined: 12 Oct 2008

#89

Posted 28 January 2009 - 05:06 PM

QUOTE (sjaak327 @ Jan 28 2009, 18:02)
QUOTE (Auxrilla @ Jan 28 2009, 16:12)
i have a problem, the god mode dont work for me i see a message that it is enable but if a car hit me or a bullet my life goes down ?

There are two godmodes, one is the normal god mode, this is not permanent, ie. if you do missions it will get reset by the game. Therefore use always god mode =+ key.

i found it a few sec ago out thx nice trainer btw realy cool icon14.gif icon14.gif icon14.gif

porkie0.0
  • porkie0.0

    Player Hater

  • Members
  • Joined: 12 Jan 2009

#90

Posted 29 January 2009 - 02:18 AM

are u able to add a super brake to it also? like car boost it needs 2 stop like instantly smile.gif
im using this mod atm its very nice
also what about a colour changer for vehicles that u spawn? (when in vehicle)
Thanks. Great trainer.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users