Quantcast

Jump to content

» «
Photo

GTA IV + Windows 7 + Press key = mini studder?

48 replies to this topic
guyderam
  • guyderam

    Player Hater

  • Members
  • Joined: 29 May 2010

#31

Posted 29 May 2010 - 11:41 AM

hey there... i tried turning off the windows event log service and when i restarted my pc, im unable to connect to my broadband connection...... But in able to connect to broadband after turning on the service again... haiz.... Running on win7 home premium 64bit. Similar prob wif the keyboard..

mprikiman
  • mprikiman

    Player Hater

  • Members
  • Joined: 30 Jun 2010

#32

Posted 30 June 2010 - 02:24 PM

I registered to this forum, just to say a big fat THANKS to you Hexed and Slunken. [SIZE=7]Took me some time to notice that lag was caused by keystrokes and at first I thought it was just my new laptop overheating. That just was not the case since I did the test also in an airconditioned room. Thanks again and have fun you people!!!! inlove.gif
Best wishes from Greece! rampage_ani.gif

MOKAGAG
  • MOKAGAG

    Player Hater

  • Members
  • Joined: 04 Sep 2010

#33

Posted 06 September 2010 - 08:50 AM

QUOTE (HeXeD @ Jan 14 2009, 21:34)
Does anyone else have this behaviour so far? I have looked through almost every windows-7 thread here and I have seen one person who has the same problem but no mention of anyone else or any troubleshooting. Hopefully this thread can help out those people cause so far I have only had ONE problem with Windows-7... this one. If I can't get my GTA IV fix in within the next week I think I'm gonna have to go back to Vista...ugggg. So here is the info:

Specs:
Intel Q6600 @3.2GHz
Gigabyte GA-P35-DS3L Motherboard
4G Patriot PC6400
ATI Radeon HD 4850
320G Seagate 7200.10 SATA
Creative Soundblaster X-Fi Fatality edition
Logitech Bluetooth Keyboard
Microsoft Habu Gaming Mouse
24" Samsung 2493BW (1920x1200) & 42" 1080p Westinghouse (1920x1080)

Problem:
Everytime I press a key on the keyboard, the game freezes very quickly. We are talking about a ~250ms pause (1/4 a second). Just say I am in a car. If I use my mouse to scroll around the car, absolutely NO brief pauses or framerate issues. Once I press forward (W) to go, I will get a very brief pause but as long as I hold that button down, the care will keep going faster and faster with absolutely NO skipping/pausing/FPS issues. The second I press left (A) or right (D) I will get another breif skip. When you are hauling ass in a car, once that 1/4 of a second video pause catches up to where you are, you are most likely going to crash. I cannot play the game in this fashion. If you press a button once, and hold it, you can continue to hold buttons without the pause, but the second you press another button you will get the brief pause or studder. When you hit several buttons the pause/studder lasts much longer. If you are trying to bob and weave from the cops, while pressing different buttons (Up, left, right, run, jump) you might as well forget it because it chokes the video up very badly.

What I have tried to resolve the issue:
1. Reinstall
2. New drivers (went from the 8.12 Vista drivers from ATI to their Beta Windows 7 driver) was a huge PITA to uninstall the Vista drivers from Windows 7, specifically the Catalyst control center.
3. New drivers for my chipset
4. Uninstalled Sound Card and ran without sound. Still studder
5. Tried to mess with the Affinity of the GTAIV executable while it was running. Turned it to only using 1 core.. game ran like complete crap..and it STILL had the keyboard pausing. Tried 2 cores, same thing. When I did this the sounds was completely messed up.
6. Tried to mess with the priority of GTAIV.exe, set it to high and it did nothing.
7. Tried running the EXE in Win XP and Vista compatability mode, and not one of them even allowed me to launch the game. From what I have seen from people that are not having a problem is this should not be necessary at all.


The only thing I have no tried is a regular USB keyboard. Only thing I can think of is it is some sort of problem with the bluetooth or the way Windows 7 handles the drivers for my logitech, but I am only using what is automatically installed.


Of course everyone knows that Windows 7 is beta, and that it is not supported by Rockstar. But I think this could be an issue we find a resolution for if we put our heads together. The only thing I am worried about is not many people have reported having this issue.

Would be a shame to have to ditch Windows 7 for Vista just because of GTA, but I will definitely do it. GTA IV seems to run VERY smooth on Windows 7...provided I hold down the up arrow and drive in a straight line. confused.gif

I have the same exact same problem....
I didn't find a solution yet

Specs

CPU: Intel i5 661 @ 3.33GHz
RAM: 4 GB
Graphics: ATI Radeon HD 5770 1 GB
OS: Windows 7 Professional 64-bit
PSU: 750W
Monitor: Acer 18.5''

DeimosBarret
  • DeimosBarret

    Player Hater

  • Members
  • Joined: 12 Oct 2010

#34

Posted 12 October 2010 - 10:00 PM

THANK YOU SO MUCH! indeed, the windows event logger. Works great now biggrin.gif

zkolo
  • zkolo

    Player Hater

  • Members
  • Joined: 18 Dec 2010

#35

Posted 20 December 2010 - 06:53 PM

Oh help me plz
windows event log doen not work for me...

DocMenach
  • DocMenach

    Player Hater

  • Members
  • Joined: 09 Jun 2005

#36

Posted 20 December 2010 - 10:07 PM

I am using Windows 7 64-bit and do not have any problems with stuttering (from keypresses or otherwise) in GTA IV or any other game. I have not had to disable logging. My specs are:
Intel Core i5 760 (2.8GHz)
Sapphire Radeon HD6850, 1GB (10.12 Catalyst drivers)
8 GB Gkill DDR3 RAM
Logotech USB wireless keyboard and mouse
Logitech Cordless Rumblepad 2
drives etc.

I use Keyboard/Mouse for on foot and the gamepad in the car. Again, I have zero issues, and very smooth framerates with most settings turned up. I did have some very constant strange stuttering issues when I tried to run the game unpatched, but after patching the game everything was perfect.

mkey82
  • mkey82

    Keep riding hard, son

  • Members
  • Joined: 14 Feb 2008

#37

Posted 21 December 2010 - 06:23 AM

^^^^ What's the point of your post?

zkolo, are you sure the service is stopped? Have you rebooted the machine after disabling it? Do you have another keyboard you can try out?

DocMenach
  • DocMenach

    Player Hater

  • Members
  • Joined: 09 Jun 2005

#38

Posted 21 December 2010 - 04:14 PM

QUOTE (mkey82 @ Dec 21 2010, 06:23)
^^^^ What's the point of your post?

The point of my post was that earlier in the thread someone asked people who are using Windows 7 and not having problems to post info also, in case there were some clues there.

microtek
  • microtek

    Player Hater

  • Members
  • Joined: 25 Dec 2008

#39

Posted 03 April 2011 - 08:35 PM

QUOTE (HeXeD @ Jan 15 2009, 04:14)
QUOTE (mazucaaa @ Jan 14 2009, 23:41)
QUOTE (HeXeD @ Jan 14 2009, 22:58)
QUOTE (creat3d22 @ Jan 14 2009, 22:19)
Right, if the whole game pauses/skips instead of just the player movement being delayed I guess it's something else.
I don't keep up to date on Win7 but do you know when the next beta version is coming out? Maybe it's an OS issue since it's still just a beta...

Did you have that problem in Vista? Does the problem occur with other games in Win7?

Yeah.. it's pretty much the ENTIRE game pauses for a breif second, but the sound is still in sync.

The video frame when you press the button is displayed (frozen) but only for VERY small time and then it skips to the frame it is supposed to be on half a second later or so. Hopefully I can get a fraps video of the issue, but it ONLY happens when I press a key on the keyboard.

I could even press a key not mapped to movement (ex. Horn) and it will give me a brief freeze. However, if I get on a LONG straight road, I can hold down "UP" and drive in the middle of the road crushing cars and killing pedestrians with absolutely NO frame skips, freezes, studders, etc..etc. It's like the game works perfectly until I actually try to control it with the keyboard.

I have no clue when the next beta comes out, but I will certainly be checking it out as soon as I can because I have a feeling it is OS related too... most definitely. It does not happen in Vista, and it does not occur with other games in Windows 7... such as COD4 and Fallout 3 (which both run like a dream).

the only reason I am not back on Vista is MANY people are playing this game with no problems in Windows 7 which leads me to believe it is more of a hardware configuration/incompatability that is causing this freak "bug" I am seeing. If I can find people who have the same issue, maybe we can find out what the similarities are so we can squash this and I can contiinue using Windows 7.

dude, im having the exactly same problem here.... its frustrating because when im not touching the keyboard i can see that the game is running much smoother than it was in vista.... but as soon i touch the keyboard the freezing starts.... confused.gif

one thing i noticed...that doesnt happen when i use the controller..... ( but now the game crashes when a try to use a gun )

Well.. thats 1 person having the issue..

What are your specs? Whats drivers are you using? What have you tried to resolve the issue? What build of the beta? I'm on 7000. Is this a cleaan install? 64-bit version? Mine is 64-bit.

Here is what I have tried tonight....

I have tried to set the compatability mode to windows 2000 on the "launchgta.exe and gtaIV.exe".
I have tried a simple Dell wires USB keyboard

I have not tried to just play with my xbox 360 controller, but to be honest.. I can't STAND using the controller. That is the primary reason I wait till the PC version comes out.


And for those of you who ARE NOT having this issue, what are your specs? What build of windows 7 are you on and is it 64-bit? Any information would be good, and the more information the more we can put our heads together and fix this issue.

hii
i have acer 5742g laptop with...
core i3
3gb ram
nvidia gforce 540m ....1 gb
500 gb hdd..
i too expirience the lagging problem...even with low settings..
plz help...sugest the perfect settings...

mirmsauce
  • mirmsauce

    Player Hater

  • Members
  • Joined: 24 Apr 2011

#40

Posted 24 April 2011 - 09:13 PM

I just wanted to register to say thanks. Disabling the event logger fixed the stuttering.

What in the event logger causes the stuttering, just curious

Thanks guys you are awesome

Ghost glendale fan 4 live
  • Ghost glendale fan 4 live

    Libby-Ketchup city!

  • BUSTED!
  • Joined: 20 Jul 2007

#41

Posted 13 June 2011 - 01:25 AM Edited by Ghost glendale fan 4 live, 15 June 2011 - 06:39 PM.

Thanks Hexed, You made my day. biggrin.gif It's fixed. ^^

indianemokid
  • indianemokid

    Player Hater

  • Members
  • Joined: 15 Jun 2011

#42

Posted 15 June 2011 - 03:39 AM

iam experiencing same type of prob....n just found a solution on some site

Question: The game seems to be running in Windows 7 64-bit Ultimate but every time I press a key on the keyboard the game flashes and lags with short freezes and hiccups. How can I fix this?

[ I]Answer: The most common reason for the game flashing and pausing briefly every time a key is pressed is a conflict between the game and the Windows Event Log. Please turn off Windows Event Log in Windows Services (msconfig).
[/I]


my pc config is -

intel I5-2400 @ 3.10 ghz
4 GB DDR3 ram,
NVIDIA geforce 9400 gt(1gb) graphics card....

hope this may help you ...

iTRiP
  • iTRiP

    Rat

  • Members
  • Joined: 21 Feb 2009

#43

Posted 24 June 2011 - 03:08 AM Edited by iTRiP, 18 August 2012 - 01:53 PM.

...

KPaNxxx
  • KPaNxxx

    Player Hater

  • Members
  • Joined: 10 Mar 2012

#44

Posted 10 March 2012 - 06:16 AM

Even i am experiencing the same problem.
My Laptops specifications are :
1.2 GB NVidia GT540m
2.Intel i5
3.4 GB ram
4.750 GB HDD

I bought a genuine copy a GTA4 last month. The whole game runs smoothly (graphics are full) BUT whenever i press a key in stutters for about half a sec and then goes smoothly, like i am driving my car and when i press W it stutters and then goes smoothly and when i press A or D the same thing happens. Is it the problem with the Game copy or any other thing? Please help me out!

And yes...i have Windows 7 Ultimate 64 bit (genuine)

Regor245
  • Regor245

    Player Hater

  • Members
  • Joined: 17 Feb 2012

#45

Posted 10 March 2012 - 07:54 AM

QUOTE (KPaNxxx @ Saturday, Mar 10 2012, 06:16)
Even i am experiencing the same problem.
My Laptops specifications are :
1.2 GB NVidia GT540m
2.Intel i5
3.4 GB ram
4.750 GB HDD

I bought a genuine copy a GTA4 last month. The whole game runs smoothly (graphics are full) BUT whenever i press a key in stutters for about half a sec and then goes smoothly, like i am driving my car and when i press W it stutters and then goes smoothly and when i press A or D the same thing happens. Is it the problem with the Game copy or any other thing? Please help me out!

And yes...i have Windows 7 Ultimate 64 bit (genuine)

HA! this thread is almost 1 year old, it's better if you've just created your own thread.

anyways, do you have patch installed?

Try 1.0.4.0, It's a patch for Windows 7 users since the Game Came out a year before windows 7 did, it includes all previous fixes from older patches.

patch 1.0.7.0

You can try 1.0.7.0. but other says that patch is laggy or performance decreased.

Chinmay99
  • Chinmay99

    Player Hater

  • Members
  • Joined: 13 Jul 2012

#46

Posted 13 July 2012 - 07:54 AM

Im unable to see any location behind the player...also nothing except ma player is visible in the game...whats the solution for this??im running it on win 7 with a 1GB nVidia graphic card

Prometheus
  • Prometheus

  • Inactive Staff
  • Joined: 18 Apr 2011
  • None

#47

Posted 13 July 2012 - 07:56 AM

QUOTE (Chinmay99 @ Friday, Jul 13 2012, 07:54)
Im unable to see any location behind the player...also nothing except ma player is visible in the game...whats the solution for this??im running it on win 7 with a 1GB nVidia graphic card

Make a new topic in this section, and make sure to specify the problem and your PC specifications.

dead.night7
  • dead.night7

    Player Hater

  • Members
  • Joined: 19 May 2011

#48

Posted 22 March 2013 - 09:34 AM

Thanks for this thread THANK U SOOOO MUCH THREAD STARTER, I had issues of the game getting lagged out with pressing of space key bar and s key not those which u told but still i stopped F*&#ing windows event log aaannnd done!!!... Whoo hoo now i can live happilly ever after

Aeternus
  • Aeternus

    Player Hater

  • Members
  • Joined: 19 Mar 2013

#49

Posted 23 March 2013 - 12:39 AM

GTA 5 In-Game Video Developers Version LEAKED!!!!!


This game is going to be so AWESOME!




User warned for spamming




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users