Quantcast

Jump to content

» «
Photo

Could not write license data!

5 replies to this topic
Vodka 177
  • Vodka 177

    Player Hater

  • Members
  • Joined: 07 Dec 2008

#1

Posted 07 January 2009 - 03:58 PM

Been running GTA4 for about 2 weeks now.

Was playing last night when suddenly screen goes black. No error codes.
Shrugged.
Rebooted machine.
Restarted social club.
Tried to play but now I get the following message "Could not write license data!
Please contact Customer Support for further instructions."

Tried to repair game.
No joy.

Anyone any ideas on this?

Need to add it is a genuine copy of the game.

Rockstar Toronto
  • Rockstar Toronto

    Rockstar Games Technical Support

  • Members
  • Joined: 04 Dec 2008
  • None

#2

Posted 07 January 2009 - 08:35 PM

Please contact securom at [email protected]

travelmeister2
  • travelmeister2

    Player Hater

  • Members
  • Joined: 08 Feb 2009

#3

Posted 08 February 2009 - 09:20 PM

Answer to 'GTA 4 Could not write license data!' or sort of?

For some reason after hoovering my pc and moving wires around etc I got this msg. I searched on google and ended up doing this which worked

This step was from another forum for securerom problems:

1. Open the command line by pressing Start and selecting the Run... option.
2. Type cmd and push the [Enter] button on the keyboard.
3. Please type in rd /s "%APPDATA%\SecuROM" and press [Enter] on the keyboard.
4. Answer Y to the Y/N question and press [Enter] to complete the process.

The folder should now be deleted. Please understand that any SecuROM application

that uses UserData will rebuild these files and folder with future launches.

THe game started but stopped working after the first main screen with text on it. Luckily I had copied my
User data stuff as a back up: c:\users\$name$\appdata\local\rockstargames\ so I copied back this entire folder and replaced it.

The game then worked 100% Hope parts of this might help anyone with a similar problem

Jakuza
  • Jakuza

    Player Hater

  • Members
  • Joined: 15 Jun 2009

#4

Posted 02 January 2010 - 11:31 PM

I just had the same problem,and i did everything like travelmeister2,but i didn't backup those files.Can someone upload that folder?PLS cryani.gif

mkey82
  • mkey82

    Keep riding hard, son

  • Members
  • Joined: 14 Feb 2008

#5

Posted 03 January 2010 - 11:29 AM

That folder is user specific and you need your own files. Try a repair installation, it should fix it.

rnarm
  • rnarm

    Player Hater

  • Members
  • Joined: 17 Apr 2013

#6

Posted 17 April 2013 - 11:25 PM

I had this error for both GTA4 and GTA:Episodes. I found then when the games the very first time I installed them, however the next day I got the "Could not write license data" securom error. I tried this fix as suggested by other forums but it did not work:

This step was from another forum for securerom problems:
1. Open the command line by pressing Start and selecting the Run... option.
2. Type cmd and push the [Enter] button on the keyboard.
3. Please type in rd /s "%APPDATA%\SecuROM" and press [Enter] on the keyboard.
4. Answer Y to the Y/N question and press [Enter] to complete the proces

What worked was the following
I found through a (perceived) separate issue was that I was having problem with some windows installers which was due to my temp folder not having the correct permission set up. I believe that the securom messes with the temp folder permissions in some manner.

To fix:
1. Click start and type in "%userprofile%\appdata\local" in to start
2. Right click temp, click properties and then the sharing tab.
3. Click edit and then add your username under "enter the object names to select" and click ok
4. Give your username full control under security and click ok.
Here is the same fix with pictures: link


The game should now work!




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users