Quantcast

Jump to content

» «
Photo

Obscure tweak that really helped me

12 replies to this topic
nojas
  • nojas

    Player Hater

  • Members
  • Joined: 04 Jan 2009

#1

Posted 07 January 2009 - 01:54 AM

Yesterday I found that in order to prevent RESC10 crashes on all Nvidia drivers, I had to disable the setting for "pre-rendered frames".

This is a poor workaround, as overall fps suffers, but the game doesn't crash.

Now I have found that due to the way GTA4 is coded, it cannot run properly with a common XP and Vista memory "tweak".

google: DisablePagingExecutive

It is somethiing which is set by many pointless programs such as Registry Mechanic and TuneUp Utilities etc etc.

Reset this value to 0, which is how XP and Vista are at default and GTA plays much better with "pre-rendered frames".

Most games play fine with or without this tweak but, at least on my system, GTA4 does not.


This could very well be something Rockstar never tested for....

Moral of the story is - You really can over "optimize" your pc to death.


babarian225
  • babarian225

    Punk-ass Bitch

  • Members
  • Joined: 06 Dec 2008

#2

Posted 07 January 2009 - 01:59 AM

Its Go and wet your Bed time!

nojas
  • nojas

    Player Hater

  • Members
  • Joined: 04 Jan 2009

#3

Posted 07 January 2009 - 02:03 AM

QUOTE (babarian225 @ Jan 7 2009, 01:59)
Its Go and wet your Bed time!

suicidal.gif

Just trying to help people who have pimped their sh*t too much.

Angry Elwood
  • Angry Elwood

    Player Hater

  • Members
  • Joined: 25 Jun 2005

#4

Posted 07 January 2009 - 04:13 AM

Thanks for the "Pre Rendered Frames" tip, that just let me play for 3 hours and it never crashed or stuttered. My previous record was about 30 minutes before a crash, and it always stuttered after a while. Granted you do take a sizeable FPS hit, but it least it works. As far as DisablePagingExecutive in my registry it was already at 0.

Well at least I can play now, I'll try to tweak my fps back up some now that the game is finally stable.

Rockstar, if you do skim these posts, if the problem is users not keeping their systems up to date, how the hell does one setting in my video card options take me from 100% crash to 100% stable?

nojas
  • nojas

    Player Hater

  • Members
  • Joined: 04 Jan 2009

#5

Posted 07 January 2009 - 05:11 AM

Hope rockstar can put something in the next patch related to this one.


Kurgen
  • Kurgen

    Old Git

  • Members
  • Joined: 16 Aug 2002

#6

Posted 07 January 2009 - 07:59 AM

QUOTE (babarian225 @ Jan 7 2009, 01:59)
Its Go and wet your Bed time!

What was that all about?


mYkSiNaToR
  • mYkSiNaToR

    Square Civilian

  • Members
  • Joined: 05 Dec 2008

#7

Posted 25 January 2009 - 10:08 AM

But I don't understand - how to do this, where should I go to disable this stuff...

mYkSiNaToR
  • mYkSiNaToR

    Square Civilian

  • Members
  • Joined: 05 Dec 2008

#8

Posted 25 January 2009 - 10:50 AM

Okay, I managed to set it to 1, this stuff. And it STILL freezes. Now I will try the suggestion here - http://www.gtaforums...howtopic=394047

Subversion1337
  • Subversion1337

    IPISubversion

  • Members
  • Joined: 11 Feb 2009

#9

Posted 11 February 2009 - 10:39 PM


I get random and too frequent PC freezes requiring restart of system also. Still looking for a fix.

Specs:

- Intel Core i7 920 CPU
- Gigabyte EX58 UDP4 Motherboard
- 6 Gb of DDR3 1333 MHz RAM
- GeForce 9800 GT
- Windows XP Service Pack 3
- Newly and correctly installed system, latest drivers for everything, latest patches
- 55 fps benchmark

elBATCHo
  • elBATCHo

    ROIDEDOUT450S

  • Members
  • Joined: 18 Dec 2008

#10

Posted 11 February 2009 - 10:50 PM

QUOTE (nojas @ Jan 7 2009, 01:54)
Yesterday I found that in order to prevent RESC10 crashes on all Nvidia drivers, I had to disable the setting for "pre-rendered frames".

This is a poor workaround, as overall fps suffers, but the game doesn't crash.

Now I have found that due to the way GTA4 is coded, it cannot run properly with a common XP and Vista memory "tweak".

google: DisablePagingExecutive

It is somethiing which is set by many pointless programs such as Registry Mechanic and TuneUp Utilities etc etc.

Reset this value to 0, which is how XP and Vista are at default and GTA plays much better with "pre-rendered frames".

Most games play fine with or without this tweak but, at least on my system, GTA4 does not.


This could very well be something Rockstar never tested for....

Moral of the story is - You really can over "optimize" your pc to death.

oh really mercie_blink.gif

i have nvidia drivers set to CPU render 6 frames ahead and no problems sly.gif


as for Subversion, before i got my extra 4gb ram, GTA4 was running fine, I had a record of about 2.5 hrs gamepley. as soon as I popped in the new 4gb, i was getting MASSIVE craches and a few times I had to hard reset my system. I ended up moving the sticks of ram around the slots and its been fixed now. I even ran Memtest on each single stick on each slot and all sticks were fine. I don't know why switching slots helped but it works now. Maybe try switching around you ram icon14.gif icon14.gif

henry_
  • henry_

    Niko Bellic's Biggest fan

  • Members
  • Joined: 06 Nov 2013
  • None

#11

Posted 22 February 2014 - 08:53 PM

My settings don't have a 0 they have 1-4 or "Let 3D application decide". So I changed it from "Let 3D application decide" to 4 and to my suprise, it made it crash alot later. So I guess you were right. (I'm Using Windows 7.) Thanks a ton!  :lol:


uncredited
  • uncredited

    Midnight Marauder

  • Members
  • Joined: 09 Feb 2013
  • None

#12

Posted 10 March 2014 - 01:17 PM

I have Windows 8.1 and an ATI card, I might test it with the latest patch to see if it fixes my random crashes.

SlaveZer0
  • SlaveZer0

    Perveyor of Destruction

  • Members
  • Joined: 05 Aug 2011
  • United-States

#13

Posted 16 March 2014 - 05:26 AM

you opened a 5 yr old post for that? what a waste





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users