Quantcast

Jump to content

» «
Photo

GTA4 PC Lag

23 replies to this topic
TheTrooper0
  • TheTrooper0

    Player Hater

  • Members
  • Joined: 30 Dec 2008

#1

Posted 30 December 2008 - 08:30 PM

after about 15 minutes of playing, my game becomkes extremely laggy, and jerky. my machine is well above the minimum spec. at first, i thought it was a conflict with the Call of Duty games i had installed, as this is similar tyo a problem i encountered with san andreas. but after uninstalling them, i still encounter the same problem. any ideas?

AMD 64 X2 5000+ processor
Nvidia 8500GT 512mb graphics
3 GB Ram
Sound Blaster audigy sound card
Windows XP Home 32Bit

rador
  • rador

    Player Hater

  • Members
  • Joined: 05 Dec 2008

#2

Posted 30 December 2008 - 08:33 PM

Did u try ALT+TAB ?

TheTrooper0
  • TheTrooper0

    Player Hater

  • Members
  • Joined: 30 Dec 2008

#3

Posted 30 December 2008 - 08:42 PM

yeah, it is incredibly slow and not really of any benefit.

FRAGEYE
  • FRAGEYE

    Rat

  • Members
  • Joined: 28 Dec 2008

#4

Posted 31 December 2008 - 01:05 AM

Is your pc overheating? Because of it lagging after about 15 mins. Being pushed very hard, the extra degree's could cause choppyness.

logitechdog
  • logitechdog

    Hustler

  • Members
  • Joined: 14 Dec 2008

#5

Posted 31 December 2008 - 01:39 PM

monitor your ram and page filing, if your talking about online TheTrooper... as that normally what causes slow alt + tabing, when your computer starts doing allot of page filing

kenwyne
  • kenwyne

    Player Hater

  • Members
  • Joined: 31 Dec 2008

#6

Posted 02 January 2009 - 01:14 AM

Memory leak. create a text file called commandline in the main gta iv folder and add -memrestrict 314572800
start the game and set your graphics to medium and the problem should go away.

YoungGun
  • YoungGun

    Thug

  • Members
  • Joined: 04 Jun 2007

#7

Posted 02 January 2009 - 01:21 AM

QUOTE (kenwyne @ Jan 2 2009, 01:14)
Memory leak. create a text file called commandline in the main gta iv folder and add -memrestrict 314572800
start the game and set your graphics to medium and the problem should go away.

what should I put for -memrestrict with my system?
specs in sig..

kenwyne
  • kenwyne

    Player Hater

  • Members
  • Joined: 31 Dec 2008

#8

Posted 02 January 2009 - 01:54 AM

QUOTE (YoungGun @ Jan 2 2009, 01:21)
QUOTE (kenwyne @ Jan 2 2009, 01:14)
Memory leak. create a text file called commandline in the main gta iv folder and add -memrestrict 314572800
start the game and set your graphics to medium and the problem should go away.

what should I put for -memrestrict with my system?
specs in sig..

i shall find out for you.

kenwyne
  • kenwyne

    Player Hater

  • Members
  • Joined: 31 Dec 2008

#9

Posted 02 January 2009 - 01:56 AM

QUOTE (YoungGun @ Jan 2 2009, 01:21)
QUOTE (kenwyne @ Jan 2 2009, 01:14)
Memory leak. create a text file called commandline in the main gta iv folder and add -memrestrict 314572800
start the game and set your graphics to medium and the problem should go away.

what should I put for -memrestrict with my system?
specs in sig..

Try the one that i said and run in whatever settings you usually use

TheTrooper0
  • TheTrooper0

    Player Hater

  • Members
  • Joined: 30 Dec 2008

#10

Posted 02 January 2009 - 08:03 PM

I'm getting a copy of vista soon, so i'm going to wait and try it on there. i've heard that it should run fine then. Thanks for the advice, i'll try it if it still won't run properly on vista.

UGLYNERDMAN
  • UGLYNERDMAN

    Player Hater

  • Members
  • Joined: 10 Dec 2008

#11

Posted 02 January 2009 - 08:17 PM

gta was like that for me until i patched it by logging into windows live. did you install the patch ?




my only problem now is some damn mission. that loads forever and never plays. its only one particular mission that does it.

TheTrooper0
  • TheTrooper0

    Player Hater

  • Members
  • Joined: 30 Dec 2008

#12

Posted 13 January 2009 - 12:03 PM

i did patch it. i'm just putting vista on in a day or two, so i'll see soon.

Speed DT
  • Speed DT

    Player Hater

  • Members
  • Joined: 20 Feb 2009

#13

Posted 15 July 2009 - 11:58 AM Edited by Speed DT, 15 July 2009 - 12:04 PM.

I had this problem after installing the latest GTA4 update. The graphics has become extremely jerky (approx 2fps). So jerky infact even the sound is breaking up. Running latest drivers etc. I don't know whats going on. Game graphics settings are set to minimum running at 800x600.

The weird thing is occasionally it runs at normal speed (140fps) for a few seconds then goes back to jerky. I have monitored the CPU, GPU, etc temps and everything is within spec.

System Specs:
Intel Core i7 940
Asus P6T Motherboard
Kingston 6GB DDR3
Asus GTX295 Graphics
2 x 1TB HDD RAID 0
Vista Ultimate x64 SP2

One last note I would like to add. Running the benchmark for this game runs fine for about 10 seconds then the frame rate gradually gets slower and slower and slower until GTA4 locks up completely. Even Windows says its not responding.

Speed DT
  • Speed DT

    Player Hater

  • Members
  • Joined: 20 Feb 2009

#14

Posted 15 July 2009 - 12:07 PM

Here is a twister. Just tried it with every single graphics option turned to full. The frame rate has increased slightly to around 3 - 4 fps.

Any thoughts?

mkey82
  • mkey82

    Keep riding hard, son

  • Members
  • Joined: 14 Feb 2008

#15

Posted 15 July 2009 - 12:17 PM

Try the memrestrict commandline.

oc student
  • oc student

    Foot Soldier

  • Members
  • Joined: 22 Apr 2008

#16

Posted 16 July 2009 - 05:12 AM

QUOTE (mkey82 @ Jul 15 2009, 12:17)
Try the memrestrict commandline.

Agreed. I don't know why everyone is avoiding telling the OP this?

mMoff2
  • mMoff2

    Player Hater

  • Members
  • Joined: 26 Apr 2010

#17

Posted 20 June 2010 - 10:15 PM

hey.

I'm having gta iv lag problems.. can i boost it somehow? after launching game i press ALT+TAB and set "GTAIV.exe" or something about it priority to high.. LAGGING ANYWAY!! devil.gif
my specs are:

windows 7 ultimate x64
intel mobile core 2 duo cpu 2ghz t6400
ati mobility radeon hd 4650
4gb ram ddr2
HP pavilion dv6

is my pc good to enough to run gta iv with (at least) medium graphics without any lag?????????????

thanks, mmoff2

mkey82
  • mkey82

    Keep riding hard, son

  • Members
  • Joined: 14 Feb 2008

#18

Posted 21 June 2010 - 10:18 AM

Your laptop is rather weak for GTAIV, you should be aiming for lower settings but whatever you do, the CPU will be holding you back.

Puffalump
  • Puffalump

    Snitch

  • Members
  • Joined: 03 Aug 2006

#19

Posted 22 June 2010 - 03:12 AM

I highly recommend trying the sticky at top for stuttering (the commandline.txt thing). It helped me after this patch I couldn't even play. Now I can.


GTA 1911
  • GTA 1911

    Liberty City Police Commissioner

  • Members
  • Joined: 09 May 2010

#20

Posted 22 June 2010 - 04:14 AM

QUOTE (Puffalump @ Jun 21 2010, 23:12)
I highly recommend trying the sticky at top for stuttering (the commandline.txt thing). It helped me after this patch I couldn't even play. Now I can.

This has already been mentioned 3 or 4 times. It's called memrestrict.

DrG24
  • DrG24

    Player Hater

  • Members
  • Joined: 09 May 2011

#21

Posted 09 May 2011 - 09:40 AM

I'm having a similar problem, I bought the game and because of my crappy connection it took about 9 - 10 hours to download, I got really excited and launched the game. I noticed in the cinematic it was really laggy, and the gameplay was too. This is the same with GTA: Episodes from Liberty City, my specs are well above the minimum:

Minimum:
OS: Windows Vista - Service Pack 1 / Windows XP - Service Pack 3
Processor: Intel Core 2 Duo 1.8GHz, AMD Athlon X2 64 2.4GHz
Memory: 1.5GB XP / 1.5GB Vista
Graphics: 256MB Nvidia 7900 / 256MB ATI X1900
DirectX Version: DirectX 9.0c Compliant Card
Hard Drive: 16GB of Hard Disc Space
Sound Card: 5.1 Channel Audio Card
Other Requirements: Initial activation requires internet connection; Online play requires log-in to Games For Windows - Live and Rockstar Games Social Club (13+ to register); software installations required including Adobe Flash, DirectX, Microsoft’s .NET Framework 3.0, Games For Windows - LIVE, and Internet Explorer.

My specs:
OS: Windows 7 Professional
Processor: Intel Core i7 2.8GHz (8 core)
Memory: 4GB DDR3
Graphics: 1GB Nvidia GeForce 9500GT
DirectX Version: DirectX 11
Hard Drive (irrelevant but still): 1TB SATA II 7200RPM

What is going on here? mad.gif

mkey82
  • mkey82

    Keep riding hard, son

  • Members
  • Joined: 14 Feb 2008

#22

Posted 09 May 2011 - 04:27 PM

9500GT is not a gaming card and it's terribly paired wit the i7.

iolet11
  • iolet11

    Player Hater

  • Members
  • Joined: 12 May 2010

#23

Posted 26 March 2012 - 10:30 AM

QUOTE (kenwyne @ Friday, Jan 2 2009, 01:14)
Memory leak. create a text file called commandline in the main gta iv folder and add -memrestrict 314572800
start the game and set your graphics to medium and the problem should go away.

oh my gosh!!! this works!! finally this game is playable in my laptop.. mine used to lag every 20 seconds or less i cant play it at all thank god i finally found the fix for the lag after searching in forums and in youtube all of them did nothing...
my laptop specs:

i5-2430m
geforce gt540m
2gb ram

thank you man i love you

YankeesPwnMets
  • YankeesPwnMets

    Software Engineer

  • Members
  • Joined: 28 Sep 2010
  • United-States

#24

Posted 26 March 2012 - 09:37 PM

You need a RAM upgrade as well... adding another 2GB will increase performance by a ton.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users