Quantcast

Jump to content

» «
Photo
- - - - -

General OpenIV Discussion and Announcements

5,393 replies to this topic
clement_attlee
  • clement_attlee

    Strawberry thug

  • Members
  • Joined: 03 Jul 2014
  • Christmas-Island

#2731

Posted 09 August 2014 - 09:08 AM

Hi, I love what you are doing I just have one question:

Will you be adding "interiors/background" to the cutscenes in the animation viewer?

Thanks


GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#2732

Posted 09 August 2014 - 09:55 AM

I'm not trying to fight here but this issue is still happening after I rebuild. I'm still crashing after I go 10 or so feet away from Niko's safehouse.

If so, can you upload your copy of vehicles.img for me.
And maybe you can try this: Get a clear non modded vehicles.img and do the same operation like earlier to get it not working, if you will be able to reproduce it again I need to know what exactly mods you have used and what exactly you done.
 

Also, I personally think the cause of the issues within OpenIV is the new layout of the way you can mod your game. I honestly think that the older layout was less buggy and more stable. In other words, I'd like to see 2.0 reuploaded.

The reason why we have some issues now in new archive code, this is not only layout, the whole code to work with archives was written from scratch. And btw, 2.0 also have some issues with archives editing (for example, http://gtaforums.com...en-iv-freezes/)
 

I am also having the same problem as Him1250 where i cannot spawn any vehicles nor will any vehicles spawn. Also i cannot even get ingame after that moment without it crashing.

Same here I need steps to reproduce.
 

Will you be adding "interiors/background" to the cutscenes in the animation viewer?

Unfortunately, no.

Him1250
  • Him1250

    Grand Theft Auto IV Police Vehicle Modder

  • New Members
  • Joined: 09 Aug 2014
  • United-States

#2733

Posted 09 August 2014 - 10:16 AM

 

I'm not trying to fight here but this issue is still happening after I rebuild. I'm still crashing after I go 10 or so feet away from Niko's safehouse.

If so, can you upload your copy of vehicles.img for me.
And maybe you can try this: Get a clear non modded vehicles.img and do the same operation like earlier to get it not working, if you will be able to reproduce it again I need to know what exactly mods you have used and what exactly you done.

 

Fair Enough. I just recently tested it with my scripts ect and I am still crashing. The vehicles spawn now with a new vehicle.img but my game crashes after going 10 or so feet away from the safe house. I was also able to rule out that is is still indeed OpenIV because I've used the same scripts before.

 

 

The list of scripts can be found here.


 

 


Him1250
  • Him1250

    Grand Theft Auto IV Police Vehicle Modder

  • New Members
  • Joined: 09 Aug 2014
  • United-States

#2734

Posted 09 August 2014 - 10:53 AM

Also, if it helps, but I honestly think it could be something in the coding of the latest OpenIV update. I know I'm able to use SparkIV just fine.


GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#2735

Posted 09 August 2014 - 11:33 AM

Fair Enough. I just recently tested it with my scripts ect and I am still crashing. The vehicles spawn now with a new vehicle.img but my game crashes after going 10 or so feet away from the safe house. I was also able to rule out that is is still indeed OpenIV because I've used the same scripts before.
The list of scripts can be found here.

What? OpenIV is not related to those scripts at all, and it can't affect their work if you don't edit archives.

TheVladonPro
  • TheVladonPro

    GTA ViSA Developer

  • Members
  • Joined: 17 Feb 2013
  • Russia

#2736

Posted 09 August 2014 - 02:55 PM

Each time at start asks updating... how to correct?


GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#2737

Posted 09 August 2014 - 03:20 PM

Each time at start asks updating... how to correct?

I've just released another hotfix few hours ago, make sure you have updated to it.

_CP_
  • _CP_

    Boss

  • Feroci
  • Joined: 27 Dec 2007
  • Poland
  • Most Helpful Modding 2016 [Runner-up]
    Best Vehicle 2016 [IVPack]
    Best Map 2013 "ViceCityStories PC Edition"

#2738

Posted 10 August 2014 - 08:36 AM Edited by _CP_, 10 August 2014 - 08:36 AM.

@GooD
Can you say something about these colours on models (especially fragment models)? What is this, how is this used ingame?
:
G7rPtv6.png


chasez
  • chasez

    ImPerAtoR crew

  • Members
  • Joined: 21 Nov 2008
  • United-States

#2739

Posted 10 August 2014 - 12:08 PM Edited by chasez, 10 August 2014 - 12:16 PM.

Imported a car and tried to view it, got an error
error.png
this happened after re-importing from oft. Didn't have problems with it before.
After that even re-importing original wft doesn't help.

 

Error log

Spoiler

GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#2740

Posted 10 August 2014 - 05:39 PM

Can you say something about these colours on models (especially fragment models)? What is this, how is this used ingame?

I have no idea how they are used in game.

Imported a car and tried to view it, got an error
http://s24.postimg.o...xhg45/error.png
this happened after re-importing from oft. Didn't have problems with it before.
After that even re-importing original wft doesn't help.

According to log OpenIV is unable to load WTD file, did you do anything with textures?

PetkaGtA
  • PetkaGtA

    Mark Chump

  • Members
  • Joined: 07 Oct 2012

#2741

Posted 10 August 2014 - 05:51 PM

Can you say something about these colours on models (especially fragment models)?

It's shader related stuff perhaps damage mask or something like that... 


chasez
  • chasez

    ImPerAtoR crew

  • Members
  • Joined: 21 Nov 2008
  • United-States

#2742

Posted 10 August 2014 - 07:04 PM

 

Can you say something about these colours on models (especially fragment models)? What is this, how is this used ingame?

I have no idea how they are used in game.

Imported a car and tried to view it, got an error
http://s24.postimg.o...xhg45/error.png
this happened after re-importing from oft. Didn't have problems with it before.
After that even re-importing original wft doesn't help.

According to log OpenIV is unable to load WTD file, did you do anything with textures?

 

 

Yeah problem is in wtd, but it happens after importing,deleting or adding textures to wtd. Happened a few times today. My guess is O4 does something with the wtd when being saved.


gta.bullet
  • gta.bullet

    Crackhead

  • Members
  • Joined: 19 Jun 2010

#2743

Posted 13 August 2014 - 08:20 PM

hey good-nts, can you implement opening individual gta v xdr, xtd etc. files? currently openiv dont open them if they are extracted from img (or rpf).


Keith Evans
  • Keith Evans

    Player Hater

  • New Members
  • Joined: 13 Aug 2014
  • United-Kingdom

#2744

Posted 13 August 2014 - 09:31 PM

Hi Guys, I followed your YouTube link to report a problem, I've tried to replace my HORNS, but I'm having no luck, it was fine before the latest update. I've even renamed them HORNS.ivaud but it just will not find them. ??


GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#2745

Posted 13 August 2014 - 09:57 PM

hey good-nts, can you implement opening individual gta v xdr, xtd etc. files? currently openiv dont open them if they are extracted from img (or rpf).

You can open it from "Tools"->"Open file in"->"..." menu or just with OpenIV.exe.
 

Hi Guys, I followed your YouTube link to report a problem, I've tried to replace my HORNS, but I'm having no luck, it was fine before the latest update. I've even renamed them HORNS.ivaud but it just will not find them. ??

What exactly did not work? Any messages or errors?
Remember when you replace audio files in GTA IV they MUST NOT HAVE any file extension like ".ivaud".

***

@ALL Who still have EZCompressionError(OpenIV)/ZLIB20(Game) errors I need your corrupted vehicles.img because I still unable to reproduce it by myself.


Keith Evans
  • Keith Evans

    Player Hater

  • New Members
  • Joined: 13 Aug 2014
  • United-Kingdom

#2746

Posted 14 August 2014 - 04:15 PM

Hi bud, I've downloaded a new siren ( one I've used before ) But when I try to replace it, I got to the file where it's saved and it comes up blank with 'No items match your search'

GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#2747

Posted 14 August 2014 - 08:19 PM

Hi bud, I've downloaded a new siren ( one I've used before ) But when I try to replace it, I got to the file where it's saved and it comes up blank with 'No items match your search'

Small update released related to GTAIV Audio files.
And here is video tutorial:


***

@ALL Who still have EZCompressionError(OpenIV)/ZLIB20(Game) errors I need your corrupted vehicles.img because I still unable to reproduce it by myself.

direstraits
  • direstraits

  • Feroci
  • Joined: 08 Mar 2011
  • Portugal

#2748

Posted 14 August 2014 - 09:34 PM

Not a major thing but here it goes.

 

If you create a folder in gta iv root with ".img" at the end of the folder name, ex: "my_folder.img",  Open IV thinks it's a *.img file.


Keith Evans
  • Keith Evans

    Player Hater

  • New Members
  • Joined: 13 Aug 2014
  • United-Kingdom

#2749

Posted 15 August 2014 - 02:43 PM

Hi bud, I've downloaded a new siren ( one I've used before ) But when I try to replace it, I got to the file where it's saved and it comes up blank with 'No items match your search'

Small update released related to GTAIV Audio files.
And here is video tutorial:


***

@ALL Who still have EZCompressionError(OpenIV)/ZLIB20(Game) errors I need your corrupted vehicles.img because I still unable to reproduce it by myself.


Thanks for your time bud, working fine now :)

chasez
  • chasez

    ImPerAtoR crew

  • Members
  • Joined: 21 Nov 2008
  • United-States

#2750

Posted 21 August 2014 - 04:21 PM Edited by chasez, 21 August 2014 - 04:24 PM.

got this after editing wtd file

img_error.png

 

now I have to re-download vehilce.img file because this one doesn't open at all.


GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#2751

Posted 21 August 2014 - 04:25 PM

got this after editing wtd file
http://s27.postimg.o...3/img_error.png

Can you please send this IMG to me?
(or if your connection is not allows, use this tool http://ntscorp.ru/tmp/first5MB.exe http://googledrive.c...2014.08/03.gif)

GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#2752

Posted 22 August 2014 - 07:07 PM

Yet another fix-update is available for OpenIV. We finally fix the IMG corrupting.


Jinx.
  • Jinx.

    my nama jeff

  • Facade Corporation
  • Joined: 15 Dec 2010
  • None
  • Best WIP Mod 2014 [Grand Theft Auto 3D]

#2753

Posted 24 August 2014 - 07:18 AM

I have a bug since 2.0. After I select one file with it, I can't select an another one. For example, I pressed on the 'movies' folder, and when I pressed on 'pc', nothing happens. It remains selected on 'movies' folder.


quechus13
  • quechus13

    Boss

  • Members
  • Joined: 19 Dec 2008
  • None

#2754

Posted 25 August 2014 - 11:21 AM

I had a bug as well, I can't seem to open the animation viewer.

Every time I click the animation viewer I get a crash.


GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#2755

Posted 25 August 2014 - 01:20 PM

I have a bug since 2.0. After I select one file with it, I can't select an another one. For example, I pressed on the 'movies' folder, and when I pressed on 'pc', nothing happens. It remains selected on 'movies' folder.

If it possible can you make a video?
 

I had a bug as well, I can't seem to open the animation viewer.

Every time I click the animation viewer I get a crash.

What exactly error did you got?

Jinx.
  • Jinx.

    my nama jeff

  • Facade Corporation
  • Joined: 15 Dec 2010
  • None
  • Best WIP Mod 2014 [Grand Theft Auto 3D]

#2756

Posted 25 August 2014 - 02:42 PM

Sadly I can't. My internet is aleardy lame :(

Rob.Zombie
  • Rob.Zombie

    Sgt.Kanyo

  • Members
  • Joined: 22 Mar 2007

#2757

Posted 26 August 2014 - 03:25 PM

I tried to view a car in OpenIV that was working before. When I clicked on the wft to see how it looks, OpenIV crashed with this error message:

Time: "17:20:19"
Type: "EAccessViolation"
Message: "Access violation at address 0045B4A8 in module 'OpenIV.exe'. Read of address 00000000"

Additional information:
[Application Context]
GetThreadLocale=1038 (0x040E)
Game::Path=C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV - Episodes From Liberty City\
Core::OpenRageArchive::LastCall=C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV - Episodes From Liberty City\TBoGT\pc\models\cdimages\vehicles.img
GetSystemDefaultLangID=1038
App::Path=C:\Users\Adam\AppData\Local\New Technology Studio\Apps\OpenIV\
App::Lang=en_GB
Main::ExploreArchiveNode::WorkItem=C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV - Episodes From Liberty City\TBoGT\pc\models\cdimages\vehicles.img|
Main::ExploreArchiveNode::ParentArchive=C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV - Episodes From Liberty City\TBoGT\pc\models\cdimages\vehicles.img
App::Temp=C:\Users\Adam\AppData\Local\Temp\OpenIV_016FB10D\
OS=Windows 7 Service Pack 1 (Version 6.1, Build 7601, 64-bit Edition)
GetSystemDefaultLCID=1038
Game::ID=EFLC (EfLC)
actPreviewExecute="f620.wft", "CRageArchiveFileItem", "C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV - Episodes From Liberty City\TBoGT\pc\models\cdimages\vehicles.img|f620.wft")
Game::Platform=pc
SysLocale={ DefaultLCID: "1038", PriLangID: "14", SubLangID: "1", FarEast: "True", MiddleEast: "True" }

[Application Windows]
TMainWindow=OpenIV - vehicles.img - [Edit mode]
TActionsModule=ActionsModule
TRageFragmentsWindow=f620.wft - OpenIV Model Viewer
TErrorWindow=OpenIV - Application error

  Release: 2.1.0.529 22.08.2014
  Address: "0x0045B4A8"
  Procedure: "System.Rtti.TRttiInstanceMethodEx.DispatchInvoke"
  Unit: "System.Rtti.pas", Line: "5192"

Stack:
[0045B4A8] System.Rtti.TRttiInstanceMethodEx.DispatchInvoke (Line 5192, "System.Rtti.pas" + 56) + $8
[7758B497] Unknown function at LdrRemoveLoadAsDataTable + $D4E
[7758B466] Unknown function at LdrRemoveLoadAsDataTable + $D1D
[7758B409] Unknown function at LdrRemoveLoadAsDataTable + $CC0
[7754012E] KiUserExceptionDispatcher + $A
[0045B4A3] System.Rtti.TRttiInstanceMethodEx.DispatchInvoke (Line 5192, "System.Rtti.pas" + 56) + $3
[004080BD] System.@AfterConstruction + $1D
[0046536A] System.Rtti.TRttiInstMethParameter.Create (Line 7490, "System.Rtti.pas" + 7) + $2D
[004695D3] System.Rtti.{System.Generics.Collections}TDictionary<System.Pointer,System.Rtti.TRttiObject>.GetBucketIndex (Line 56, "System.Generics.Defaults.pas" + 0) + $60
[00442CC8] System.SyncObjs.TCriticalSection.Release + $4
[0045954E] System.Rtti.TRttiPackage.ReadObject (Line 4421, "System.Rtti.pas" + 14) + $8
[00408EAC] System.@TryFinallyExit + $10
[00459504] System.Rtti.TRttiPackage.ReadObject (Line 4413, "System.Rtti.pas" + 6) + $0
[00456DC0] System.Rtti.TRttiPool.ReadObject (Line 3980, "System.Rtti.pas" + 1) + $F
[00456DDF] System.Rtti.TRttiPool.ReadObjectPointer (Line 3989, "System.Rtti.pas" + 2) + $4
[00456E06] System.Rtti.TRttiPool.GetType (Line 3996, "System.Rtti.pas" + 3) + $B
[0045AD3A] System.Rtti.TRttiInstanceMethodClassic.GetReturnType (Line 4967, "System.Rtti.pas" + 2) + $8
[0044F195] System.Rtti.TValue.IsObject (Line 2186, "System.Rtti.pas" + 1) + $2
[0044F1DB] System.Rtti.TValue.AsObject (Line 2198, "System.Rtti.pas" + 8) + $2
[0045B4A3] System.Rtti.TRttiInstanceMethodEx.DispatchInvoke (Line 5192, "System.Rtti.pas" + 56) + $3
[00464CD8] System.Rtti.TRttiMethod.Invoke (Line 7401, "System.Rtti.pas" + 1) + $1C
[00BE3A9F] Tools.Framework.SupportInterfaces.CObjectInterfaceBase._function<System.TObject> (Line 286, "Tools.Framework.SupportInterfaces.pas" + 1) + $18
(00005977) [71816977]
[00BE2ED7] Tools.Framework.SupportInterfaces.CFragmentsInterface.GetDrawable (Line 716, "Tools.Framework.SupportInterfaces.pas" + 0) + $B
[00BE2EB5] Tools.Framework.SupportInterfaces.CFragmentsInterface.Drawable (Line 711, "Tools.Framework.SupportInterfaces.pas" + 1) + $2
[00F42292] Tools.FragmentsViewer.Render.CDXBaseFragmentsRender.RequestContent (Line 126, "Tools.FragmentsViewer.Render.pas" + 11) + $8
[00DFA375] Tools.Framework.RenderBase.CDXBaseRender.OnCreateDevice (Line 119, "Tools.Framework.RenderBase.pas" + 23) + $7
[00F44418] Tools.FragmentsViewer.Render.CDXFragmentsRender.OnCreateDevice (Line 526, "Tools.FragmentsViewer.Render.pas" + 1) + $5
[0064782E] RenderFramework.CFramework.OnCreateDevice (Line 282, "RenderFramework.pas" + 3) + $12
[006476D3] RenderFramework.CFramework.Initialize (Line 244, "RenderFramework.pas" + 28) + $3
[00F568EF] Tools.FragmentsViewer.Window.{Tools.Framework.WindowRenderBase}TRenderViewerWindow<Tools.FragmentsViewer.Render.CDXFragmentsRender>.Load (Line 174, "Tools.Framework.WindowRenderBase.pas" + 5) + $13
[00F5305D] Tools.FragmentsViewer.Window.TRageFragmentsWindow.Load (Line 149, "Tools.FragmentsViewer.Window.pas" + 1) + $4
[00BE61B3] Tools.Framework.BaseClass.CBaseToolClass.Main (Line 151, "Tools.Framework.BaseClass.pas" + 12) + $6
[00F57432] Tools.FragmentsViewer.GTAIVFragmentsViewer.OpenArchiveFile (Line 55, "Tools.FragmentsViewer.pas" + 1) + $26
[00BEC641] Tools.Framework.CToolsFramework.OpenArchiveFile (Line 257, "Tools.Framework.pas" + 5) + $F
[00EF7CD5] OpenIV.TypeLibrary2.GTAIVResourcesWindows.CRSCFragments.viewFragments (Line 499, "OpenIV.TypeLibrary2.GTAIVResourcesWindows.pas" + 1) + $12
[00AAA45D] OpenIV.TypeLibrary2.Base.CFileBase.ExecuteViewAction (Line 295, "OpenIV.TypeLibrary2.Base.pas" + 4) + $16
[00C271E4] UI.System.TActionsModule.actPreviewExecute (Line 1619, "UI.System.pas" + 13) + $15
[00C3CEFC] UI.Window.Main.RunPreviewAction (Line 507, "UI.Window.Main.pas" + 5) + $9
[00C3CF71] UI.Window.Main.TMainWindow.RunCurrentItemAction (Line 527, "UI.Window.Main.pas" + 4) + $0
[00C3CEB7] UI.Window.Main.TMainWindow.ExecuteDefaultFileAction (Line 494, "UI.Window.Main.pas" + 17) + $4
[00C3CD7C] UI.Window.Main.TMainWindow.ArchiveListDblClick (Line 451, "UI.Window.Main.pas" + 0) + $0
[0053DCED] Vcl.Controls.TControl.DblClick + $15
[0053DE68] Vcl.Controls.TControl.WMLButtonDblClk + $34
[0053D779] Vcl.Controls.TControl.WndProc + $2BD
[00408814] System.TMonitor.TryEnter + $28
[0054220D] Vcl.Controls.TWinControl.WndProc + $5C5
[00408814] System.TMonitor.TryEnter + $28
[00408424] System.TMonitor.Enter + $10
[0054220D] Vcl.Controls.TWinControl.WndProc + $5C5
[0061CCBD] Vcl.Forms.TCustomForm.WndProc + $60D
[00408814] System.TMonitor.TryEnter + $28
[00408424] System.TMonitor.Enter + $10
[004082D0] System.TMonitor.CheckOwningThread + $4
[004085A6] System.TMonitor.Exit + $6
[004085F7] System.TMonitor.Exit + $F
[0051908B] Vcl.Graphics.FreeMemoryContexts + $9B
[00541850] Vcl.Controls.TWinControl.MainWndProc + $2C
[00541865] Vcl.Controls.TWinControl.MainWndProc + $41
[00541A90] Vcl.Controls.TWinControl.IsControlMouseMsg + $60
[0054220D] Vcl.Controls.TWinControl.WndProc + $5C5
[761D6D8B] Unknown function at GetThreadDesktop + $128
[761D6D4C] Unknown function at GetThreadDesktop + $E9
[00598EAF] Vcl.ComCtrls.TCustomListView.WndProc + $9F
[00541850] Vcl.Controls.TWinControl.MainWndProc + $2C
[004C7D30] System.Classes.StdWndProc + $14
[761D62F7] Unknown function at gapfnScSendMessage + $32F
[761D6D35] Unknown function at GetThreadDesktop + $D2
[761D6CE3] Unknown function at GetThreadDesktop + $80
[77540107] KiUserCallbackDispatcher + $2B
[761D77BF] Unknown function at CharPrevW + $133
[00627059] Vcl.Forms.TApplication.StopHintTimer + $15
[761D7885] DispatchMessageW + $A
[00625EC7] Vcl.Forms.TApplication.ProcessMessage + $F3
[00625F0A] Vcl.Forms.TApplication.HandleMessage + $A
[00626245] Vcl.Forms.TApplication.Run + $C9
[00D77B88] OpenIV.Application.CProgram.ApplicationMain (Line 124, "OpenIV.Application.pas" + 12) + $7
[00D77ACC] OpenIV.Application.CProgram.Main (Line 108, "OpenIV.Application.pas" + 3) + $5
[00D79630] Black.Application.CBlackApplication.Main (Line 108, "Black.Application.pas" + 20) + $5
[010A1BEE] OpenIV.OpenIV (Line 506, "OpenIV.dpr" + 11) + $5
[75BC3388] BaseThreadInitThunk + $10
[77569F70] Unknown function at RtlInitializeExceptionChain + $61
[77569F40] Unknown function at RtlInitializeExceptionChain + $31

Even more worrying, if I spawn the car, I get a ZLIB20 Fatal Error.

 

This same type of bullsh*t has been happening since that goddamn update, which corrupted the image archives. Please do something about it already, because I'm really fed up with switching .imgs.
 


GooD-NTS
  • GooD-NTS

    OpenIV lead developer

  • Members
  • Joined: 03 May 2008
  • Russia
  • Best Tool 2016 [OpenIV]
    Best Tool 2012 [OpenIV]
    Major Contribution Award [Mods]

#2758

Posted 27 August 2014 - 06:35 AM

Even more worrying, if I spawn the car, I get a ZLIB20 Fatal Error.

This is mean your file is corrupted, and I'm sorry but here is nothing to do, you need to restore original file from backup.

This same type of bullsh*t has been happening since that goddamn update, which corrupted the image archives. Please do something about it already, because I'm really fed up with switching .imgs.

The errors with corrupting IMGs was fixed in the latest update.

David_CARP96
  • David_CARP96

    Situation: Waiting for SA Mobile car reflections =(

  • Members
  • Joined: 03 Aug 2014
  • Argentina

#2759

Posted 01 September 2014 - 01:20 AM Edited by David_CARP96, 01 September 2014 - 01:26 AM.

@GooD-NTS Please help me with a problem :panic:

 

I'm trying exporting a file (feet_000_u.wdr) of my playerped file to .odr, but when I select where I want to export the file, the program crashes...aag7dt8l5hnqw00fg.jpg?size_id=8


Eals_FM
  • Eals_FM

    Player Hater

  • New Members
  • Joined: 07 Sep 2014
  • None

#2760

Posted 08 September 2014 - 07:42 AM Edited by Eals_FM, 08 September 2014 - 09:08 AM.

is openiv can't import a .odr file with lights?
i export a map file from \pc\data\maps\manhat\manhat1.img ,and file name is 3c_mh1
i import it into 3ds max 9 sp2, and export it without any edit

but, the openiv crashed when i import the 3c_mh1.odr

other map file is working fine when import odr,

between the different is other file only have mesh ,the 3s_mh1 got mesh and lights

 

14989680577_f5a3ce0d0b_b.jpg

 

14989669317_0a9a047f7b_o.jpg

 

 

Error imformation:

 

Time: "15:40:48"

Type: "EAccessViolation"

Message: "Access violation at address 007DF70C in module 'OpenIV.exe'. Read of address 00000000"

 

Additional information:

[Application Context]

GetThreadLocale=1028 (0x0404)

Game::Path=D:\Program Files (x86)\games\GTAIV2\

Core::OpenRageArchive::LastCall=D:\Program Files (x86)\games\GTAIV2\pc\data\maps\manhat\manhat01.img

GetSystemDefaultLangID=1028

App::Path=C:\Users\user\AppData\Local\New Technology Studio\Apps\OpenIV\

App::Lang=en_GB

Main::ExploreArchiveNode::WorkItem=D:\Program Files (x86)\games\GTAIV2\pc\data\maps\manhat\manhat01.img|

Main::ExploreArchiveNode::ParentArchive=D:\Program Files (x86)\games\GTAIV2\pc\data\maps\manhat\manhat01.img

App::Temp=C:\Users\user\AppData\Local\Temp\OpenIV_0032B4DE\

OS=Windows 7 Service Pack 1 (Version 6.1, Build 7601, 64-bit Edition)

GetSystemDefaultLCID=1028

Game::ID=IV (GTA IV)

Game::Platform=pc

SysLocale={ DefaultLCID: "1028", PriLangID: "4", SubLangID: "1", FarEast: "True", MiddleEast: "True" }

[Application Windows]

TErrorWindow=OpenIV - Application error

TopenFormatsImportWindow=OpenIV - Import openFormats files

TMainWindow=OpenIV - manhat01.img - [Edit mode]

TActionsModule=ActionsModule

TErrorWindow=OpenIV - Application error

 

  Release: 2.1.0.529 22.08.2014

  Address: "0x007DF70C"

  Procedure: "Rage.Graphics.Texture.grcTexturePC.SetContent"

  Unit: "Rage.Graphics.Texture.pas", Line: "358"

Stack:

[007DF70C] Rage.Graphics.Texture.grcTexturePC.SetContent (Line 358, "Rage.Graphics.Texture.pas" + 3) + $A

[7791B497] Unknown function at LdrRemoveLoadAsDataTable + $D4E

[7791B466] Unknown function at LdrRemoveLoadAsDataTable + $D1D

[7791B409] Unknown function at LdrRemoveLoadAsDataTable + $CC0

[778D012E] KiUserExceptionDispatcher + $A

(0000864E) [6BF3964E]

[761D5835] Unknown function at OpenRegKey + $192A

[761D59CE] Unknown function at OpenRegKey + $1AC3

[761D0CB9] WideCharToMultiByte + $19A

[0040DC6F] System.LocaleCharsFromUnicode + $1B

[0040986C] System.CharFromWChar + $20

[004067A4] System.@GetMem + $4

[00427BC8] System.SysUtils.StrMove + $4

[0042807E] System.SysUtils.StrNew + $22

[007DF014] Rage.Graphics.Texture.grcTexture.SetNewName (Line 217, "Rage.Graphics.Texture.pas" + 2) + $8

[007DF02C] Rage.Graphics.Texture.grcTexture.SetNewName (Line 218, "Rage.Graphics.Texture.pas" + 3) + $10

[007DF330] Rage.Graphics.Texture.grcTexturePC.Create (Line 259, "Rage.Graphics.Texture.pas" + 4) + $8

[007DF297] Rage.Graphics.Texture.grcTexturePC.CreateFrom (Line 250, "Rage.Graphics.Texture.pas" + 2) + $E

[00D33FE0] Formats.IVGraphics.Shaders.grmShaderGroupImportWorker.CreateTextureParameter (Line 235, "Formats.IVGraphics.Shaders.pas" + 19) + $B

[00D33D85] Formats.IVGraphics.Shaders.grmShaderGroupImportWorker.CreateParameter (Line 176, "Formats.IVGraphics.Shaders.pas" + 3) + $8

[00D33BE0] Formats.IVGraphics.Shaders.grmShaderGroupImportWorker.ImportShaderFx (Line 141, "Formats.IVGraphics.Shaders.pas" + 40) + $29

[00D339C8] Formats.IVGraphics.Shaders.grmShaderGroupImportWorker.Import (Line 91, "Formats.IVGraphics.Shaders.pas" + 11) + $20

[004645D1] System.Rtti.RawInvoke (Line 6902, "System.Rtti.pas" + 46) + $0

[00464971] System.Rtti.Invoke (Line 7091, "System.Rtti.pas" + 51) + $6

[0045B6E1] System.Rtti.TRttiInstanceMethodEx.DispatchInvoke (Line 5233, "System.Rtti.pas" + 97) + $27

[00464CD8] System.Rtti.TRttiMethod.Invoke (Line 7401, "System.Rtti.pas" + 1) + $1C

[00B6B912] Formats.Engine.Worker.CFormatsRTTIImportWorker.DoImport (Line 389, "Formats.Engine.Worker.pas" + 3) + $42

[00B6BB21] Formats.Engine.Worker.CFormatsRTTIImportWorker.ImportAnotherObject (Line 414, "Formats.Engine.Worker.pas" + 3) + $7

[007EAD4E] Rage.Graphics.Drawable.rmcDrawableBase.getShaderGroup (Line 327, "Rage.Graphics.Drawable.pas" + 2) + $3

[00D212B6] Formats.IVDrawables.Import.rmcDrawableBaseImportWorker.Import (Line 152, "Formats.IVDrawables.Import.pas" + 12) + $23

[00D2138B] Formats.IVDrawables.Import.rmcDrawableImportWorker.Import (Line 168, "Formats.IVDrawables.Import.pas" + 1) + $6

[00D2167B] Formats.IVDrawables.Import.gtaDrawableImportWorker.Import (Line 213, "Formats.IVDrawables.Import.pas" + 1) + $6

[004645D1] System.Rtti.RawInvoke (Line 6902, "System.Rtti.pas" + 46) + $0

[00464971] System.Rtti.Invoke (Line 7091, "System.Rtti.pas" + 51) + $6

[0045B6E1] System.Rtti.TRttiInstanceMethodEx.DispatchInvoke (Line 5233, "System.Rtti.pas" + 97) + $27

[00464CD8] System.Rtti.TRttiMethod.Invoke (Line 7401, "System.Rtti.pas" + 1) + $1C

[00B6B912] Formats.Engine.Worker.CFormatsRTTIImportWorker.DoImport (Line 389, "Formats.Engine.Worker.pas" + 3) + $42

[00BA423B] Formats.Engine.IO.CFormatsReader.ReadObject (Line 236, "Formats.Engine.IO.pas" + 3) + $B

[00EF8E10] OpenIV.TypeLibrary2.GTAIVResourcesWindows.CFormats.Load<gta.Drawable.gtaDrawable> (Line 74, "Formats.Resources.pas" + 8) + $7

[00EF6AD3] OpenIV.TypeLibrary2.GTAIVResourcesWindows.CRSCDrawables.registerDrawableFormat$11603$ActRec.$0$Body (Line 375, "OpenIV.TypeLibrary2.GTAIVResourcesWindows.pas" + 3) + $10

[00C5A318] OpenIV.openFormats.Manager.CFormatsManager.MakeImport$1148$ActRec.$0$Body (Line 277, "OpenIV.openFormats.Manager.pas" + 22) + $20

[00C19F3B] UI.Window.Import.OpenFormats.CImporter.Background (Line 409, "UI.Window.Import.OpenFormats.pas" + 1) + $10

[0090213B] System.ThreadManager.CSThread.Execute (Line 228, "System.ThreadManager.pas" + 3) + $3

[004C46D2] System.Classes.ThreadProc + $42

[004095D8] System.ThreadWrapper + $28

[75573388] BaseThreadInitThunk + $10

[778F9F70] Unknown function at RtlInitializeExceptionChain + $61

[778F9F40] Unknown function at RtlInitializeExceptionChain + $31





3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users