Quantcast

Jump to content

» «
Photo

[REL|BIN/SRC|Beta] SparkIV

926 replies to this topic
Glumok
  • Glumok

    8 years on GTAForums... Bordel de foutre !

  • Members
  • Joined: 04 Apr 2007
  • None

#571

Posted 26 May 2009 - 12:46 PM

QUOTE (OutOfTimer @ May 22 2009, 20:15)
Aru is brilliant, so I bet he thought that by showing off his remarkable programming skills he would attract R*'s attention and get a job at the company. Unfortunately R* doesn't think like that. They believe modders are a threat to them and hate everybody who tries to make a contribution to the community.

Two of the biggest sh*t I've ever read on this forum.

Never noticed that Aru is a long time modder/user ? Don't remember, for instance, of Spark for GTA III's era ?
Since years, this guy is in the GTA modding community, always making amazing tools for free. Just don't talk when you don't know what you are talking about.

And about R* and modders, they do love them. Even if they don't release any SDK for GTA, at least they keep us free to edit almost all the files. It would be easy for them to just completely lock the game, hardcoding everything. I do remember there is even a URL like "moddersrules.com" (I don't remember the exact name) registered by them.

gaytony
  • gaytony

    Player Hater

  • BUSTED!
  • Joined: 27 May 2009

#572

Posted 27 May 2009 - 12:22 PM

QUOTE (gorgeprofondegta4 @ May 26 2009, 12:46)
QUOTE (OutOfTimer @ May 22 2009, 20:15)
Aru is brilliant, so I bet he thought that by showing off his remarkable programming skills he would attract R*'s attention and get a job at the company. Unfortunately R* doesn't think like that. They believe modders are a threat to them and hate everybody who tries to make a contribution to the community.

Two of the biggest sh*t I've ever read on this forum.

Never noticed that Aru is a long time modder/user ? Don't remember, for instance, of Spark for GTA III's era ?
Since years, this guy is in the GTA modding community, always making amazing tools for free. Just don't talk when you don't know what you are talking about.

And about R* and modders, they do love them. Even if they don't release any SDK for GTA, at least they keep us free to edit almost all the files. It would be easy for them to just completely lock the game, hardcoding everything. I do remember there is even a URL like "moddersrules.com" (I don't remember the exact name) registered by them.

Ha ha nope your full of sh*t! rockstar don't want modders! We make them look bad!

jurasiks
  • jurasiks

    Player Hater

  • Members
  • Joined: 30 May 2009

#573

Posted 30 May 2009 - 02:27 PM

spark 0.6.2 don't work with GTA IV 1.0.2.1 version!!!

gtaforlifeshopper
  • gtaforlifeshopper

    Player Hater

  • BUSTED!
  • Joined: 02 Jun 2009

#574

Posted 02 June 2009 - 06:55 PM

QUOTE (jurasiks @ May 30 2009, 14:27)
spark 0.6.2 don't work with GTA IV 1.0.2.1 version!!!

Is there gonna be any more updates for SparkIV...? I still use the r3 version by gamerzworld found here! and it works on all versions of GTAIV even 1.0.3.0 but if you wanna play online you can only use texture and model edits!!!

killer1234567
  • killer1234567

    Player Hater

  • Members
  • Joined: 02 Jun 2009

#575

Posted 02 June 2009 - 08:30 PM

what version is this for mad.gif

kaamarko
  • kaamarko

    Player Hater

  • Members
  • Joined: 04 Jun 2009

#576

Posted 04 June 2009 - 03:46 PM

HI! Can you help me, how to edit non opening-non embed wdr-s and wtf-s? confused.gif

Gocha
  • Gocha

    Player Hater

  • Members
  • Joined: 01 Jun 2009

#577

Posted 09 June 2009 - 07:39 PM

Please add .WAD (contains IMG files) editing support.

Thanks

Dvt-MedShot
  • Dvt-MedShot

    Mack Pimp

  • Members
  • Joined: 02 May 2007

#578

Posted 13 June 2009 - 07:49 PM Edited by Dvt-MedShot, 15 June 2009 - 07:01 AM.

Hi I recently installed patch 1.0.3.0, and now Spark IV doesn't work anymore. At starting, it gives the following error message:

QUOTE
Your GTAIV.exe seems to be modified or is a newer version than this tool supports.
If it is a newer version, please check for an update of SparkIV. SparkIV can not run without a supported GTAIV.exe file


However, my GTAIV.exe is offcourse not modified. I just installed 1.0.3.0 and downloaded the newest Spark IV (0.6.2).

What's the matter?


EDIT: Wait... Is Spark IV actually supposed to work with 1.0.3.0?
EDIT 2: No, it isn't. Appearantly, Spark IV doesn't work with 1.0.3.0.
For all people with the same problem, use this Spark IV R2 release instead. That one does work with 1.0.3.0

Sorry for the inconvenience. turn.gif

Teo265
  • Teo265

    Perfectionist

  • Members
  • Joined: 06 Mar 2009

#579

Posted 19 June 2009 - 07:10 PM

Aru, do you update SparkIV for 1.0.4?

gamerzworld
  • gamerzworld

    Why did I move here? I guess it was to sell Shark Cards.

  • Members
  • Joined: 29 Nov 2005
  • United-States

#580

Posted 19 June 2009 - 07:21 PM

Here you go.

http://gzwn.net/Docu...kIV 0.6.2.1.rar

Should work with both 1.0.4.0 EFIGS and 1.0.3.1 Russian EXEs.

Teo265
  • Teo265

    Perfectionist

  • Members
  • Joined: 06 Mar 2009

#581

Posted 19 June 2009 - 07:34 PM

Thanks

OutOfTimer
  • OutOfTimer

    PC Enthusiast

  • Members
  • Joined: 04 Mar 2009
  • None

#582

Posted 19 June 2009 - 08:10 PM

QUOTE (gamerzworld @ Jun 19 2009, 19:21)
Here you go.

http://gzwn.net/Docu...kIV 0.6.2.1.rar

Should work with both 1.0.4.0 EFIGS and 1.0.3.1 Russian EXEs.

You are our star, dude. Thank you very much.

lilmcnessy
  • lilmcnessy

    FenderCore

  • Members
  • Joined: 29 Oct 2008

#583

Posted 20 June 2009 - 09:17 AM Edited by lilmcnessy, 20 June 2009 - 11:44 AM.

QUOTE (gamerzworld @ Jun 20 2009, 07:21)
Here you go.

http://gzwn.net/Docu...kIV 0.6.2.1.rar

Should work with both 1.0.4.0 EFIGS and 1.0.3.1 Russian EXEs.

There is no filter in that version cryani.gif
The filter only works when it is maximized
It also crashes when you listen to the a few audio files

chasez
  • chasez

    ImPerAtoR crew

  • Members
  • Joined: 21 Nov 2008
  • United-States

#584

Posted 20 June 2009 - 12:08 PM

QUOTE (gamerzworld @ Jun 19 2009, 19:21)
Here you go.

http://gzwn.net/Docu...kIV 0.6.2.1.rar

Should work with both 1.0.4.0 EFIGS and 1.0.3.1 Russian EXEs.

It's too buggy:( I'll wait for stable

gamerzworld
  • gamerzworld

    Why did I move here? I guess it was to sell Shark Cards.

  • Members
  • Joined: 29 Nov 2005
  • United-States

#585

Posted 21 June 2009 - 04:25 PM

Fixed the filter (caused by me adding the revision number to the version string) and added support for Japan EXEs. As for the audio thing, I'm not quite sure what to tell you as I'm not a C# coder by heart. The only thing I think I can do is revert back to the player code from the official 0.6.2 release. (Aru changed up the player code after releasing 0.6.2) Did anyone have problems with playing audio in the official 0.6.2 release?

http://gzwn.net/Docu...kIV 0.6.2.2.rar

Teo265
  • Teo265

    Perfectionist

  • Members
  • Joined: 06 Mar 2009

#586

Posted 21 June 2009 - 06:52 PM

Thanks... Again.

Dageron RUS
  • Dageron RUS

  • Members
  • Joined: 28 Apr 2009
  • Belarus

#587

Posted 22 June 2009 - 08:54 AM

gamerzworld, can you post Japan AES key offsets, please? smile.gif
(I tired of their patch downloading, but need offsets...)

And here it is offset for XBox360 ".exe" (it can be extracted from default.xex using XexTool): 0x00A80F40
That also can be useful for such who research x360 version of the game.

gamerzworld
  • gamerzworld

    Why did I move here? I guess it was to sell Shark Cards.

  • Members
  • Joined: 29 Nov 2005
  • United-States

#588

Posted 22 June 2009 - 03:15 PM

QUOTE (|Dageron| @ Jun 22 2009, 03:54)
gamerzworld, can you post Japan AES key offsets, please? smile.gif
(I tired of their patch downloading, but need offsets...)

And here it is offset for XBox360 ".exe" (it can be extracted from default.xex using XexTool): 0x00A80F40
That also can be useful for such who research x360 version of the game.

CODE
0xB8813C /* 1.0.1.2 JAP*/,
0xB8C38C /* 1.0.2.2 JAP*/,

abdelkadir
  • abdelkadir

    Player Hater

  • Members
  • Joined: 26 Jun 2009

#589

Posted 26 June 2009 - 10:14 PM

i have update my framwork to 3.5 but when i want to run sparkIV an error sad your

GTA.exe seems to be modified or is a newer version than this tool supports.if it is a newer version, please check for an updateof sparkIV. SparkIV can not run withou a supported GTAIV.exe file.


please some one help me please

gamerzworld
  • gamerzworld

    Why did I move here? I guess it was to sell Shark Cards.

  • Members
  • Joined: 29 Nov 2005
  • United-States

#590

Posted 26 June 2009 - 10:18 PM

QUOTE (abdelkadir @ Jun 26 2009, 17:14)
i have update my framwork to 3.5 but when i want to run sparkIV an error sad your

GTA.exe seems to be modified or is a newer version than this tool supports.if it is a newer version, please check for an updateof sparkIV. SparkIV can not run withou a supported GTAIV.exe file.


please some one help me please

Read the 5th post on this page.

Holcy
  • Holcy

    Player Hater

  • Members
  • Joined: 29 Jun 2009

#591

Posted 30 June 2009 - 03:58 AM Edited by Dutchy3010, 30 June 2009 - 08:11 AM.

Good job aru... but i have one question, is there going to be a spark update for the new patch 1.0.4.0? thanks!

>>Please don't quote large posts or images -- Dutchy3010<<

gamerzworld
  • gamerzworld

    Why did I move here? I guess it was to sell Shark Cards.

  • Members
  • Joined: 29 Nov 2005
  • United-States

#592

Posted 30 June 2009 - 04:18 AM

QUOTE (Holcy @ Jun 29 2009, 22:58)
QUOTE (aru @ Dec 16 2008, 23:48)
<snip>

Good job aru... but i have one question, is there going to be a spark update for the new patch 1.0.4.0? thanks!

*facepalm*

Gocha
  • Gocha

    Player Hater

  • Members
  • Joined: 01 Jun 2009

#593

Posted 30 June 2009 - 12:03 PM

Is there goings to add support for audio editing? As i noticed San Andreas support for audio editors got reachable not long ago, i suppose it would be added not soon

jjcoolj91
  • jjcoolj91

    "Snipin's a good job mate...Challenging Work."

  • Members
  • Joined: 13 Nov 2007

#594

Posted 30 June 2009 - 05:16 PM

QUOTE (Gocha @ Jun 30 2009, 05:03)
Is there goings to add support for audio editing? As i noticed San Andreas support for audio editors got reachable not long ago, i suppose it would be added not soon

Guys i think aru has chose to leave the spark IV Topic unmanaged by him, he hasnt posted in here since January 27th confused.gif

your gonna have to ask someone else to make an audio editor for GTA IV

atnc
  • atnc

    Player Hater

  • Members
  • Joined: 06 Jan 2009

#595

Posted 01 July 2009 - 05:00 PM

i did some changes with an old version of spark, then i ve upgraded gta iv to 1.0.4.0 . now i cannot open the game it says gta iv stopped running. i just downloaded the latest version of spark to undo my changes but now i cant open the file "playerped.rpf" it gives an error. any1 can help me out with this problem?

gamerzworld
  • gamerzworld

    Why did I move here? I guess it was to sell Shark Cards.

  • Members
  • Joined: 29 Nov 2005
  • United-States

#596

Posted 01 July 2009 - 05:04 PM

QUOTE (atnc @ Jul 1 2009, 12:00)
i did some changes with an old version of spark, then i ve upgraded gta iv to 1.0.4.0 . now i cannot open the game it says gta iv stopped running. i just downloaded the latest version of spark to undo my changes but now i cant open the file "playerped.rpf" it gives an error. any1 can help me out with this problem?

What is the error Spark gives you?

Khelben25
  • Khelben25

    Player Hater

  • Members
  • Joined: 01 Jul 2009

#597

Posted 01 July 2009 - 07:57 PM

Man i download all of SparksIV but GTA IV patch 1.0.4.0 with any SparksIV dont works Help me... cryani.gif

gamerzworld
  • gamerzworld

    Why did I move here? I guess it was to sell Shark Cards.

  • Members
  • Joined: 29 Nov 2005
  • United-States

#598

Posted 01 July 2009 - 08:01 PM

QUOTE (Khelben25 @ Jul 1 2009, 14:57)
Man i download all of SparksIV but GTA IV patch 1.0.4.0 with any SparksIV dont works Help me... cryani.gif

http://gzwn.net/Docu...kIV 0.6.2.2.rar

Fabio206
  • Fabio206

    GTA-Expert.it Webmaster

  • Members
  • Joined: 20 Oct 2006

#599

Posted 01 July 2009 - 08:10 PM

Mm gamerzworld I dunno if you could modify source code, but have you already tried to add the "level" function (for textures) to sparkiv (as in OpenIV)? shoul be very useful..
If I failed at asking, sorry biggrin.gif anyway thanks for your work on the last unofficial build smile.gif

gamerzworld
  • gamerzworld

    Why did I move here? I guess it was to sell Shark Cards.

  • Members
  • Joined: 29 Nov 2005
  • United-States

#600

Posted 01 July 2009 - 08:24 PM

QUOTE (Fabio206 @ Jul 1 2009, 15:10)
Mm gamerzworld I dunno if you could modify source code, but have you already tried to add the "level" function (for textures) to sparkiv (as in OpenIV)? shoul be very useful..
If I failed at asking, sorry biggrin.gif anyway thanks for your work on the last unofficial build smile.gif

Like I said, I'm not a C# coder. I would love to see that feature be integrated though.




3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users