Quantcast

Jump to content

» «
Photo

[GTAIV] Asi loader

1,019 replies to this topic
pogoberserker
  • pogoberserker

    Player Hater

  • Members
  • Joined: 23 Jan 2009

#151

Posted 24 January 2009 - 10:31 PM

Nice Alexander!
But the SNT don't work sad.gif


Neon25
  • Neon25

    Proud PC gamer

  • Members
  • Joined: 21 Aug 2005

#152

Posted 24 January 2009 - 10:32 PM

It's not the case of bad ASI loader, it's the case that the memory offsets and adressess changed, so all of the mods need to be redone again.

KooolaNL
  • KooolaNL

    Square Civilian

  • Members
  • Joined: 12 Jan 2009

#153

Posted 24 January 2009 - 10:34 PM

no asi loads for me

Ftmch
  • Ftmch

    I'm selling these fine leather jackets...

  • Members
  • Joined: 02 Dec 2008

#154

Posted 24 January 2009 - 10:36 PM

Tried this new version, and the playerselector.asi and timesync.asi still don't work, the game loads without problems though.

HazardX
  • HazardX

    pedestrian mangler

  • Members
  • Joined: 13 Dec 2008

#155

Posted 24 January 2009 - 10:49 PM

QUOTE (Ftmch @ Jan 24 2009, 23:36)
Tried this new version, and the playerselector.asi and timesync.asi still don't work, the game loads without problems though.

ALL asi files made for the old version are useless now and might cause the game to crash! You need to wait for an updated version of those plugins. This is not a fault of the AsiLoader.

KooolaNL
  • KooolaNL

    Square Civilian

  • Members
  • Joined: 12 Jan 2009

#156

Posted 24 January 2009 - 10:54 PM

rofl now we w8 for


playerchooser for 1.0.2.0
carspawner for 1.0.2.0 this is the 1.0.1.0 version of the carspawner i use
BT mod for 1.0.2.0

sad.gif

hoping 2 see that very soon lol.gif

CleanShot
  • CleanShot

    Sensory Sniper

  • Members
  • Joined: 24 Jan 2009

#157

Posted 24 January 2009 - 11:03 PM

In particular, I wait for new Alice.asi which will work for 1.0.2.
I am very excited about how fast Alexander has created new AsiLoader. Thanks.

Ricksta
  • Ricksta

    Homeboy

  • Members
  • Joined: 17 Sep 2006

#158

Posted 24 January 2009 - 11:29 PM

I want 1.0.2.0 versions of
Awwu's trainer
bodyguards!
ragdoll
and teleporter

biggrin.gif

Rich246
  • Rich246

    A Custom What?

  • Members
  • Joined: 20 May 2008
  • United-States

#159

Posted 25 January 2009 - 12:31 AM

QUOTE (Ricksta @ Jan 24 2009, 18:29)
I want 1.0.2.0 versions of
Awwu's trainer
bodyguards!
ragdoll
and teleporter

biggrin.gif

You Took the words right out of my mouth tounge2.gif

Remos
  • Remos

    Player Hater

  • Members
  • Joined: 22 Jan 2009

#160

Posted 25 January 2009 - 03:59 AM Edited by Remos, 25 January 2009 - 04:03 AM.

I can't find dsound.dll in order to back it up, anyone else having this problem?

Edit: Never mind >.>
It was asking to replace something until just a few seconds ago.

hristi
  • hristi

    Square Civilian

  • Members
  • Joined: 03 Jan 2009

#161

Posted 25 January 2009 - 04:20 AM

How come it gives me the "R6030 - CRT not initialized" error?

jetter10
  • jetter10

    Player Hater

  • Members
  • Joined: 24 Jan 2009

#162

Posted 25 January 2009 - 09:15 AM

wow over one night it was patched to work?!?!?
how?? magic? or are you the god??

Seemann
  • Seemann

    Ruhe

  • Members
  • Joined: 03 Sep 2004
  • Russia
  • Best Tool 2013 "Sanny Builder"

#163

Posted 25 January 2009 - 09:27 AM

QUOTE (jetter10 @ Jan 25 2009, 17:15)
wow over one night it was patched to work?!?!?
how?? magic? or are you the god??

It isn't so hard actually.

--

Those of you who experience troubles with new ASI loader could try new XLiveLess.

jetter10
  • jetter10

    Player Hater

  • Members
  • Joined: 24 Jan 2009

#164

Posted 25 January 2009 - 09:36 AM

oh really?

and it doesn't work for me, with dsound.dll in root folder T_T
makes my game crash, works without it though... weird??

Leopard_
  • Leopard_

    Call me Leo.

  • Members
  • Joined: 21 Jun 2008

#165

Posted 25 January 2009 - 09:45 AM

I want my own mod to work suicidal.gif

Diaz070
  • Diaz070

    Punk-ass Bitch

  • Members
  • Joined: 24 Jan 2009

#166

Posted 25 January 2009 - 10:58 AM

And I want your mod to work and ragdoll,carspawner,playerselector,flymod sneaky2.gif sneaky2.gif orly.gif orly.gif

Anach
  • Anach

    Square Civilian

  • Members
  • Joined: 21 Dec 2008

#167

Posted 25 January 2009 - 01:56 PM

Works fine, but using it with older mods will cause the game to crash. So make sure you arent trying to use mods that havent been updated yet.

buzbegone
  • buzbegone

  • Members
  • Joined: 27 Jun 2007

#168

Posted 25 January 2009 - 02:02 PM Edited by buzbegone, 25 January 2009 - 02:29 PM.

QUOTE (jetter10 @ Jan 25 2009, 17:36)
oh really?

and it doesn't work for me, with dsound.dll in root folder T_T
makes my game crash, works without it though... weird??

You're not alone bud, we're both experiencing congruent problems

Might I make a suggestion, maybe the problem is that people use the bink32.dll that is modded instead of the original that was installed with the patch

jetter10
  • jetter10

    Player Hater

  • Members
  • Joined: 24 Jan 2009

#169

Posted 25 January 2009 - 02:32 PM

think am using the original, tried 2, could anyone post the original?

HazardX
  • HazardX

    pedestrian mangler

  • Members
  • Joined: 13 Dec 2008

#170

Posted 25 January 2009 - 02:53 PM

QUOTE (hristi @ Jan 25 2009, 05:20)
How come it gives me the "R6030 - CRT not initialized" error?

Indeed, same here. Dependencies do not get loaded, in this case MSVCR90.dll, which is required for VisualStudio 2008 projects. confused.gif

juboaku
  • juboaku

    Crackhead

  • Members
  • Joined: 24 Dec 2008

#171

Posted 25 January 2009 - 03:18 PM

QUOTE (hristi @ Jan 25 2009, 04:20)
How come it gives me the "R6030 - CRT not initialized" error?


me too...but then i delete all asi file in my gta4 folder then everything fine (bad english)

Alexander Blade
  • Alexander Blade

    Come As You Are

  • Members
  • Joined: 05 Nov 2006
  • None

#172

Posted 25 January 2009 - 09:26 PM

new version is published now smile.gif download from
http://Alexander.SannyBuilder.com

sjaak327
  • sjaak327

    Big Homie

  • Feroci
  • Joined: 01 Dec 2008
  • None

#173

Posted 25 January 2009 - 09:36 PM

What is changed with the new version ?

The version you posted yesterday was working fine for me.

HazardX
  • HazardX

    pedestrian mangler

  • Members
  • Joined: 13 Dec 2008

#174

Posted 25 January 2009 - 09:42 PM

QUOTE (Alexander Blade @ Jan 25 2009, 22:26)
new version is published now smile.gif download from
http://Alexander.SannyBuilder.com

Hi Alexander, thanks alot for your work! However, the above mentioned error "R6030 - CRT not initialized" occurs with this new version. The error does not pop up in the old version or in XliveLess. The error basically means that the DLL (or ASI in this case) was executed before required dependencies (in this case msvcr90.dll) have been loaded. I guess the dsound.dll behaves somewhat different than the hooked binkw32.dll earlier. I'm not sure how to fix this. i read in articles that the problem would come up when you are loading DLLs rom inside DllMain. Could you take a look at this problem? My .Net ScriptHook causes the error too.

BWARazor
  • BWARazor

    Peon

  • Members
  • Joined: 26 Dec 2008

#175

Posted 25 January 2009 - 09:49 PM

My problem is that the dsound has no effect, im moving Dsound into the GTA IV Root and the .asi file (that is made for the patch 1.2 ) and then i run GTAIV and there is no effect... NO error but also no asi script that i can use ingame

JKM
  • JKM

    [BM] Projectleader

  • Members
  • Joined: 16 Jul 2005

#176

Posted 25 January 2009 - 10:58 PM

QUOTE (Alexander Blade @ Jan 25 2009, 21:26)
new version is published now smile.gif download from
http://Alexander.SannyBuilder.com

the dsound.dll is working fine for me smile.gif
even your new filecheckfix and spawner. Great job Alex icon14.gif

buzbegone
  • buzbegone

  • Members
  • Joined: 27 Jun 2007

#177

Posted 26 January 2009 - 12:25 AM

Yes Alex, thanks for all the speedy updates you've managed to handle for us

Not to be a whiny b*tch but I've replaced my binkw32.dll with the original and still sound.dll crashes
Maybe it's something else that I haven't even considered of yet

Costar
  • Costar

    Li'l G Loc

  • Members
  • Joined: 07 Jan 2006

#178

Posted 26 January 2009 - 12:48 AM

QUOTE (Alexander Blade @ Jan 25 2009, 21:26)
new version is published now smile.gif download from
http://Alexander.SannyBuilder.com

Alex, I have dlded the newer asi loader. The 2 bink files are "fixt", I have the dsound in the game folder, and the other Alice.asi, lua.dll etc... as well as the "superman" script, but it isnt working..

I used to have "Alice" and nothing else, well besides Rappo's Guards.asi, then found Control Center from sarac, I had to get the xlive wrapper and it said to remove other asi loaders, so to try it out, I did, CC workt fine till the new game patch..

Well, out came a new xlive wrapper so I put that in, "Guards.asi" now works again, CC has not been updated yet ..
Anyway, thing is, I can't seem to get your stuff to work now, even w/ the above files I mentioned, being in their correct directories. I've not yet received any errors at all, superman.lua simply is not initializing. If there is any info you need to determine a cause, leme know, Thx smile.gif

Anach
  • Anach

    Square Civilian

  • Members
  • Joined: 21 Dec 2008

#179

Posted 26 January 2009 - 03:05 AM

QUOTE (buzbegone @ Jan 26 2009, 00:25)
Yes Alex, thanks for all the speedy updates you've managed to handle for us

Not to be a whiny b*tch but I've replaced my binkw32.dll with the original and still sound.dll crashes
Maybe it's something else that I haven't even considered of yet

My bink32.dll is version 1.8.12.0. In case your version differs.

I did a repair install of GTA and reinstalled both patches, just to be sure it was a clean install before I started modding again.

I use Jonesoft generic mod enabler in most games I play, which backs up everything that's replaced by mods, however, i had not used it from the start, so there were certain things I was unsure about.

buzbegone
  • buzbegone

  • Members
  • Joined: 27 Jun 2007

#180

Posted 26 January 2009 - 03:06 AM

Do you mind making another update with a few bug fixes maybe Alex?
The majority of people who visit this topic have experienced a problem or two with the new update

As for me, I have reinstalled the game and replaced filelist.pak and then added dsound.dll but it crashes before the it actually starts

I don't want to sound like a broken record when being compared to the other people who've experienced this but can you please make another update?




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users