Quantcast

Jump to content

» «
Photo

Solution to grainy shadows?

65 replies to this topic
LOSEROCK
  • LOSEROCK

    Crackhead

  • Members
  • Joined: 12 Apr 2005

#31

Posted 06 December 2008 - 08:49 AM

Damn Rockstar! I expected so much more from them...
I want someone to release a Limit Adjuster like the one Sacky released for San Andreas... That'll fix it.

Rasmussen
  • Rasmussen

    Player Hater

  • Members
  • Joined: 03 Dec 2008

#32

Posted 06 December 2008 - 09:21 AM

QUOTE (plaguelord69 @ Dec 5 2008, 17:59)
So can somone confirme that he has still grainy shadows when textures set to high.


I have still grainy shadows and trees with High Texture and High Rendering.
No difference between 8800GTS 320MB( running 1024x768) and My new 9800GT 1GB (just bougth so i can run in 1680x1050)

The hole scene is flickering with this grainy shadow, and the trees are flickering to.




Rasmussen
  • Rasmussen

    Player Hater

  • Members
  • Joined: 03 Dec 2008

#33

Posted 06 December 2008 - 09:29 AM Edited by Rasmussen, 06 December 2008 - 11:38 AM.

QUOTE (Chiba @ Dec 5 2008, 09:55)
I read that too, but why are there so many PC version screenshots with good looking shadows? Like these for example. So obviously not everyone has them and I hope there's some kind of easy fix out there.


These shot's was taken with "Post Processing Blur and Bloom effects" the useless "P" key toggle, so they don't count.

adhome
  • adhome

    Crackhead

  • Members
  • Joined: 06 Dec 2008

#34

Posted 06 December 2008 - 12:43 PM

user posted image
http://www.dateispei.....fx fehler.jpg

They only need to add a blure only to the Shadows. Full screen Blure wirth 'P' is no solution.

The shader are in seperate fles on Disk. Perhaps a Mod is possible. Sure a complete new renderpath is needed?
All other Games can make smooth shadows. This will look 1000x better as this screen....

They only need to add a blure only to the Shadows. Full screen Blure wirth 'P' is no solution.

The shader are in seperate fles on Disk. Perhaps a Mod is possible. Sure a complete new renderpath is needed?
All other Games can make smooth shadows. This will look 1000x better as this screen....

CukyDoh
  • CukyDoh

    Crackhead

  • Members
  • Joined: 03 May 2008

#35

Posted 06 December 2008 - 01:28 PM

QUOTE (adhome @ Dec 6 2008, 12:43)
The shader are in seperate fles on Disk. Perhaps a Mod is possible.

If the shaders weren't in a compiled format, and I just had the raw shader code to work with, I could probably do it.

plaguelord69
  • plaguelord69

    Player Hater

  • Members
  • Joined: 05 Dec 2008

#36

Posted 06 December 2008 - 02:00 PM

@ad home, ye man those picture looks terrible.Lets hope those new drivers from nvidia and ati will fix some issue.
But the simple and moust best solution is to remove shadows.

Well from those grainy shadows we can see that they didnt worked on the game engine to fully port it for pc users.
This is not a half port of the game in my oppinion.
And now they wonder why people are returning back games.

pc version =console version

1. grainy shadows
2. the game seems to use only procesor power but not the gpu so much.
3. 2 gigs of ram are enough

They need to fix that or this will be another big misstake for pc gaming industry
This is half product.
Sorry foR OT.

ati is realasing drivers for 3 days so we will see.
But i dont expect much.

Chiba
  • Chiba

    Player Hater

  • Members
  • Joined: 26 Jun 2005

#37

Posted 06 December 2008 - 03:26 PM

Just curious: was there a similar uproar when GTA IV was released on consoles? Or are console gamers just used to such ugly graphics?
Cause I really don't understand why this wasn't fixed for the PC version. It's nothing that could have been easily ignored by the developers, it's the first thing you notice when you start the game.

unuinu
  • unuinu

    Player Hater

  • Members
  • Joined: 05 Dec 2008

#38

Posted 06 December 2008 - 04:08 PM

I know some ppl are not having the same issue with the shadows.

could it be vista? does this game support dx10 at all?!? because dx10 has better lighting and shadows correct? I am installing vista today and can report back.

Matoxic
  • Matoxic

    Player Hater

  • Members
  • Joined: 06 Dec 2008

#39

Posted 06 December 2008 - 04:13 PM

QUOTE (unuinu @ Dec 6 2008, 16:08)
I know some ppl are not having the same issue with the shadows.

could it be vista? does this game support dx10 at all?!? because dx10 has better lighting and shadows correct? I am installing vista today and can report back.

I'm using vista and the shadows are grainy, not saying GTA IV doesn't support dx10.. But I've seen the same type of shadow/textures used in Fallout 3 that GTA uses (some people will know what I mean).. But that's ok for fallout 3 because it's dark and grungy.. GTA is too cleancut unless it's nightime


adhome
  • adhome

    Crackhead

  • Members
  • Joined: 06 Dec 2008

#40

Posted 06 December 2008 - 05:12 PM

I simply played some time further. It's only in sunhineweather so bad. It will not disturb so mutch as the fist time with lots of sun.
I suggest play some time.

Most time it is darker and you will see no shadows. At least you can switch on Bluer with 'p' for short time.

Psycold
  • Psycold

    Snitch

  • Members
  • Joined: 05 Dec 2008

#41

Posted 06 December 2008 - 06:58 PM

QUOTE (Rasmussen @ Dec 6 2008, 09:21)
QUOTE (plaguelord69 @ Dec 5 2008, 17:59)
So can somone confirme that he has still grainy shadows when textures set to high.


I have still grainy shadows and trees with High Texture and High Rendering.
No difference between 8800GTS 320MB( running 1024x768) and My new 9800GT 1GB (just bougth so i can run in 1680x1050)

The hole scene is flickering with this grainy shadow, and the trees are flickering to.

that actually makes me happy that a 1gb card doesn't make any difference, gives me confidence that my card is not as outdated as the game makes me feel it is

kiraly5
  • kiraly5

    Player Hater

  • Members
  • Joined: 07 Dec 2008

#42

Posted 07 December 2008 - 07:21 PM Edited by kiraly5, 07 December 2008 - 07:27 PM.

Hi, I have the same issue. My hardware is:
-Windows XP, SP3
-video card: Geforce 9800 GT, 512 MB
-processor: AMD Athlon X2 Dual Core, 3.0 GHz
-RAM: 2 GB

The shadows really look crap especially, as you have said before, the shadows of the trees and these kind of things. Well, I have been asking my friends around and one of them has vista and an 8800GT. He says the shadows work fine. So I don't really know the solution, I hope there will be a patch for this.

scandal2
  • scandal2

    Player Hater

  • Members
  • Joined: 04 Dec 2008

#43

Posted 07 December 2008 - 07:40 PM

Same problem, terrible shadows and annoying flickering with streetlights and trees shadows.
8800gts 512

Jancis
  • Jancis

    Player Hater

  • Members
  • Joined: 07 Dec 2008

#44

Posted 07 December 2008 - 11:04 PM

like many others, the same... XFX 8800GT Alpha Dog, gave the game to my griend with some kind of 9600GT, the same shadow problem, and another firend with another brand 8800GT and he is complaining about those sahdows. Well, I don`t know... it is the only thing, that disturbes me to play the game properly. I really hope, that there will bee some kind of patch witch will fix this problem, because it is unapceptable for this game confused.gif

Gemini][
  • Gemini][

    Player Hater

  • Members
  • Joined: 07 Jun 2005

#45

Posted 07 December 2008 - 11:21 PM

People...

The Fugly shadows won't go away. It's a technique the engine uses, just like in MASS EFFECT.
That's because we get ports directly from the console versions, with no reworked shadowing paths.

Ashok0
  • Ashok0

    Player Hater

  • Members
  • Joined: 07 Dec 2008

#46

Posted 08 December 2008 - 01:26 AM

QUOTE (Gemini][ @ Dec 7 2008, 23:21)
People...

The Fugly shadows won't go away. It's a technique the engine uses, just like in MASS EFFECT.

Well... the shadows in MASS EFFECT looked fine. What the h*** is wrong with the shadows in GTA4?

ghettophat
  • ghettophat

    Player Hater

  • Members
  • Joined: 06 Dec 2008

#47

Posted 08 December 2008 - 02:41 AM

agreed shadows in mass effect r perfect

i have an ati 512 mb 1900xt, and i get all the mentioned problems

patch pleaaaassseeeee.

Ahm3dS
  • Ahm3dS

    SiLveR RiNHo! FTW!

  • BUSTED!
  • Joined: 07 Dec 2008

#48

Posted 08 December 2008 - 06:11 AM

Same Here...

Hope R* fix this sad.gif sad.gif

Cdnalsi
  • Cdnalsi

    PC Gaming Masterrace

  • Members
  • Joined: 15 May 2008

#49

Posted 08 December 2008 - 06:22 AM

Same issues here as well. Shadows and trees and flickering during the night.

9600m GT latest nVidia GTA drivers..

Gemini][
  • Gemini][

    Player Hater

  • Members
  • Joined: 07 Jun 2005

#50

Posted 08 December 2008 - 11:37 PM

QUOTE (Ashok0 @ Dec 8 2008, 01:26)
QUOTE (Gemini)
[,Dec 7 2008, 23:21] People...

The Fugly shadows won't go away. It's a technique the engine uses, just like in MASS EFFECT.

Well... the shadows in MASS EFFECT looked fine. What the h*** is wrong with the shadows in GTA4?

You're kidding me, right?
http://masseffect.bi...31425&forum=127

necKros
  • necKros

    Player Hater

  • Members
  • Joined: 08 Dec 2008

#51

Posted 09 December 2008 - 12:13 AM

Well, I have the same problem with my 9600GT. I also experimented this very issue in Mass Effect, so I guess it's a card side problem.

It is, indeed, a problem not only with shadows, but with the way the game handles transparency. You will also encounter this when long range textures "fade" into bigger ones, when the scenery pops up and in transparent textures like tree leaves, wired fences and things like that. Instead of fading well, they use a dither effect, giving that grainy, mspaint-looking impression.

This is not something that happens to everyone, so I don't think I will go and accept it. I've played other games with dynamic shadows and they look ok.

Maybe the way GTA4 engine is designed will not be able to do this work properly on our cards, and this problem won't be fixable for us, but I'd like to hear R*'s word about this.

siapnar
  • siapnar

    Rat

  • Members
  • Joined: 03 Dec 2008

#52

Posted 09 December 2008 - 01:14 AM

QUOTE (Flat Face @ Dec 5 2008, 17:35)
um... i own it on ps3 and the shadows are grainy, its just how it is so get used to it.

Yep

siapnar
  • siapnar

    Rat

  • Members
  • Joined: 03 Dec 2008

#53

Posted 09 December 2008 - 01:23 AM

I found some shadow values in visualSettings.dat:

imposter.shadow.blendRange 12.00 <--- probably changes how far the shadows blend more into each other (you can see this effect further in the distance ingame)
imposter.shadow.blendBias 128.00 <--- I think this drops the resolution from "imposter.shadow.size1" to the value set. I could be way off though
imposter.shadow.size1 256.00 <--- Shadow resolution, no doubt. Making the resolution higher will probably pixelate the shadows more. Or not. Dunno.
imposter.shadow.amt1 12.00 <--- No idea.. amt?
imposter.shadow.size2 128.00 <--- Shadow resolution of dynamic shadows maybe (the shadows cast by your car lights at night)
imposter.shadow.amt2 64.00 <--- No idea.. amt?

Hell, I don't even know if these are the proper shadow settings..

IF YOU AREN'T ALL THAT PROFICIENT WITH COMPUTERS I WOULDN'T SUGGEST ALTERING THESE UNTIL THEY HAVE BEEN TESTED BY MORE TECH SAVVY PEOPLE

I'll try some different settings out either tonight or tomorrow

vokuhila
  • vokuhila

    Player Hater

  • Members
  • Joined: 09 Dec 2008

#54

Posted 09 December 2008 - 02:32 PM

I really hope these are general settings, but since the values a few lines above talk about tree.imposters - might they only affect shadows of trees and leafs etc?

Gemini][
  • Gemini][

    Player Hater

  • Members
  • Joined: 07 Jun 2005

#55

Posted 09 December 2008 - 07:00 PM

QUOTE (necKros @ Dec 9 2008, 00:13)
Well, I have the same problem with my 9600GT. I also experimented this very issue in Mass Effect, so I guess it's a card side problem.

It is, indeed, a problem not only with shadows, but with the way the game handles transparency. You will also encounter this when long range textures "fade" into bigger ones, when the scenery pops up and in transparent textures like tree leaves, wired fences and things like that. Instead of fading well, they use a dither effect, giving that grainy, mspaint-looking impression.

This is not something that happens to everyone, so I don't think I will go and accept it. I've played other games with dynamic shadows and they look ok.

Maybe the way GTA4 engine is designed will not be able to do this work properly on our cards, and this problem won't be fixable for us, but I'd like to hear R*'s word about this.

It's not your card. It's just the way the shadow path has been implemented on the console version of the game. Since R* didn't rework the path for PC users, we get the same shadowing techique. The same for Mass Effect. If you check the 360 version, the problem is also there.

plaguelord69
  • plaguelord69

    Player Hater

  • Members
  • Joined: 05 Dec 2008

#56

Posted 09 December 2008 - 07:20 PM

I tried to set some options on 0 but the game wasnt responding, so i belive only they know what the paths mean.
ANd i do belive we mortals cant chagne the way game works.

Patch cooming this week i hope.

necKros
  • necKros

    Player Hater

  • Members
  • Joined: 08 Dec 2008

#57

Posted 09 December 2008 - 07:49 PM

QUOTE (Gemini][ @ Dec 9 2008, 19:00)
QUOTE (necKros @ Dec 9 2008, 00:13)
Well, I have the same problem with my 9600GT. I also experimented this very issue in Mass Effect, so I guess it's a card side problem.

It is, indeed, a problem not only with shadows, but with the way the game handles transparency. You will also encounter this when long range textures "fade" into bigger ones, when the scenery pops up and in transparent textures like tree leaves, wired fences and things like that. Instead of fading well, they use a dither effect, giving that grainy, mspaint-looking impression.

This is not something that happens to everyone, so I don't think I will go and accept it. I've played other games with dynamic shadows and they look ok.

Maybe the way GTA4 engine is designed will not be able to do this work properly on our cards, and this problem won't be fixable for us, but I'd like to hear R*'s word about this.

It's not your card. It's just the way the shadow path has been implemented on the console version of the game. Since R* didn't rework the path for PC users, we get the same shadowing techique. The same for Mass Effect. If you check the 360 version, the problem is also there.

Well yeah, except the shadows look ok in some PCs.

Gemini][
  • Gemini][

    Player Hater

  • Members
  • Joined: 07 Jun 2005

#58

Posted 09 December 2008 - 08:27 PM

QUOTE (necKros @ Dec 9 2008, 19:49)
QUOTE (Gemini)
[,Dec 9 2008, 19:00]
QUOTE (necKros @ Dec 9 2008, 00:13)
Well, I have the same problem with my 9600GT. I also experimented this very issue in Mass Effect, so I guess it's a card side problem.

It is, indeed, a problem not only with shadows, but with the way the game handles transparency. You will also encounter this when long range textures "fade" into bigger ones, when the scenery pops up and in transparent textures like tree leaves, wired fences and things like that. Instead of fading well, they use a dither effect, giving that grainy, mspaint-looking impression.

This is not something that happens to everyone, so I don't think I will go and accept it. I've played other games with dynamic shadows and they look ok.

Maybe the way GTA4 engine is designed will not be able to do this work properly on our cards, and this problem won't be fixable for us, but I'd like to hear R*'s word about this.

It's not your card. It's just the way the shadow path has been implemented on the console version of the game. Since R* didn't rework the path for PC users, we get the same shadowing techique. The same for Mass Effect. If you check the 360 version, the problem is also there.

Well yeah, except the shadows look ok in some PCs.

I guess that people don't see the problem as we do, or it's one of the settings. I'll try with the rendering options, but I doubt that people with dynamic shadows and the highest rendering setting are getting other results.

Marcin6
  • Marcin6

    Hustler

  • Members
  • Joined: 18 Jul 2007
  • Poland

#59

Posted 09 December 2008 - 08:40 PM

The same here

Run game at 9800 GTX+ BFG

MMhardKy
  • MMhardKy

    Rat

  • Members
  • Joined: 10 Apr 2007

#60

Posted 09 December 2008 - 09:34 PM

QUOTE (necKros @ Dec 9 2008, 19:49)
QUOTE (Gemini)
[,Dec 9 2008, 19:00]
QUOTE (necKros @ Dec 9 2008, 00:13)
Well, I have the same problem with my 9600GT. I also experimented this very issue in Mass Effect, so I guess it's a card side problem.

It is, indeed, a problem not only with shadows, but with the way the game handles transparency. You will also encounter this when long range textures "fade" into bigger ones, when the scenery pops up and in transparent textures like tree leaves, wired fences and things like that. Instead of fading well, they use a dither effect, giving that grainy, mspaint-looking impression.

This is not something that happens to everyone, so I don't think I will go and accept it. I've played other games with dynamic shadows and they look ok.

Maybe the way GTA4 engine is designed will not be able to do this work properly on our cards, and this problem won't be fixable for us, but I'd like to hear R*'s word about this.

It's not your card. It's just the way the shadow path has been implemented on the console version of the game. Since R* didn't rework the path for PC users, we get the same shadowing techique. The same for Mass Effect. If you check the 360 version, the problem is also there.

Well yeah, except the shadows look ok in some PCs.

No they doesn't. Only the "postprocessing" (or "blur", how many people are calling it here) is activated. Try pressing the "p" key on your keyboard.

THE SHADOWS ARE SUPPOSED TO LOOK LIKE THAT PEOPLE

They always had. I have the PS3 version also and its the same. Enable postprocessing and shadows will look MUCH better.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users