Quantcast

Jump to content

» «
Photo

All Controllers WORKING!

1,081 replies to this topic
Pablos544
  • Pablos544

    Player Hater

  • Members
  • Joined: 27 Mar 2012

#1051

Posted 27 March 2012 - 08:23 AM

QUOTE (Remizov @ Thursday, Dec 4 2008, 18:07)
Best edit that link first:

http://lcsteam.net/d...r.emulation.zip

I can hereby confirm that that second link works, whereas the first didn't do much. The link that works has 4 "xinput_XX.dll" files and nothing else. I advice ignore the one that has "xbox360cemu.ini" file as this seems to be a bit of a bogus!!

l008com
  • l008com

    Player Hater

  • Members
  • Joined: 05 Dec 2008

#1052

Posted 07 April 2012 - 03:46 AM

Is there a web page that explains how to get standard controllers working with this game, without having to read through 4 years and 53 pages of conversation?

Jackath
  • Jackath

    Player Hater

  • Members
  • Joined: 11 Apr 2011

#1053

Posted 09 April 2012 - 06:55 PM

Hey umm, I have a Nyko Airflo EX will it work? Also it says "Invalid Resource Detected" Please reinstall game D:

Jackath
  • Jackath

    Player Hater

  • Members
  • Joined: 11 Apr 2011

#1054

Posted 09 April 2012 - 07:01 PM

Scratch that part about invalid resource but it doesn't seem to work for me D: Please help! Again I have a Nyko Airflo EX

Nagual
  • Nagual

    Player Hater

  • Members
  • Joined: 17 Jun 2012

#1055

Posted 17 June 2012 - 02:49 AM

Hello All,

first of all THANK YOU SO MUCHO!
It took me a few hours but it finally got the job done.
One tiny small gripe though..
It seems the 'back' button (select on my ps2 style gamepad) doesn't cycle through the camera angles.
It works when I test it in Xinput and ingame, when I hold it for a second or two, it also saves a clip.
But just tapping it won't change the camera!

I've spent alot of pages searching but couldn't find the answer.
Any Ideas?

ps. version = 6
OS= Windows 7 64-bit

Cheerrsss!!

v3teran
  • v3teran

    Player Hater

  • Members
  • Joined: 01 Aug 2012

#1056

Posted 03 August 2012 - 02:12 PM

Im using a ps2 pad through a rockfire converter and all the buttons work except for one axis on analogue joystick 2(right one),i have tried everything so i now use xpadder and it works great with any game.

vilenightwing
  • vilenightwing

    Player Hater

  • Members
  • Joined: 13 Aug 2012

#1057

Posted 13 August 2012 - 02:05 AM

So i've tried this and it mostly works (gta through steam v 1.07 i think using"xinput1_3.dll") with my logitech g13 but when i use the joystick the camera becomes extra sensitive and returns to default position almost instantly. Has anyone has this or know a fix. thanks in advance.

Mutagen
  • Mutagen

    Player Hater

  • Members
  • Joined: 16 Aug 2012

#1058

Posted 16 August 2012 - 02:19 PM

when i use the xInput test on status reads not connected even thought the controller is connected, i've tried changing the name of the dll and it hasn't worked so far in game, any suggestions?

forxthexbirdsx
  • forxthexbirdsx

    Player Hater

  • Members
  • Joined: 21 Aug 2012

#1059

Posted 21 August 2012 - 05:31 AM

How do I unpack the files, do I just drag and drop, and also how do I find the gta4 dir. file

Prometheus
  • Prometheus

  • Moderator
  • Joined: 18 Apr 2011
  • None

#1060

Posted 21 August 2012 - 02:17 PM

QUOTE (forxthexbirdsx @ Tuesday, Aug 21 2012, 05:31)
How do I unpack the files, do I just drag and drop, and also how do I find the gta4 dir. file

Exactly, simply drag and drop. Also if you have installed GTA IV to the default directory which is chosen during installation, it should be in:

For x86 [32-bit Windows] | C:\Program Files\Rockstar Games\Grand Theft Auto IV

For x64 [64-bit Windows] | C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV

smile.gif

thanos388
  • thanos388

    Player Hater

  • Members
  • Joined: 20 Jan 2009

#1061

Posted 17 November 2012 - 09:55 AM

i read all posts and i didnt figured out something... I have installed GTA EFLC and i am using a generic usb controller.After many tries u managed to get it working but buttons need remap and whatever i did i cant change them.. is there any chance or i should quit trying?

Tori_95
  • Tori_95

    PHD Guy

  • Members
  • Joined: 02 Jan 2012

#1062

Posted 18 November 2012 - 03:26 AM


does this has the sensitive pads (i mean no complete wheel rotation like in keyboard)?

mkey82
  • mkey82

    Keep riding hard, son

  • Members
  • Joined: 14 Feb 2008

#1063

Posted 18 November 2012 - 10:15 AM

QUOTE (thanos388 @ Saturday, Nov 17 2012, 11:55)
i read all posts and i didnt figured out something... I have installed GTA EFLC and i am using a generic usb controller.After many tries u managed to get it working but buttons need remap and whatever i did i cant change them.. is there any chance or i should quit trying?

The buttons can be remapped with the configuration files that are present in the archive.

faizanali
  • faizanali

    Proud PC Gamer

  • BUSTED!
  • Joined: 21 Oct 2011

#1064

Posted 18 November 2012 - 12:13 PM

I usually play Non-Gamepad Compatible games with Xpadder, And yes the emulator has been fine for a few years, It automatically detects the game and takes someone's profile from the Internet.

JillSaphic
  • JillSaphic

    Player Hater

  • Members
  • Joined: 08 Apr 2012

#1065

Posted 18 November 2012 - 12:32 PM

I made it through 15 pages of this thread,, and it works!
PS2 + USB into my Lenovo WS laptop. Ive had the game
since Sept. (not the download) and just found the
WS-10 error fix, and now this emulator.
Thank you Catskill and S. Racer. Only had to change the axis controls!
(took about 20 minutes) I didnt know you had to restart the game to see
the changes you made in the gamepad settings take effect.
Thank you!
user posted image

thanos388
  • thanos388

    Player Hater

  • Members
  • Joined: 20 Jan 2009

#1066

Posted 19 November 2012 - 07:19 AM Edited by thanos388, 19 November 2012 - 12:29 PM.

I made remapping with xbox360emu and works fine wink.gif

mistamatrix
  • mistamatrix

    Player Hater

  • Members
  • Joined: 24 Nov 2012

#1067

Posted 24 November 2012 - 02:30 PM

Hi everyone just joined to add my own spin on all this. I've had no luck with any of the suggestions in this thread trying to get my PSone pad working in Steam GTA 4, spent a good couple of hours trying everything last night to no avail. Tried again today and discovered x360ce, and amazingly it worked. No bull.

Download the following:

http://code.google.com/p/x360ce/
http://download.gta-...joypad-mod.html


Put the x360ce file into the GTA 4 folder and run the software, accept the files it mentions and let it search for a profile online. It should be as simple as that, but you can configure it manually. Once done you can close the program and save your changes.

Put the controller textures into the ..\GTAIV\pc\textures folder on your installation overwriting the old ones (feel free to back them up).

Open the game and you will see now that the Playstation pad is now fully featured, even to the point of the ingame tutorials etc. and it's wonderful.

Had to share this with you guys, since I'm sure there's still people stuck like I was.

mishobg12
  • mishobg12

    Player Hater

  • Members
  • Joined: 24 Dec 2012

#1068

Posted 24 December 2012 - 02:41 AM

I would like to share my experience with this, hopefully it will make someone's life easier. Note: Jump to the text in bold if you are only interested in what worked for me.

Initially, I copied all the files from the zip in the first post in my GTA folder (am using x64 windows 7, so that is C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV ). What happened is that the game crashed after the rockstar-logos intro. The XInputTest would crash also.

Then I tried the zip file in the 3rd (or 4th) post (the one that contains only dll files). The game was able to ran and the gamepad worked, but with no vibration. It also seemed like the dll is completely ignoring the ini file, because any changes I made in there weren't making a difference. I guess that's why vibration didn't work - cause it is disabled by default.


I managed to trace the source of the hack to this webpage and I found a newer version called x360ce_vibmod_3101_beta3 that is available here.

Now, remember. You need the file to be called xinput9_1_0.dll , NOT xinput1_3.dll. Download the file, put it in the gta folder and rename it to the proper name. Also, this version reads the settings from x360ce.ini , NOT xbox360cemu.ini . However, the x360ce.ini that is available at that last link is for some exotic controller, so what I did was I used the xbox360cemu.ini from the zip in the first post and renamed it to x360ce.ini .


My controller is speedlink sl-6535-sbk-01. The only modifications I had to make in the ini file from the first zip was to reorder the A,B,X,Y buttons like this:

CODE

A=3    #button id; 0 to disable
B=2    #button id; 0 to disable
X=4    #button id; 0 to disable
Y=1    #button id; 0 to disable


Hope this helps. Happy gaming!

DRUZZRIN12296
  • DRUZZRIN12296

    Square Civilian

  • Members
  • Joined: 04 Aug 2009
  • None

#1069

Posted 15 January 2013 - 08:57 PM

I use a PS3 controller, using MotionInJoy. Works very well, but would someone be able to tell me how I can set up wireless feature? I was wondering whether I could use my Logitech anywhere dongle from my mx mouse..? Or would I have to buy a separate bluetooth dongle? The anywhere thing says it can have multiple devices connected to it but I wasn't sure if this meant only Logitech, please someone help or move this topic biggrin.gif

AkmalMazny
  • AkmalMazny

    Player Hater

  • Members
  • Joined: 25 Jan 2013

#1070

Posted 25 January 2013 - 10:07 AM Edited by AkmalMazny, 25 January 2013 - 10:16 AM.

Hey Why After Paste The File On Gta Iv Directiory I Got A Crash ?

confused.gif

Here For The Pix

user posted image


Mbergh22
  • Mbergh22

    Player Hater

  • Members
  • Joined: 01 May 2008

#1071

Posted 24 March 2013 - 08:00 PM

I have tried the steps and most everything works except for the joysticks. I just have the Logitech Dual Action controller and I can not move left or right using the left joystick or change the camera left or right using the right joystick. I can only go up and down on both. Any help would be great.

rober87
  • rober87

    Player Hater

  • Members
  • Joined: 31 Mar 2013

#1072

Posted 31 March 2013 - 07:11 PM

Is there also for the Xbox-controller itself a solution, maybe with this tool, to individual change all buttons?

Furthermore I noticed if I use the Xbox-controller viewing arround the car and stopping it,
the camera doesn't go back in standard position, but if I used the mouse, camera does! sad.gif Is there a solution?

WitchMX
  • WitchMX

    Player Hater

  • Members
  • Joined: 05 May 2013

#1073

Posted 05 May 2013 - 09:30 AM

Hey Guys... I need help.


While trying to follow this process I messed up something and now a lot of my games wont start. First, Y bought GTA 4 through Steam, I dont know if that is why the game directory is not in C:/ Program Files:/Rockstar Games.. Instead I found it in a hidden folder in the Username:/ APPData:/Local folder.

The thing is that in the instructions it said to put the .dll files in the GTA directory, but a few posts later there where some guys saying that they had to be pasted on the sysWOW64 folder.... So I did that, because I could not find my game directory... The thing is that I replaced (did not back up all of them) and now the game wont even start (gta, skyrim, tomb raider)....

I tried re installing DirectX with no luck, I eve re installed GTA but nothing....

Anyone could help me?

Thanks in advance

Arclight83
  • Arclight83

    Player Hater

  • Members
  • Joined: 10 May 2013

#1074

Posted 10 May 2013 - 11:32 AM

Everything in GTA IV with my gamepad worked fine.

I've just started EFLC, but the only issue I have is that the right analogue stick is messed up. Pushing up/down rotates the camera and pushing left/right moves camera up or down.

Any ideas?

gakkenost
  • gakkenost

    Player Hater

  • Members
  • Joined: 09 Aug 2013

#1075

Posted 09 August 2013 - 11:28 PM

i cant get annything to work.

i used the archive and the game crashes when the money was supposed to come up, i used the other archive that was submitted later, the controller works but the a b x y is on the wrong places, and i cant fix it in the other archive because it does not have any files i can customize in. i tried to do mixes between different files, but nothing helps.. any suggestions?

mva1997
  • mva1997

    Player Hater

  • Members
  • Joined: 29 Jan 2013

#1076

Posted 03 September 2013 - 04:04 PM

I started the game. And when the game is ready to be played, the camera turns to my feet and cannot see straight. What's going on?

Capten Morgan
  • Capten Morgan

    Square Civilian

  • Members
  • Joined: 08 Sep 2013

#1077

Posted 08 September 2013 - 03:15 AM

I started the game. And when the game is ready to be played, the camera turns to my feet and cannot see straight. What's going on?

Try X-PADDER its simple and free,just google, and you can map your controller to about 150 buttons...


TheBandit69
  • TheBandit69

    Player Hater

  • Members
  • Joined: 25 Dec 2013

#1078

Posted 26 December 2013 - 04:29 AM

Doesn't work at all for me. Using a ps3 controller.


KreepyKakes
  • KreepyKakes

    Player Hater

  • Members
  • Joined: 29 Dec 2013

#1079

Posted 29 December 2013 - 09:56 PM

Hey guys how do i change button configs? i don't seem to get it

Fire and Aim are on Left and Right, I want them to be in reverse


jpm1
  • jpm1

    Vice city citizen

  • Members
  • Joined: 26 Sep 2005
  • None

#1080

Posted 30 December 2013 - 01:08 AM

i use Joy to key . it emulates whatever you want and has almost endless possibilities . just purchased a GXT24 3 days ago and with its 12 programmable buttons , I can drive in Vice city using signals . i park the car then i turn off the lights before turning off the engine . i don't have to come to the keyboard to set the good radio each time anymore :yingyang:





3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users