Quantcast

Jump to content

» «
Photo

Flaky AI

  • This topic is locked This topic is locked
33 replies to this topic
Rasdock
  • Rasdock

    Player Hater

  • Members
  • Joined: 01 May 2007

#1

Posted 03 December 2007 - 11:38 PM

For some reason, I think I've seen this mentioned before, but I can't find it right now. I have a finished game that I've been playing since April (probably finished in July or so), and it has suddenly gotten really flaky. AI cars crash probably more than they just drive down the road, and I very, very often will see them up ahead facing in my direction, and they do a quick 180 and continue on their way. I'll see a whole highway of cars do this, and it's really annoying.

Is this probably caused by my saving my game too often in the same slot? I got tired of the behaviour, so I started a brand new game (which I have also now finished) and the AI cars are acting normal on this set of saves.

GTA Phreak
  • GTA Phreak

  • Members
  • Joined: 25 Apr 2007

#2

Posted 04 December 2007 - 12:41 AM

I believe that the "car suddenly switch ends and drives backwards in plain view" is a save related glitch.
Once you got it, it remains on subsequent saves. So you have to go back to an unglitched save or start from beginning.

If you still have the glitched save try uploading it ( http://gtasnp.com ) and post the link here, then maybe some of the resident save experts can have a look at it (and possibly come up with a fix)

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#3

Posted 04 December 2007 - 12:46 AM

Yes, assuming you have the PC version, definitely upload the save. We've made great progress recently on decoding the save file and I'd love to take a shot at detecting and repairing this glitch, but I lost the one save I had with this glitch active.

Rasdock
  • Rasdock

    Player Hater

  • Members
  • Joined: 01 May 2007

#4

Posted 04 December 2007 - 09:23 AM

Okay, here it is:

http://gtasnp.com/6162

Earlier, I loaded the game and saved it in a different slot. I assume that won't have fixed the bug, so this save should be exhibiting the problem.

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#5

Posted 04 December 2007 - 12:14 PM

Thank you. I loaded the save and saw what I was expecting. I notice you also have a stray blip on your map. Any idea when that showed up?

This save looks like a pretty good sample - at least from what I could tell from the game and stats. I'll start digging into the save file fairly soon, but I don't want you waiting around for something dramatic. Do you need this save repaired for some reason, or are you mostly trying to track down your glitch?

So you had been playing this save for a quite a while before things got screwy. Were you working on side-missions when you noticed the glitch, or just having fun on the map? Any idea which events or missions you completed shortly before the NRG-500 challenge?

Since I seem to remember one of my good pals getting this glitch, I think it's fair to assume that cheats, trainers, and mods are not a factor. Saving in the same slot shouldn't make a difference, and I'm fairly certain the save I lost didn't have all that many saves on it. Can you think of anything strange you may have done to cause this glitch? Keep in mind that this is an extremely rare glitch, so any of the common non-standard methods of game play are less likely to be the source.

I've got 1 very old clue to follow up on and if that doesn't pan out I'll need to start replacing entire blocks of memory until I can isolate the source. It's a process that's likely to take a long time and produce no results.

BTW, it took all of 10 minutes to get these screenshots.

user posted image user posted image

Rasdock
  • Rasdock

    Player Hater

  • Members
  • Joined: 01 May 2007

#6

Posted 04 December 2007 - 10:54 PM

The stray marker at Sweet's house hounded me for a long time. I got it before CJ was exiled from Los Santos, and I think it showed up after the Sweet's Girl mission. Fortunately, my current playthrough doesn't have it. smile.gif

No, I don't have a real need for the save to be fixed. I was just curious about the glitch and figured someone else might have an answer or want to know about it. After finishing the game, I've pretty much just been firing it up to drive around listening to music, or perhaps cause a little mayhem with the Rhino. I'd been doing that for months when the problem appeared all of a sudden. That's why I restarted the game (and now finished with 100% and no known glitches). I only did the NRG challenge the other day because I half decided to get my old save to 100%. Before that, the save was called "BMX" for a long time, because the BMX challenge was the last real thing I'd done for a long time. I doubt if it matters, but I will say that I was mainly playing in Venturas when the glitch started. The highway by the quarry is where I started seeing the cars in reverse a lot.

You may also notice that the save does not have access to basketball. I also couldn't go to the gym for a while, but that was somehow fixed. I did save at Madd Dogg's long ago, before I even knew that was a no-no.

By the way, no cheats but I did use one of those "10x viewing distance" files a long time ago. I backed up the original file and went back to it before too long. I also replaced my water texture at some point (I went back to the original on that one as well), but I doubt if that would have any bearing. Beyond that, I haven't really done anything outside the bounds of normal play. You'd think I would have with that many hours racked up, but I just go in there to relax and drive around. smile.gif

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#7

Posted 05 December 2007 - 02:48 AM

Well, thanks for the clues. I get the feeling the glitch showed up without doing any side missions.

I'm made some progress, I think. If I replace the global timer with my own then the glitch seems to go away, but then the clock is stopped. If I replace the entire block the clock is working and no glitch is apparent, but the save disks don't work.

Blip repair shouldn't be difficult, and the basketballs are an easy fix, but I'm still confused about what's going on with the timers.

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#8

Posted 06 December 2007 - 12:07 AM

Update:

This glitch certainly has me confused. If I copy your Global Timer value to one of my saves I get the same glitch. Other than being able to identify this variable based on it's position in the save file, I have only the slightest idea about what this variable is supposed to do (it's apparently a "global timer") or how other parts of the game interact with it. Messing with this value always produces strange side effects so formulating a fix is proving to be difficult.

I don't think it is likely that I'll be able to make more progress with this single example to work with. If anyone has a similar problem, please upload the save for examination.

Symptoms of the glitch are:
  • Traffic appears to jitter when driving. This is more apparent when vehicles are driving quickly, but can be a bit subtle. By making direct comparisons with normal saves I got pretty good at recognizing the glitch right away.
  • The more obvious symptoms seem most apparent on the Julius Thruway. A particularly good spot is on the shoulder of the freeway just SW of the train bridge crossing the freeway in NE Las Venturas (a little north of the tunnel and bribe).
  • Cars will disappear and jump a short distance, often appearing backwards.
  • Cars that reappear occasionally merge with other vehicles - the front of the jumping vehicle is embedded in the rear of another.
  • Some vehicles seem more affected than others. Cop Cars and motorcycles were never observed jumping, Perennials and taxis jump frequently.
  • Traffic jams are more common when this glitch is active - but this may not be obvious without a direct comparison.

Rasdock
  • Rasdock

    Player Hater

  • Members
  • Joined: 01 May 2007

#9

Posted 06 December 2007 - 03:00 AM

I wonder if it would always be most apparent at the Julius Thruway for anyone who had the glitch, or if it's because I spend my time in the area most often. I would say that I save at the Four Dragons more than any other save location. I hope my current game doesn't develop the problem, but if it does, I'll upload that save as well. I'm not sure if a second example from the same person would help you or not.

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#10

Posted 06 December 2007 - 03:51 AM

Yes, any addition saves should help. Since the only thing I have to work on is a large global timer, I'm trying to increase the timer on another save using a trainer to speed up the clock and ward off hunger. Maybe someone has a very old save with around 2 CJ year's worth of playing time.

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#11

Posted 06 December 2007 - 08:21 AM Edited by OrionSR, 06 December 2007 - 09:42 AM.

<Save Repair v2>

Give this save a shot. A buddy of mine, pdescobar, is a great deal more clever about Global Timers than I am. He reset it to a low value, and then made adjustments to everything he could think of that was dependent of this timer. On version 1 your prize cars weren't showing up, this version seems to be functioning, but having never attempted this kind of repair it is difficult to anticipate everything that needs a little nudge.

So were are hoping that you might spend a little time with this save and test it out to see what else is broken. We've checked a race, and a stadium event. Cars are working now, and the saves, weapons, assets, and other pickups seem to be working without adjustment. So give it a try and please report anything you notice. If you are skilled at debug reporting, please include a list of everything you test that does work so we don't duplicate our efforts.

I'm probably going to drop research on your save, I've got some other projects to work on. However, I have started an experiment that is using a trainer to increase the game speed on a 100% save in order to run up the Global Timer to see if I can reproduce the glitch by "playing for a long time." It would be disappointing to learn that continuing to improve a save could lead to an unavoidable glitch.

In addition to attempting to repair your traffic problems, PD also fixed the basketball glitch. Well, the basketballs should appear, but the glitch caused by saving at Madd Dogg's Crib is still present. We're testing a fix for that now (move the save away from the court below) and may eventually work up a tool that can move the disk on standard saves and prevent the glitch from happening again.

PD was also quite happy to have a stray blip to play with. These things pop up occasionally so it's been on the list of things to experiment with. I've simulated stray blips before, but this was our 1st real glitch blip to play with. If I understand the process correctly, the blip is now inactive and should soon be recycled and ready for reuse by new blips.

Have fun.

Struff Bunstridge
  • Struff Bunstridge

    ...loading...

  • Members
  • Joined: 09 Nov 2007

#12

Posted 06 December 2007 - 10:17 AM

Speaking of stray blips (not sure if this thread is PC only, but I'm on PS2), after finishing all story missions, I've found a little yellow blip denoting a mission destination above one of the piers in SF. It also appears to be about 400 miles in the air, as no matter how high I fly, it's always higher than I am. Is this the kind of thing already mentioned in this topic, and if not, has anyone heard of/found a solution for this?

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#13

Posted 06 December 2007 - 10:49 AM

Well, I don't think the topic was intended to be PC only, but I'm not sure what to suggest as an option for PS2. If I had access to a save file in a format that looked similar to our PC files I might be able to identify the blip and mark it for deletion and make the appropriate change to the checksum, but then there's the possibility that the PS2 device format used to transfer the save would reject the file as corrupt. I don't think it's likely that this repair can be made without someone with a little more experience with PS2 modding chipping in.

I'm not sure if your specific stray blip has been identified. Some strays seem more common than others but I haven't looked into that much. It seems that occasionally the script will delete the blip icon but doesn't set the blip as inactive and then they stick around forever after that. If you manage to get CJ up to around 1000 meters you should start to come even with that blip. My guess is that it is located inside of an interior which are usually at this elevation, but not visible unless you are in the correct "world" view. Save disk can be seen clustered over the Jefferson area which is where most of the save houses are located.

I'm not sure if the PC and PS2 interiors line up or not. I see different maps and I'm not sure why. Hidden Interiors isn't really my thing - Hidden Interior Map About the only thing I see in the area of the SF piers would be the RC Battle Ground from Zero's 3rd Mission, or perhaps the Kickstart arena out by the ship.

Struff Bunstridge
  • Struff Bunstridge

    ...loading...

  • Members
  • Joined: 09 Nov 2007

#14

Posted 06 December 2007 - 10:57 AM

Thanks for that map OrionSR, I'm at work so can't check my PS2 right now, but if memory serves, the blip is more or less equidistant between the Bloodbowl and Kickstart interiors. Guess I'll try maximum height and see if anything's there. Thanks again!

Rasdock
  • Rasdock

    Player Hater

  • Members
  • Joined: 01 May 2007

#15

Posted 06 December 2007 - 09:40 PM

Thaks for everything, Orion. I'm glad I gave you and your friend some fodder for your bug-squashing efforts. I will be glad to play around with this repair save and let you know what I come up with. Just to give a heads-up and a little checklist for myself, I will probably take the opportunity to get the game to 100%. To do so, I will be doing the following actions:

Finish the three Chiliad challenges
Finish Freight level 2
Find the snapshots
Find the remaining spray tags

I got solid gold on the schools on my current game, so I may try to do the same here. That should be a wide enough range of activity for now, but I'll try to keep track of anything else I might do.

I did think of one other semi-unusual thing I did, and it was not long before the glitch started. I doubt if it's related, but I'll mention it. You know how the harvesters by Helena's house are usually not usable? CJ will pull at the doors to no effect. Well, I was recently blocking the harvester with a car when it was in use, killing the operator, and hopping in and harvesting pedestrians in Santa Maria. I doubt if I'm the first to do that, or if it has anything to do with anything, but I can say for sure that I was doing that not long at all before I started noticing the glitch.

Rasdock
  • Rasdock

    Player Hater

  • Members
  • Joined: 01 May 2007

#16

Posted 06 December 2007 - 11:38 PM Edited by Rasdock, 07 December 2007 - 05:55 AM.

I got some things done, so a brief report. First of all, thanks for getting rid of the stray marker. That's a blessing. I didn't hit the Julius yet, but the cars I did encounter were acting normal, as you said they would. I finished Chiliad and got a couple more golds at the driving school, finished Kickstart, and flew back from Venturas. There was only one odd thing, and it's probably a simple explanation. When I first started the save, I drove from Doherty to the base of Chiliad, and I realized I couldn't get to the top of the mountain in time to do the challenge. I noticed a Clover sitting near the roadside, so I hopped in with the intention of driving to the Angel Pine safehouse. Instead, I got out and took a bicycle and saved. When I got back to the spot, I saw this:

user posted image

I think it was just a case of that being the vehicle spawn spot, and the game was confused to find an activated car in the spot. So, it spawned a bike right on top of it.

Edit: After this, I finished the train missions, got all the snapshots and the tags for 100%. Gambled a little. Nothing odd at all.

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#17

Posted 07 December 2007 - 07:54 AM

Thanks for the update. I haven't looked at your save again, I'm back to testing my own saves, but I am keeping an eye on the topic. Just so you know, I'm hoping you find something else amiss, that when repaired, will bring back the glitch. Otherwise I'm stuck with the hypothesis that too much play leads to this glitch, and I'm not the least bit happy with that possibility.

And yeah, it sounds like you are on the right track for debug checking. The stuff you wanted to do anyway was an obvious place to start, but gambling and Off-Track-Betting, car mods, hotdog stands, girlfriends, airport gates and tickets, export crane for new cars, clothes stores, tattoos, burglary, gang wars,... sorry, the list could go one forever I suppose.

Oh yeah, since your basketballs are back, go play some basketball, set a high score. I totally forgot there was a basketball challenge until just recently. I'm not very good at it. Sorry, I suppose I should be happy it's working properly, but I keep hoping for something else to explain your glitch.

And thanks again for uploading your save.

Hot Rod
  • Hot Rod

    Player Hater

  • Members
  • Joined: 04 May 2006

#18

Posted 07 December 2007 - 11:14 PM

OrionSR if you have some time perhaps you could look into a save since I am experiencing the same problem on two of my saves. I've uploaded the one where the glitch is most noticeable ( http://gtasnp.com/download/6224 ). I don't know exactly what caused it but it definitely got worse with time.

On my second affected save I noticed a car driving in reverse and then turning while I was on the City Slicking mission from Back to School. After that I drove around for 20 minutes and it didn't happen again. So I completed the NRG mission by the docs and some 5 minutes later I spotted a car turning on the spot.
Since at this point the glitch is so rare I can't be sure it didn't appear before the Back to School mission.

If you'd like I could upload the second save as well since it has the glitch in its early phase.

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#19

Posted 08 December 2007 - 12:17 AM

QUOTE (Hot Rod @ Dec 7 2007, 16:14)
OrionSR if you have some time perhaps you could look into a save since I am experiencing the same problem on two of my saves. I've uploaded the one where the glitch is most noticeable ( http://gtasnp.com/download/6224 ). I don't know exactly what caused it but it definitely got worse with time.

On my second affected save I noticed a car driving in reverse and then turning while I was on the City Slicking mission from Back to School. After that I drove around for 20 minutes and it didn't happen again. So I completed the NRG mission by the docs and some 5 minutes later I spotted a car turning on the spot.
Since at this point the glitch is so rare I can't be sure it didn't appear before the Back to School mission.

If you'd like I could upload the second save as well since it has the glitch in its early phase.

Yeah, you've got the same glitch. The train path seems to cause particular confusion for the glitchy cars, which is why I like the spot where the train bridge crosses the freeway in north LV for checking the glitch. You don't seem to have it quite as bad as Rasdock, but it's definitely there.

And you've got close to 600 days of play time (I need a more accurate measure) so, unfortunately, your save seems to confirm the hypothesis that playing too long causes the glitch. Please upload the other save, it should be useful for narrowing down the time limit for when we should start looking for the glitch.

Thank you for contributing your observation that the glitch appears to get worse over time. I keep hoping for a 2nd trigger but I'm starting to doubt I'll find one. I began a test using a trainer to advance the time quickly, and noticed the cars were beginning to get a bit jittery so I was starting to suspect this might be the case.

I'm not sure if I can convince my friend to make another manual repair. What I'm hoping for is to gather a few examples and work on a generic fix tool that can reset the timer to a low value and allow game play to continue normally, but this will take a while to develop. I hope you don't might waiting until then.

But I suppose if lots of people were having this problem and contributed examples to work on, the priority of a fix might get bumped up a little.

pdescobar
  • pdescobar

    Conformist Scum Panda

  • Members
  • Joined: 19 Jul 2005

#20

Posted 08 December 2007 - 12:46 AM

Ahhh. so this is the traffic glitch topic.

QUOTE (OrionSR @ Dec 7 2007, 19:17)
And you've got close to 600 days of play time (I need a more accurate measure) so, unfortunately, your save seems to confirm the hypothesis that playing too long causes the glitch. Please upload the other save, it should be useful for narrowing down the time limit for when we should start looking for the glitch.

Thank you for contributing your observation that the glitch appears to get worse over time. I keep hoping for a 2nd trigger but I'm starting to doubt I'll find one. I began a test using a trainer to advance the time quickly, and noticed the cars were beginning to get a bit jittery so I was starting to suspect this might be the case.

The Time Played stat on the Misc section is what I've been using as it's a direct representation of the global timer. Hot Rod's save has a time played of 167:03 and Rasdock's was something like 156:29. It will be interesting to see the time on this other save.

QUOTE (continued...)
I'm not sure if I can convince my friend to make another manual repair. What I'm hoping for is to gather a few examples and work on a generic fix tool that can reset the timer to a low value and allow game play to continue normally, but this will take a while to develop. I hope you don't might waiting until then.

But I suppose if lots of people were having this problem and contributed examples to work on, the priority of a fix might get bumped up a little.

It wasn't exactly a manual repair the last time. wink.gif The only manual editing I did on Rasdock's was the blip; screwing with the timers had to be done via a program because there are too many and it was too easy to mess up manually. Anyhow, here's Hot Rod's file with the same fix applied. As with Rasdock, your time played has been rolled back to 16 minutes and other internal timers were adjusted accordingly. Also as with Rasdock, I did very little testing -- mainly just checking if the traffic looked better and parked cars still worked -- so please give it a thorough playing and post back with anything strange or not working.
http://gtasnp.com/6227

Hot Rod
  • Hot Rod

    Player Hater

  • Members
  • Joined: 04 May 2006

#21

Posted 08 December 2007 - 12:53 AM

Here it is: http://gtasnp.com/6225

Saved right after I finished Back to School and noticed the glitch for the first time. Since I'm at the fourth Woozie mission I can't say that I've really played a lot. It would be worrying if this glitch is indeed time related and would start so soon.

Another thing I should mention is that on the first save I noticed the cars turning around quite a while back and that was the only (and not so often) manifestation of the glitch. So I continued playing and wasn't very bothered by it. Then I took a few months off from playing. After I started again that's when the glitch really aggravated and started fusing cars and such.

So for that save the glitch manifested itself modestly for a long time and then quickly got worse.

Could the game version have an impact on this? I reinstalled the game (switching from version 1.1 to 1.0) at around the same time the glitch got worse though I can't remember which was first.

Anyway thank you for you effort and I hope you can find out more.

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#22

Posted 08 December 2007 - 01:06 AM

Interesting observations Hot Rod. It's difficult to know which clues will provide a breakthrough.

However, car appearing backwards and making a j-turn in traffic is fairly normal, specially if CJ suddenly changes directions. What makes this glitch distinctive is cars will spawn in forward, then disappear and reappear, sometimes they spawn in backward, and sometimes they jump a short distance.

Jittery traffic however seems to be an early symptom. The cars don't travel along the road in a smooth manner and appear to be constantly tapping the throttle. When I see the jittery cars I head to my glitch spot on the Julius Thruway to see if the cars will display more severe symptoms. However, I'm not sure if it fair to use jittery traffic as a an early warning sign just yet.

And sorry PD. I thought I sent you a link to this topic along with the save.

pdescobar
  • pdescobar

    Conformist Scum Panda

  • Members
  • Joined: 19 Jul 2005

#23

Posted 08 December 2007 - 01:38 AM

QUOTE (Hot Rod @ Dec 7 2007, 19:53)
Here it is: http://gtasnp.com/6225 

Saved right after I finished Back to School and noticed the glitch for the first time. Since I'm at the fourth Woozie mission I can't say that I've really played a lot. It would be worrying if this glitch is indeed time related and would start so soon.

The Back to School save only has 18 hours of play time, so I really hope the glitch isn't appearing this early. It looked ok to me on a quick test but Orion has a better eye for this than I do.

QUOTE (continued...)
Could the game version have an impact on this? I reinstalled the game (switching from version 1.1 to 1.0) at around the same time the glitch got worse though I can't remember which was first.

Game version shouldn't matter much as I think Rasdock was using version 2.

-----------------

QUOTE (OrionSR @ Dec 7 2007, 20:06)
And sorry PD. I thought I sent you a link to this topic along with the save.

You very well might have; sometimes stuff slips by me. wink.gif

Hot Rod
  • Hot Rod

    Player Hater

  • Members
  • Joined: 04 May 2006

#24

Posted 08 December 2007 - 01:59 AM

QUOTE (OrionSR @ Dec 8 2007, 01:06)
However, car appearing backwards and making a j-turn in traffic is fairly normal, specially if CJ suddenly changes directions. What makes this glitch distinctive is cars will spawn in forward, then disappear and reappear, sometimes they spawn in backward, and sometimes they jump a short distance.


So if I'm only getting the cars spawning backwards then turning 180 without any jumping/teleporting/merging then that's not (part of) the glitch?
Because as I've said that's all I experienced for a long time up until recently when the other symptoms occurred on the first save and that is what's happening remotely on the second.

Rasdock
  • Rasdock

    Player Hater

  • Members
  • Joined: 01 May 2007

#25

Posted 08 December 2007 - 02:09 AM

I didn't know who to thank before, Mr. Escobar, so thanks for the fix. I had fun getting a second game up to 100%, but I think I'll always want to keep my original game around because that's the one I worked on for so long. I'm glad I can do that minus the traffic glitch as well as the stray marker glitch, which I never expected to be rid of. So, thanks again!

QUOTE
So if I'm only getting the cars spawning backwards then turning 180 without any jumping/teleporting/merging then that's not (part of) the glitch?  Because as I've said that's all I experienced for a long time up until recently when the other symptoms occurred on the first save and that is what's happening remotely on the second.


I think you'll probably develop those problems over time. Mine started out with just the backwards/180 cars and got worse.

Hot Rod
  • Hot Rod

    Player Hater

  • Members
  • Joined: 04 May 2006

#26

Posted 08 December 2007 - 02:48 AM

QUOTE (Rasdock @ Dec 8 2007, 02:09)
I think you'll probably develop those problems over time. Mine started out with just the backwards/180 cars and got worse.

Yes, that's what I thought as well so that's why I was puzzled when Oracle said it was normal for cars to do the 180/J turns.

Regarding time as the only factor contributing to the glitch - it might be true as I had 100% completion long before experiencing the severe issues from the first save. But since I was still (re)doing some missions and other stuff that was left to do I can't say they did or didn't have an effect.

Ring_of_Fire
  • Ring_of_Fire

    Glitching is fun!

  • Members
  • Joined: 20 Mar 2007

#27

Posted 08 December 2007 - 02:53 AM Edited by Ring_of_Fire, 08 December 2007 - 03:13 AM.

Does Patch v1.01 fix this glitch or make it worse? Does v2.0 have it as well, but in an even worser form? Does modding up the game cause the AI to behave weirdly?

If not, then it's just San Andreas buggy way of randomly spawning vehicles and people out of nowhere. It happened in Vice City as well.

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#28

Posted 08 December 2007 - 04:01 AM Edited by OrionSR, 10 December 2007 - 03:11 AM.

QUOTE (Hot Rod @ Dec 7 2007, 18:59)
QUOTE (OrionSR @ Dec 8 2007, 01:06)
However, car appearing backwards and making a j-turn in traffic is fairly normal, specially if CJ suddenly changes directions. What makes this glitch distinctive is cars will spawn in forward, then disappear and reappear, sometimes they spawn in backward, and sometimes they jump a short distance.


So if I'm only getting the cars spawning backwards then turning 180 without any jumping/teleporting/merging then that's not (part of) the glitch?
Because as I've said that's all I experienced for a long time up until recently when the other symptoms occurred on the first save and that is what's happening remotely on the second.

It's difficult to say that it is not part of the glitch. I'm really not at all sure what is going on, but I'm not having too much difficulty finding glitched saves now that I know what to look for. I just received a save with over 200 hours of play time, and it's suffering the glitch pretty badly.

But for the sake of clarification: No, cars sometimes spawn backwards and then try to turn around in traffic. I do not consider this part of the glitch unless they do the jumping/teleportation thing. Perhaps this is something that gets worse with time. Spawning in forwards and then flipping around backwards is "proof" of the glitch, merging is a dead give-away, and jittery traffic may be an early warning sign.

And I think it might be related, but I'm not sure: cars can be seen flying and rotating in the tunnel under the SF golf. I've seen a similar glitch in Liberty City, but I've never noticed it in San Andreas before.

Rasdock has a native v2 save, so yes, v2 can get the glitch as well as v1. And with that in mind: I doubt very much that the v1.01 patch is any different.

OrionSR
  • OrionSR

    Chain Game Development Team

  • Feroci Racing
  • Joined: 23 May 2007
  • None
  • Helpfulness Award [GTA & Modding]

#29

Posted 17 December 2007 - 08:33 PM

Update on Global Timer Refresh Fix

The pickup pool timers were not well defined, so they were not adjusted with the initial patch. It is likely that stray pickups such as a recently used jetpack, gang war health or armor, or cash and weapons from gangs, cops, or peds, might be found lying around waiting to unspawn at some future date. These should probably be collected to free up some room in the pickup pool. Also, pickups that had been recently collected (not sure on the specific requirements) may be invisible and may be waiting to spawn for a very long time.

Also, there has been a report that the normal pickups are respawning in about half the expected time.

Hot Rod
  • Hot Rod

    Player Hater

  • Members
  • Joined: 04 May 2006

#30

Posted 18 December 2007 - 07:48 PM

Well I can confirm that some items that were lying around (a cop pistol and cane) got saved with the game but picking them up cleared the problem. Not picking them up would have caused them to be continuously saved (lying around), right?
I don't know about the rest as I haven't been playing a lot with the fixed save but I'll check into it and see if perhaps I spot some other "things".





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users