Quantcast

Jump to content

» «
Photo

Game crash on Load/New game

10 replies to this topic
ramonthief
  • ramonthief

    Player Hater

  • Members
  • Joined: 04 Jun 2006

#1

Posted 27 September 2007 - 03:17 PM

For some reason, my San Andreas game started to crash whenever I started or loaded a new game, it crashes when it has finished loading the game, so it doesn't crash WHILE its loading. The error tells me that there is something wrong with my vorbis.dll(Ogg vorbis?) or at least, it's causing the crash.

I'm almost sure it has something to do with my sound, since whenever I try to enter the audio options menu, it crashes, while entering the controls/video settings works just fine. I have absolutely no idea what to do, I tried downloading some Ogg vorbis codecs, which I have never done before, reinstalling DirectX, installing both newer and older drivers for my soundcard + graphics card. But none seems to work.

So to summer up:
* Game crashes when it has FINISHED loading a savegame/new game.
* Game crashes when I try to enter the Audio options

What I have done so far:
* Reinstalling DirectX
* Trying newer and older drivers for my soundcard
* Trying newer and older drivers for my graphics card
* Tried downloading Ogg vorbis codecs.

Operating System: Windows Vista, the error also occured in Windows XP SP2, so that can't be the problem.
Video/Graphics card: XFX nVidia 7950GT(512MB)
Processor: AMD X2 3800+(tried to run singlecore and dualcore)
RAM: 3GB

gtamodder
  • gtamodder

  • Members
  • Joined: 12 Sep 2007

#2

Posted 27 September 2007 - 03:20 PM

Please read the pinned posting requirements.

Try this.

1. Reinstall the game.
2. Try putting gta-sa.exe into windows 98 compbabilty mode.
3. Delete gta.set file from my documents/GTA San Andreas user files.

ramonthief
  • ramonthief

    Player Hater

  • Members
  • Joined: 04 Jun 2006

#3

Posted 27 September 2007 - 03:25 PM

QUOTE (gtamodder @ Sep 27 2007, 15:20)
Please read the pinned posting requirements.

Try this.

1. Reinstall the game.
2. Try putting gta-sa.exe into windows 98 compbabilty mode.
3. Delete gta.set file from my documents/GTA San Andreas user files.

1. Reinstall the game. Already tried that, forgot to mention
2. Try putting gta-sa.exe into windows 98 compbabilty mode. No sucess
3. Delete gta.set file from my documents/GTA San Andreas user files. There isn't even a gta.set because I can't create a new savegame

Ring_of_Fire
  • Ring_of_Fire

    Glitching is fun!

  • Members
  • Joined: 20 Mar 2007

#4

Posted 27 September 2007 - 06:07 PM Edited by Ring_of_Fire, 27 September 2007 - 06:12 PM.

Insert the GTA San Andreas DVD disc and tell me if it says 3.94GB in "My Computer" for your DVD-ROM (D: E:) drive.

If it does, then try to reinstall by selecting "Complete" along with the optional radio stations instead of "Custom". Windows Vista's "Programs and Features" located in the Control Panel should now show that San Andreas is at least 4.68GB in size.

http://www.gtaforums...dpost&p=4537502
Try to disable UAC first things first, and if it crashes again, go into Task Manager and you will see that it still lists "gta_sa.exe". Close it down and relaunch San Andreas.

QUOTE
There isn't even a gta.set because I can't create a new savegame

So you mean you didn't care to change your graphics settings? Go to "C:\Users\Public\Public Documents\GTA San Andreas User Files" to see if the [.set] file is there. If not, then it should be in "C:\Users\ramonthief\Documents\GTA San Andreas User Files". Make sure the game is in Windows 98/Me compatibility mode.

VCHolmes
  • VCHolmes

    Foot Soldier

  • Members
  • Joined: 02 Aug 2007

#5

Posted 28 September 2007 - 11:26 AM

QUOTE
For some reason, my San Andreas game started to crash whenever I started or loaded a new game

Have any mods installed?

QUOTE (ramonthief)
There isn't even a gta.set

Search your Computer for 'gta_sa.set'.

QUOTE (ramonthief)
The error tells me that there is something wrong with my vorbis.dll

As suggested by gtamodder, reinstall.

Follow this procedure to do a clean install:
  1. Uninstall GTA San Andreas
  2. Delete the 'gta_sa.set'
  3. Delete the program installation folder to ensure that there are no leftover files.
  4. Install the game from the DVD. Do a Complete Install (with the Radio Stations) as RoF suggested.

ramonthief
  • ramonthief

    Player Hater

  • Members
  • Joined: 04 Jun 2006

#6

Posted 28 September 2007 - 04:02 PM

I've done the reinstall and deleted everything that was left, even went through the computer registry to double check it, but the error still occurs, even after the reinstall.

THERECANONLYBEONE
  • THERECANONLYBEONE

    the tranquilizer

  • Members
  • Joined: 07 Aug 2007

#7

Posted 28 September 2007 - 09:07 PM

i also got this problem but i dont crash when i start i new game i olny crash whenever i load a game after the load screen it crashes sad.gif

THERECANONLYBEONE
  • THERECANONLYBEONE

    the tranquilizer

  • Members
  • Joined: 07 Aug 2007

#8

Posted 28 September 2007 - 09:09 PM

btw i even reformat my comp and installed all the latest graphic cards and sound cars but still noluck

CCPD
  • CCPD

    Boss

  • Members
  • Joined: 01 May 2006
  • None

#9

Posted 28 September 2007 - 09:16 PM

@ ramonthief - Did you purchase the game in the shop or downloaded it from the Internet?

@ THERECANONLYBEONE - Use an user posted image button.

akohli
  • akohli

    Player Hater

  • Members
  • Joined: 02 May 2013

#10

Posted 02 August 2013 - 09:52 AM

Same prob. is wid me... When i start the game it starts normally but when i click on new game or load game it crashes..... wht should i do??? sad.gif

0909090
  • 0909090

  • Members
  • Joined: 14 Mar 2012
  • Slovakia

#11

Posted 02 August 2013 - 10:12 AM

Where did you get your game from?




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users