Quantcast

Jump to content

» «
Photo

Taxi Glitch PC-DVD

  • This topic is locked This topic is locked
7 replies to this topic
AnarC21
  • AnarC21

    Player Hater

  • Members
  • Joined: 29 Sep 2006

#1

Posted 29 September 2006 - 01:27 AM Edited by AnarC21, 01 October 2006 - 06:33 PM.

Hello, I'm here with a somewhat known and unknown problem, with no apparent solution or explenation.

I'm running San Andreas on a SP2 xp Pro edition, AND a Home Edition SP2 PC(s).
One is a dual core with SLI dual 7600gt(corsair 400), one is an Athlon XP 2800+ with a new x800rx ati radeon card(corsair 333).

I have seen many posts and topics on the net that hint at the TAXI glitch. I even heard it had to with when you leave san andreas by plane and leave the borders of the map, somehow the TAXI glitch manifests itself. The mission where you have to go to snowy liberty city comes to logic there.

The people who recognise this problem I assume searched for it themselves.

And may have struck luck with some programmer somewhere who knows how to fix this sh*tty and most frustrating BUG. May I also mension that I have completed the game at 87.something % percent with no cheating what so ever.

Since this glitch has come up I am not motivated anymore to do anything to get the 100% with this game, as many OTHERS may experience also.

So my ultimate question is: (you may have guessed allready)
Do we have a solution for this tremendous bug/glitch? Does anyone out there have it?

pdescobar
  • pdescobar

    Conformist Scum Panda

  • Members
  • Joined: 19 Jul 2005

#2

Posted 29 September 2006 - 09:27 AM

The root cause (in terms of gameplay) of the taxi glitch is unknown, although it is a carryover glitch which will affect a new game if that game is started while a glitched game is in memory. Lots of people like to speculate that an early pilot's license causes it, but I don't believe it's nearly that simple. Leaving the borders of the map is a more plausible cause, but it's not an easy thing to pin down.

No matter what the gameplay cause is, after doing some experimenting just recently on a save from the user robots, I think I have come up with a way to fix it. It appears that the glitch is the result of the map zone information within the save becoming corrupted; it is fixable on the PC version but requires you to hex edit the save file. I whipped up a quick program to do it, but testing was very minimal. Please give it a try and let me know how it works for you. Simply extract the exe using WinRAR or similar and then drag your savefile onto the exe icon. http://pdescobar.hom...ta/taxi_fix.rar

AnarC21
  • AnarC21

    Player Hater

  • Members
  • Joined: 29 Sep 2006

#3

Posted 01 October 2006 - 05:45 PM Edited by AnarC21, 06 October 2006 - 04:09 AM.

He thanks for the quick reply.

The .exe I unzipped. If a person would open the .RAR it will not work. So I just extracted it. I dragged the savegame over extracted .exe. The commandline came up and said it fixed the file. After that I went in the user folder, and checked that out. Two files: the original with an extended name of .bak, and the "fixed" savegame.

The first time I started the game up with it, GTA-SA crashed>>>>>>>>>>>>>>>>>>>
EDIT : No crashes with San Andreas since I finished the taxi missions. Everything is E.O.K from here on out biggrin.gif

The second time the game works: Taxi Glitch fixed! Passengers show up, you can pick them up, drop them of, and money can be made.

I screamed for a short second as in yeah it is actually possible now to get a 100%. So thanks for that pdescobar cool.gif Many thanks.

ceco
  • ceco

    Player Hater

  • Members
  • Joined: 31 Jul 2010

#4

Posted 31 July 2010 - 12:11 AM

I've had the same problem. Thanks for posting the link.
I got one more question. If I delete "GTASAsf1.b.bak" file, will I still have problems with glitch or no?
Thanks.

Anurag_Anmol
  • Anurag_Anmol

    Delete... me....

  • Members
  • Joined: 14 Jun 2010

#5

Posted 01 August 2010 - 09:18 AM

OMG 4 year bump xd

lil weasel
  • lil weasel

    Shoot Looters, Hang Pirates!

  • Members
  • Joined: 25 Dec 2006
  • None
  • Contribution Award [San Andreas]

#6

Posted 01 August 2010 - 11:59 AM

QUOTE (ceco @ Jul 31 2010, 00:11)
I've had the same problem. Thanks for posting the link.
I got one more question. If I delete "GTASAsf1.b.bak" file, will I still have problems with glitch or no?
Thanks.

Make a back-up of the file before you delete it. then if you have a problem you can put it back. This would apply to any file you want to try deleting. Or just move it to a different file for that matter.

Ignore Anurag_Anmol comment. It is acceptable to make a substantial reply or question to any old topic.

josepha916
  • josepha916

    Crackhead

  • Members
  • Joined: 21 Jun 2013

#7

Posted 07 September 2013 - 03:28 PM

I tried that before (fixing the save). It doesn't work for me, though. The only reliable method I know to fix this is to delete the User Files folder.

Girish
  • Girish

  • Moderator
  • Joined: 20 Apr 2006
  • India
  • Best Moderator 2011

#8

Posted 07 September 2013 - 03:44 PM

Please check the date of the last post before replying to topics.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users