Quantcast

Jump to content

» «
Photo

[WIP] San Andreas Audio Toolkit (SAAT)

384 replies to this topic
Dillyracer
  • Dillyracer

    citizen of lost heaven

  • Members
  • Joined: 30 Jul 2005

#91

Posted 17 January 2006 - 08:00 PM

MPEG LAYER -3 16kbit/s, 16,000 Hz, Mono
I used these settings, tried the method in the manual and the method of BMWpower. both crashes ingame, why ?

pdescobar
  • pdescobar

    Conformist Scum Panda

  • Members
  • Joined: 19 Jul 2005

#92

Posted 17 January 2006 - 08:42 PM

QUOTE (Dillyracer @ Jan 17 2006, 13:23)
I got it running, but i insert just the same as in the readme to extract GENRL, but it always give an error

nvm, i solved it, now lets get that skyline running tounge.gif

Your initial problem (the one in this image) was simply the INI referencing a file in the wrong spot or with the wrong name. Easily fixed and it looks like you did fix it.

QUOTE
i did everything in the manual to export it but now i am having a new problem :
There isn't any sound in the main menu and when loading it crashes

I saved the 2 sounds for the elegy, Accel and Down, the sound002 i didn't record yet, and i saved them as a wav
with gold wave
MPEG LAYER -3 16kbit/s, 16,000 Hz, Mono

i tought this one is right ?

Err, that may not be a useable format. I've never tested importing an MPEG Layer 3 (.mp3) file and so I don't know if my import routines will properly convert it. See if there's an option for 16-bit "PCM WAV" or "Uncompressed WAV" that saves with a .wav extension.

However, if all you have changed is a car engine sound, then the game should not be crashing on launch since that sound isn't being accessed yet. Did the BankLkup.dat file update properly when you imported?

===============

@Craig: It's on the drawing board. See my post of Jan 16 2006, 13:49 EST (US) which is the most recent mention of interface plans.

BMWPower
  • BMWPower

    SiX-In-Line Rulz!

  • Members
  • Joined: 06 Nov 2004

#93

Posted 17 January 2006 - 08:43 PM

QUOTE (Dillyracer @ Jan 17 2006, 20:00)
MPEG LAYER -3 16kbit/s, 16,000 Hz, Mono
I used these settings, tried the method in the manual and the method of BMWpower. both crashes ingame, why ?

_001.wav - Acceleration
_002.wav - Shifting
_003.wav - Deacceleration

So i named my wav's just like the original ones. If you didn't named your wavs like the original ones, you have to open 'saat_import.ini' file and change the name of the wav's. But i renamed my wavs to sound_00* (like the original wav's, because i'm lazy tounge.gif ) Rename your wavs like the original and you won't have any problems. Why you have to edit the *.ini file when you can just name your files like the original ones? sigh.gif

And today i tried to import an 16-bit 32,000 Hz Mono wav, and the game didn't crash.
But first try with 16,000 only to understand the importing, then try to import higher wav's.

I have changed the car sounds of all the cars in the game and now it's very cool! xmas.gif

pdescobar
  • pdescobar

    Conformist Scum Panda

  • Members
  • Joined: 19 Jul 2005

#94

Posted 17 January 2006 - 08:47 PM

QUOTE (BMWPower @ Jan 17 2006, 15:43)
I have changed the car sounds of all the cars in the game and now it's very cool! xmas.gif

I'm glad you're getting good results. biggrin.gif Did you happen to write down which sound banks contained the sounds for which vehicles? That could be handy to know for others who want to change specific sounds.

BMWPower
  • BMWPower

    SiX-In-Line Rulz!

  • Members
  • Joined: 06 Nov 2004

#95

Posted 17 January 2006 - 08:53 PM

@ pdescobar

I have one more question about the sound of the car engines.
I changed the sound of my elegy. OK. But when i'm not driving. I'm in the car, but i don't drive. The car is on N gear. The sound of the car is the original. When i'm driving with 7-8 km/h the engine sound is still the original. And after that the game is starting to run my wav file. How can i change this? I want to disable all original engine sounds. And i want when i'm not driving the car more than 7-8 km/h, and when the car is on N gear to hear my wav.

I hope you'll understand me, sorry, i know that my english is too bad... blush.gif

pdescobar
  • pdescobar

    Conformist Scum Panda

  • Members
  • Joined: 19 Jul 2005

#96

Posted 17 January 2006 - 09:04 PM

QUOTE (BMWPower @ Jan 17 2006, 15:53)
@ pdescobar

I have one more question about the sound of the car engines.
I changed the sound of my elegy. OK. But when i'm not driving. I'm in the car, but i don't drive. The car is on N gear. The sound of the car is the original. When i'm driving with 7-8 km/h the engine sound is still the original. And after that the game is starting to run my wav file. How can i change this? I want to disable all original engine sounds. And i want when i'm not driving the car more than 7-8 km/h, and when the car is on N gear to hear my wav.

I hope you'll understand me, sorry, i know that my english is too bad... blush.gif

My guess is that the "engine idle" sounds are different sounds stored elsewhere than the accel/shift/decel sounds. Possibly because there is fewer variety. The first places to check are Bank 001 and Bank 126 because some of those specifically sounded like idle sounds to me. But, they could be elsewhere in GENRL as well. I couldn't much tell the difference between one engine sound and another when I listened to them all to create the directory, which is why any specifics on what cars use sounds from what banks would be helpful.

BMWPower
  • BMWPower

    SiX-In-Line Rulz!

  • Members
  • Joined: 06 Nov 2004

#97

Posted 17 January 2006 - 09:11 PM

QUOTE (pdescobar @ Jan 17 2006, 20:47)
QUOTE (BMWPower @ Jan 17 2006, 15:43)
I have changed the car sounds of all the cars in the game and now it's very cool! xmas.gif

I'm glad you're getting good results. biggrin.gif Did you happen to write down which sound banks contained the sounds for which vehicles? That could be handy to know for others who want to change specific sounds.

colgate.gif
Yeah i'm thinking of this, i have the numbers of the banks, but i don't know the name of the cars that are using this wavs. I'll write what i know... smile.gif


GENRL
Bank_002 - Elegy, Primo..............
Bank_011 - ........
Bank_020 - i think that this is hermes, oceanic, but i'm not sure.
Bank_029 - Broadway....
Bank_032 - Maybe Hotring....?
Bank_035 - ........
Bank_037 - ........
Bank_040 - The bad V8 devil.gif > Sabre, Blade, Clover, Picador, Buccanee....
Bank_081 - ........
Bank_087 - ........
Bnak_089 - ........
Bnak_093 - ........
Bnak_095 - Idon't know names, but it's a big engine. Maybe SIX-In-Line devil.gif
Bank_097 - Small engine...
Bank_109 - Bandito
Bank_111 - .......
Bank_117 - .......
Bank_124 - some bus i think....
Bank_131 - some bus i think....
Bank_134 - .......

****
Motorcycles

Bank_105
Bank_113
Bank_119

blush.gif

BMWPower
  • BMWPower

    SiX-In-Line Rulz!

  • Members
  • Joined: 06 Nov 2004

#98

Posted 17 January 2006 - 09:15 PM

QUOTE (pdescobar @ Jan 17 2006, 21:04)
QUOTE (BMWPower @ Jan 17 2006, 15:53)
@ pdescobar

I have one more question about the sound of the car engines.
I changed the sound of my elegy. OK. But when i'm not driving. I'm in the car, but i don't drive. The car is on N gear. The sound of the car is the original. When i'm driving with 7-8 km/h the engine sound is still the original. And after that the game is starting to run my wav file. How can i change this? I want to disable all original engine sounds. And i want when i'm not driving the car more than 7-8 km/h, and when the car is on N gear to hear my wav.

I hope you'll understand me, sorry, i know that my english is too bad... blush.gif

My guess is that the "engine idle" sounds are different sounds stored elsewhere than the accel/shift/decel sounds. Possibly because there is fewer variety. The first places to check are Bank 001 and Bank 126 because some of those specifically sounded like idle sounds to me. But, they could be elsewhere in GENRL as well. I couldn't much tell the difference between one engine sound and another when I listened to them all to create the directory, which is why any specifics on what cars use sounds from what banks would be helpful.

I think i found it. Bank_001.
10x again!

thinktank23
  • thinktank23

    Player Hater

  • Members
  • Joined: 17 Jan 2006

#99

Posted 17 January 2006 - 09:45 PM

QUOTE (tzesun @ Jan 8 2006, 03:18)
About the gunshot sounds - I found out to avoid the gunshot sound changing pitch way too much in game whilst firing (very noticable with full auto, especially the assault rifles) both sound files (each gunshot sound effect uses 2 wav files) need to be a different pitch (when tested with the default ones, swapping the sound round made no difference, though using the same unedited sound for both shots caused the changing pitch effect in game). So make sure that both the sounds are different pitches.

how much lower should the pitch be? I recorded several test WAVs ("test one", "test two", etc) to write down which sound file played when firing different weapons. What a MESS that turned out to be!!!! Several of the wavs play at the same time, and thier pitch was off, all like you said. I was planning on importing some weapon sounds from Counter-Strike, but i gave up after this. I was wondering, what if you change the sample rates of the wavs you are replacing in the ini to the sample rate of your custom weapon wavs, would this work in eliminating pitch problems?

Dammit, rockstar, why did you give us such crap gun sounds?

Dillyracer
  • Dillyracer

    citizen of lost heaven

  • Members
  • Joined: 30 Jul 2005

#100

Posted 18 January 2006 - 01:53 PM

got everything in but when i get in the elegy the game crashes.
I saved the 2 sounds like this PCM signed 16 bit MONO.
This is normally the right save ?

BMWPower
  • BMWPower

    SiX-In-Line Rulz!

  • Members
  • Joined: 06 Nov 2004

#101

Posted 18 January 2006 - 03:24 PM

QUOTE (Dillyracer @ Jan 18 2006, 13:53)
got everything in but when i get in the elegy the game crashes.
I saved the 2 sounds like this PCM signed 16 bit MONO.
This is normally the right save ?

My game crashed too, but this was from the Hz of the wav.
I don't have any problems when i converted and save my ripped sounds as:

*.Wav (standart)
16-bit Mono
16,000 / 32,000 Hz

... with Easy CD-DA Extractor 6 or 9 version. Try this perfect program. It's very good not only with converting. It can Burn Audio CD's and it has CD Ripper. colgate.gif

BMWPower
  • BMWPower

    SiX-In-Line Rulz!

  • Members
  • Joined: 06 Nov 2004

#102

Posted 20 January 2006 - 09:24 PM

What I have to edit in stream_import.ini file, when i want to delete an ogg?

pdescobar
  • pdescobar

    Conformist Scum Panda

  • Members
  • Joined: 19 Jul 2005

#103

Posted 20 January 2006 - 09:35 PM

QUOTE (BMWPower @ Jan 20 2006, 16:24)
What I have to edit in stream_import.ini file, when i want to delete an ogg?

Well, you really shouldn't be actually deleting any tracks because you get unpredictable game behavior. It's not easy to remove any except the last track by editing the INI and that's a good thing. wink.gif What you can do is use a small placeholder sound that's simply a little bit of silence (cut out a piece of one of the "silence" tracks from the police radio stream if you can't manufacture silence.) However, depending on where that sound is used, very small replacements can lead to the "dead air" bug where the radio stops playing until you switch to another station and back. Exactly what are you wishing to remove?

Dillyracer
  • Dillyracer

    citizen of lost heaven

  • Members
  • Joined: 30 Jul 2005

#104

Posted 21 January 2006 - 08:57 AM

with the GENRL sounds it looks a bit like this with vehicles i think.
Most of the files are ranged in order like this

1. Idle sounds of elegy (starting, motor running in N)
2 The sounds of the vehicle itself.

There are also some special effects in there

BMWPower
  • BMWPower

    SiX-In-Line Rulz!

  • Members
  • Joined: 06 Nov 2004

#105

Posted 21 January 2006 - 11:05 AM

QUOTE (pdescobar @ Jan 20 2006, 21:35)
QUOTE (BMWPower @ Jan 20 2006, 16:24)
What I have to edit in stream_import.ini file, when i want to delete an ogg?

Well, you really shouldn't be actually deleting any tracks because you get unpredictable game behavior. It's not easy to remove any except the last track by editing the INI and that's a good thing. wink.gif What you can do is use a small placeholder sound that's simply a little bit of silence (cut out a piece of one of the "silence" tracks from the police radio stream if you can't manufacture silence.) However, depending on where that sound is used, very small replacements can lead to the "dead air" bug where the radio stops playing until you switch to another station and back. Exactly what are you wishing to remove?

I want to delete the small ogg's, not the songs, only the voices of the people in air.
Because i ripped my own ogg's from the radio, and the i don't want the original ogg's.

And i want to ask you.
I want when i'm driving the Sultan the game to load the wav's of the Phoenix. I don't want to replace anything. I just want when i'm driving the Sultan the game to running the Phoenix wav's. Is it possible? dozingoff.gif

10x

Handsome Rob
  • Handsome Rob

    Player Hater

  • Members
  • Joined: 21 Jan 2006

#106

Posted 21 January 2006 - 11:18 AM Edited by Handsome Rob, 21 January 2006 - 02:06 PM.

I've been trying to extract some sound effects with SAAT, but every time I try I get the same error message saying

"Error in lookup file metadata-full.ini: No entries for index 6. The exporter needs to read sound lengths from the lookup file. Aborting."

Has anyone else come across this problem and know how to sort it out?
Thanks

EDIT: Actually I've worked it out now, the online manual file explained it http://pdescobar.hom...aat/MANUAL.html
thanks for a really useful program

pdescobar
  • pdescobar

    Conformist Scum Panda

  • Members
  • Joined: 19 Jul 2005

#107

Posted 21 January 2006 - 05:42 PM

QUOTE (BMWPower @ Jan 21 2006, 06:05)
QUOTE (pdescobar @ Jan 20 2006, 21:35)
QUOTE (BMWPower @ Jan 20 2006, 16:24)
What I have to edit in stream_import.ini file, when i want to delete an ogg?

Well, you really shouldn't be actually deleting any tracks because you get unpredictable game behavior. It's not easy to remove any except the last track by editing the INI and that's a good thing. wink.gif What you can do is use a small placeholder sound that's simply a little bit of silence (cut out a piece of one of the "silence" tracks from the police radio stream if you can't manufacture silence.) However, depending on where that sound is used, very small replacements can lead to the "dead air" bug where the radio stops playing until you switch to another station and back. Exactly what are you wishing to remove?

I want to delete the small ogg's, not the songs, only the voices of the people in air.
Because i ripped my own ogg's from the radio, and the i don't want the original ogg's.

If you mean the Station IDs and DJ chatter ("You're listening to Radio X, Blah blah blah") you may be able to use placeholders.

If you mean the intro/outro part of the song when the DJ talks over the music, you should keep the songs essentially the same by cutting up your replacement into 3 parts and mirroring the current format. I went into some more detail on that procedure in a previous post.

QUOTE
And i want to ask you.
I want when i'm driving the Sultan the game to load the wav's of the Phoenix. I don't want to replace anything. I just want when i'm driving the Sultan the game to running the Phoenix wav's. Is it possible? dozingoff.gif

I'm thinking which sound plays in which vehicle is probably hardcoded to the vehicle ID, but that's somewhat out of my area of experience. If it is editable, it'd be set in vehicles.ide or handling.cfg. Perhaps someone with more vehicle modding experience can weigh in on that.

SwedishMafia
  • SwedishMafia

    BF2 First sergeant TheLeadMaster

  • Members
  • Joined: 14 Nov 2005

#108

Posted 24 January 2006 - 10:32 AM

Pdescoabr, Your'e a king!! I'ce been waiting for this ever since I started modding. Rockstar really knew how to pick some of th worst sound fx possible.
The program is great and the command lines are easy to memorise. Great work, keep it up!

*OGM*_2pac
  • *OGM*_2pac

    Creator of GTA Lost Angelz

  • Members
  • Joined: 01 Aug 2005

#109

Posted 24 January 2006 - 03:05 PM

Only one thing to say .......Amazing!!!! suicidal.gif

Scrag
  • Scrag

    Crackhead

  • Members
  • Joined: 22 Aug 2005

#110

Posted 24 January 2006 - 07:37 PM

Everyone should post the new sound effects they have made.

BMWPower
  • BMWPower

    SiX-In-Line Rulz!

  • Members
  • Joined: 06 Nov 2004

#111

Posted 24 January 2006 - 09:24 PM

I can upload some engine sounds...???
Just tell me where to upload the sounds, because i'm from Bulgaria, and you don't see the Bulgarian free servers. rolleyes.gif

And i think i did the trick with the radiostations. I delete all songs, that i put my ogg's in the folder, i opened Stream_import.ini and i changed the number of files to 11, and the name of the ogg's. That i delete the a big part of the list with tracks in stream_import.ini and now there are only 11 tracks in the .ini file. I playedthe game, and everything is OK! colgate.gif

Dillyracer
  • Dillyracer

    citizen of lost heaven

  • Members
  • Joined: 30 Jul 2005

#112

Posted 25 January 2006 - 02:14 PM

upload it on gtagarage biggrin.gif

Dillyracer
  • Dillyracer

    citizen of lost heaven

  • Members
  • Joined: 30 Jul 2005

#113

Posted 25 January 2006 - 06:39 PM

I have a weird problem that popped up, when i slow down with a modified hotringracerA. it always gives the normal sound but there are some disturbances when slowing down, wtf is that ?

Wormzer
  • Wormzer

    Player Hater

  • Members
  • Joined: 27 Jan 2006

#114

Posted 27 January 2006 - 12:14 PM Edited by Wormzer, 27 January 2006 - 12:21 PM.

Great work pdescobar! I've thought many times about how cool it would be just to modify the tracks on any given station. And SAAT does that and then some. colgate.gif

I almost have a station playing just right, but I was wondering if anyone could please offer me some assistance?

I'm trying to change the majority of the tracks on a few stations. I started with K-Dust, and I've imported 14 tracks using the Intro/Mid/Outro "mirror" method and they seem to play fine in-game. Although, like a few others mentioned previously in this thread, the problem I'm having is that the station doesn't always continue playing after a track stops. The tracks always change if I switch stations or use a new vehicle, but otherwise I get dead air after a track ends on that station.

At first I just tried just altering the (ID) and (DJ) files to make it as simple as possible. This is where the problem first occured for me though, so I tried the more detailed "mirror" method of changing the original tracks thinking that would solve it. So I modeled my Intros, Mids, and Outros identically with the original tracks I replaced in the .ini as instructed, and every Intro and Outro I created was 15 seconds to help with stability. It seems I've been able to change 14 of the original songs on K-Dust without any stability issues, but I'm still having the same problem getting the next track to play as before.

I was thinking a possibility was that my Intros\Outros are a little too big. Or I've been thinking I converted to .ogg with Easy CD-DA using the wrong configuration. (I currently have them converted as Vorbis 1.1 with VBR Quality 4 (128kb). And when clipping with Audactity my Intros/Mids/Outros were all labeled Stereo, 44100hz, and at 16-Bit.)

Any help at all would be greatly appreciated! And my apologies for such a lengthy post gents.

pdescobar
  • pdescobar

    Conformist Scum Panda

  • Members
  • Joined: 19 Jul 2005

#115

Posted 27 January 2006 - 09:56 PM

Wormzer: have you noticed any consistency with regard to when the dead air starts? For example, does the entire 3-piece song play and then dead air shows? or is it after DJ/ID tracks, after commercials, always after a specific clip, etc? If all your clips are over 15 seconds, then the whole theory that short clip lengths cause the dead air bug might need to be tossed out and the true cause might be something else. Also, have you heard all of your replacements play in-game?

Wormzer
  • Wormzer

    Player Hater

  • Members
  • Joined: 27 Jan 2006

#116

Posted 28 January 2006 - 04:30 AM

Thanks for the reply pdescobar, I apprectiate it! smile.gif

I just finished listening to the station cycle through all the tracks twice. Once in the audio section of the main menu and once again in-car during a saved game. The station ID's, DJ Intros/Outros, and comercials all played great, but one track in particular gave me problems.

(Sometimes the dead air would occur after a track finished, other times it would occur after a few transitional (ID) and (DJ) clips. I also noticed that when I switched cars or changed stations during the dead air the same track would kick on each time. And even though it wouldn't play the Intros of that track it would always cycle through to the next track when finished. So I'm lead to believe it was an issue with either the Intros or the track itself.)

Ultimately, I reconverted and reclipped that particular track with the same exact settings as before and it appears to work fine now. (I don't know why, but before these tests the dead air seemed to occur a lot more frequently than when just 1 particular track of 17 was starting an Intro. confused.gif )

So if anyone else is experiencing an issue similar to this, check each track to see if it's the audio file itself that's causing the problem.

Thanks again pdescobar, this is an awesome tool!

Dillyracer
  • Dillyracer

    citizen of lost heaven

  • Members
  • Joined: 30 Jul 2005

#117

Posted 28 January 2006 - 01:02 PM

Does anyone know where i can find the landstalker sound, i searched all the banks but didn't find anything

DJStylus
  • DJStylus

    Bread is tasty. Period.

  • Members
  • Joined: 05 Nov 2004

#118

Posted 31 January 2006 - 07:05 AM Edited by DJStylus, 31 January 2006 - 08:17 AM.

Awesome! Now I can replace those crappy gun sounds!

EDIT: Aw crap. Can someone please make a reference table for Bank_137?
I'm having lots of trouble figuring out the gun sounds.

pylb_etajv
  • pylb_etajv

    You can call me PY.

  • Members
  • Joined: 04 Jul 2005

#119

Posted 01 February 2006 - 03:57 PM

Awesome tool smile.gif

But I have a little question, (I'm also posting in the tutorial request forum, since i realise this has nothing to do with the tool except for audio). Does anyone know how to place a "sound origin" or associate a sound with an environment ? Like in Ganton you can hear gunshots, in Nightclubs you hear the music, etc...
I don't want to change a sound, or add a sound, but create a new place in the game where sound is played.

Thanks anyway for this utility smile.gif

pdescobar
  • pdescobar

    Conformist Scum Panda

  • Members
  • Joined: 19 Jul 2005

#120

Posted 01 February 2006 - 09:21 PM

QUOTE (pylb_etajv @ Feb 1 2006, 10:57)
Awesome tool smile.gif

But I have a little question, (I'm also posting in the tutorial request forum, since i realise this has nothing to do with the tool except for audio). Does anyone know how to place a "sound origin" or associate a sound with an environment ? Like in Ganton you can hear gunshots, in Nightclubs you hear the music, etc...
I don't want to change a sound, or add a sound, but create a new place in the game where sound is played.

Thanks anyway for this utility smile.gif

I think the gunshots in Ganton might be from actual gunfights. tounge2.gif The background music medley in the Dance Club interiors, however, is due to an Audio Zone which is created by an "AUZO" entry in the ipl files. Specifically, take a look at the file Audiozon.ipl and reference the IPL Definition topic for some details.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users