Quantcast

Jump to content

» «
Photo

[REL|SA] Map Cleaner

157 replies to this topic
$ Niki $
  • $ Niki $

    Group:Sound&Art Prod. Group:Modelers Group:AF Motion GFX

  • Awaiting Authorisation
  • Joined: 11 Dec 2009

#151

Posted 28 August 2010 - 04:18 PM

QUOTE (ilir @ Aug 28 2010, 11:10)
yair1221's & andyyy94's problem solved.
--------------------------------------------------------------------------
I've sent a PM to steve-m about fixing low audio when you start new game for first time. I think this is the only mapcleaner's bug.
It will be very nice if steve make a little update of macleaner. suicidal.gif

Yeah i really hated the starting low audio damn ugly thing suicidal.gif , i wish he fix that it will be cool .

larosco
  • larosco

    Yay Area

  • Members
  • Joined: 27 Jan 2005

#152

Posted 12 September 2010 - 01:39 AM

the only way i can get it to working again is to change directory which is bad

faraz420
  • faraz420

    Player Hater

  • Members
  • Joined: 21 Oct 2010

#153

Posted 21 October 2010 - 01:56 PM

QUOTE (steve-m @ Jun 21 2005, 23:58)
Update: I've uploaded a new version of the Map Cleaner, should be fully functional. It's recommended to use the default settings, so just select your SA directory and press start. Check out the readme for full documentation and hints. Stripped mission script and water file included.

[ Get SA Map Cleaner 0.4 Beta ]


There's also a test version of the upcoming 0.5 release available.

- - - original post - - -

illspirit and I were working on cleaning the SA map the last days, mainly for total conversions such as MI, but weren't very successful yet. When deleting too much, the game either crashes immediately after everything was loaded, or it enters an infinite loop of doom.

It's no problem to get the (visual) map clear. All you need to do is remove all ipl entries from the gta.dat and delete all binary ipls in gta3.img. It's even possible to remove the interior ide entries and delete the complete gta_int.img (!), but as soon as you start removing some of the city map ide files, the problems begin.

As far as we know, you can remove all of the \LA\ ide files, and very few of the others, without a crash. illy tried to delete single object defs in one ide that wasn't working, and eventually got it running, but only with half the defs still in, and it didn't seem to matter which half was deleted.

So then we went on with deleting unused files from the img, since that was a problem for VC. I even coded a tool for that. But still not more successful than before.

So that's why we are publishing this, and we hope someone might still have any idea we overlooked, or can do some more testing and maybe get it working by deleting just some more col files or anything. I've uploaded my tool and a stripped water file and mission script, all in the following package. Take a look at the readme before using the tool! And remember to have a complete backup copy of SanAn, YOU WILL NEED IT!!!

Download


Edit: And on a side note, we know that there must be some data that define how items are grouped and replaced by LOD (parent objects and such). And I'm quite sure that's the cause of the above mentioned problems. But atm we have no idea where these are hidden. Possibly binary and text ipls, since they have a new parameter (which is -1 for LODs and non-child objects), and there could be some other data hidden in the binary ipls now. Or, it has something to do with the 64 nodes*.dat files, which might divide the map into a 8x8 (or deeper) grid, containing links and parameters to the item instances, which might be used by the engine for some sort of quadtree sorting. But that's only a wild guess, since I haven't really looked at those files yet.

Hey it is not working. i clean the map by using this programe and when i load my game it crashed.PLEASE tell me the solution.Iam waiting for your answer. angry.gif angry.gif angry.gif

GritEngine
  • GritEngine

    I♥R*N

  • BUSTED!
  • Joined: 29 Jun 2010

#154

Posted 22 October 2010 - 02:22 AM

do you have v1.0 of SA?

Also, have you installed at least dexx's basic map included?? put in thenew script assets? Read the readme at all? sly.gif

Check if the interior img file is still there... if it is, rename or delete it. That's if all the above is "yes". Good luck.

Nawram
  • Nawram

    Player Hater

  • Members
  • Joined: 22 Mar 2012

#155

Posted 24 March 2012 - 06:24 PM

Hallo steve-m

Ich habe eine frage. Ich habe San Andreas mit deiner genialen Software, Map Cleaner, "gecleant". Jetzt möchte ich gerne wissen, wie ich den Barber Shop, den Burger Shot, der Tuning Shop und den Paintshop wiederherstellen kann.

Vielen Dank!

d3jan
  • d3jan

    Prime

  • Members
  • Joined: 01 Jun 2011
  • Macedonia

#156

Posted 21 June 2012 - 01:25 AM

hi, i have a problem, if i delete everything and add the Dexx map the game crashes, but when i keep "dynamic, dynamic2,multiobj" the game its working fine, but if a delete "multiobj" and keep "dynamic, dynamic2" the game crashes after few second of playing, does anyone knows how to delete everything and not crash biggrin.gif plss help

Skander44
  • Skander44

    Player Hater

  • Members
  • Joined: 02 Dec 2012

#157

Posted 23 January 2013 - 07:56 AM

I used to have a prob with 4.0 (Problem is : at TXDCUT it freezes sad.gif now its fixed with 5.0 RC1) YAAAY FOR STEVE-M

Skander44
  • Skander44

    Player Hater

  • Members
  • Joined: 02 Dec 2012

#158

Posted 23 January 2013 - 07:58 AM

QUOTE (andyyy94 @ Thursday, Aug 19 2010, 22:30)
Hi everyone! I got the same problem as yair.
I've replaced ALL the files, checked whatever is told in this topic, and my game stills crashing! If you want to know if I modified my game, I only changed textures with TXD Workshop.
Do I need a completely default gta3.img to make my game load? Or is just an unknown error?
Thanks! I need some help with a TC.

PS: I used Mapcleaner 0.5 RC1

Simple, if it keeps on crashing, Thats because theres no maps and to stop it from crashing. You need to download a map mod. Thats the error, i learned that from TC GTAIV TO SA
smile.gif




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users