Quantcast

Jump to content

» «
Photo

Solution for f*** problem with black roads

81 replies to this topic
Aeutius
  • Aeutius

    Player Hater

  • Members
  • Joined: 12 Jun 2005

#1

Posted 14 June 2005 - 12:08 AM

Yes!

I was fighting with this fuc*** bug for two days. I tried nearly everething - new drivers, downgrading directs, Windows ME compatibility modes, etc... Finally, i managed to find a way to fix. Its quite simple - all you need is small tool called nVHardPage - you can download it here. Run it, choose Direct3D, find "User MipMap" and disable it. It works!

Here some screens:

BEFORE

user posted image

AFTER

user posted image

Greetings from Poland biggrin.gif

Lambda.core
  • Lambda.core

    Player Hater

  • Members
  • Joined: 12 Jun 2005

#2

Posted 14 June 2005 - 12:23 AM

I have a Radeon 9550 and I have this problem, should I still download it?

jesushumper
  • jesushumper

    Prankster

  • Members
  • Joined: 11 May 2005

#3

Posted 14 June 2005 - 12:36 AM

You can also just raise teh Mipmap levels in your Direct 3D tweaks under "Advanced" in display properties. This helps with the 'banding' effect on that top screenshot.

Enabling anisotropic filtering will help a lot too.
With very small performance hit.

Yes, that texture banding it annoying as hell.

Put those two optoins up and you're fine.
Just fine.

Overture
  • Overture

    Knight of the damned

  • Members
  • Joined: 11 Jun 2005

#4

Posted 14 June 2005 - 02:32 AM

You know, I thought that smoothly gradiated textures over a distance was a feature.
The "improved" view just seems unrealistic to me.

Oh well, each to their own.

Zackzr
  • Zackzr

    A deadly blessing...

  • Members
  • Joined: 09 May 2005

#5

Posted 14 June 2005 - 06:56 AM

QUOTE (Aeutius @ Jun 14 2005, 00:08)
Yes!

I was fighting with this fuc*** bug for two days. I tried nearly everething - new drivers, downgrading directs, Windows ME compatibility modes, etc... Finally, i managed to find a way to fix. Its quite simple - all you need is small tool called nVHardPage - you can download it here. Run it, choose Direct3D, find "User MipMap" and disable it. It works!

Greetings from Poland biggrin.gif

Hello, can you tell me how to apply those settings? I downloaded the program and I see no save or apply anywhere. Maybe I am overlooking it? Can you tell me how to apply the changes with this program? Thanks

Aeutius
  • Aeutius

    Player Hater

  • Members
  • Joined: 12 Jun 2005

#6

Posted 14 June 2005 - 09:19 AM

QUOTE (Zackzr @ Jun 14 2005, 06:56)
Hello, can you tell me how to apply those settings? I downloaded the program and I see no save or apply anywhere. Maybe I am overlooking it? Can you tell me how to apply the changes with this program? Thanks

There is no option to save - you only need to change it, exit the program and run game.

Zackzr
  • Zackzr

    A deadly blessing...

  • Members
  • Joined: 09 May 2005

#7

Posted 14 June 2005 - 09:59 AM

QUOTE (Aeutius @ Jun 14 2005, 09:19)
QUOTE (Zackzr @ Jun 14 2005, 06:56)
Hello, can you tell me how to apply those settings?  I downloaded the program and I see no save or apply anywhere.  Maybe I am overlooking it?  Can you tell me how to apply the changes with this program?  Thanks

There is no option to save - you only need to change it, exit the program and run game.

Ok, well thanks, I guess it just won't work with my video card then. If I close it out, and then start it again the "Enable Mip Mapping" box is checked again. It will not disable it for some reason then. Thanks anyways.

Denny8303
  • Denny8303

    Player Hater

  • Members
  • Joined: 28 May 2004

#8

Posted 14 June 2005 - 10:15 AM

Didn't work for me either, this is probably my biggest annoyance with SA atm. Ah well, thanks anyway though guys.

Aeutius
  • Aeutius

    Player Hater

  • Members
  • Joined: 12 Jun 2005

#9

Posted 14 June 2005 - 10:21 AM

Strange... People, maybe you shoud try another tweaker? All you need is to find way to shut down this user mipmaps.

Zackzr
  • Zackzr

    A deadly blessing...

  • Members
  • Joined: 09 May 2005

#10

Posted 14 June 2005 - 11:14 AM Edited by Zackzr, 14 June 2005 - 11:17 AM.

QUOTE (Aeutius @ Jun 14 2005, 10:21)
Strange... People, maybe you shoud try another tweaker? All you need is to find way to shut down this user mipmaps.

I'm sorry for my ignorance on this topic (I have never had to mess with Mip Maping before), but where can I find another "tweaker"? I have searched google for over an hour and have found nothing. What should I search for?

I am having no problems with the game so far anywhere except for the same problem you had in San Fierro. I don't really see it anywhere else, only in San Fierro, but it is very annoying, and would be great if I could remedy this problem.

Aeutius
  • Aeutius

    Player Hater

  • Members
  • Joined: 12 Jun 2005

#11

Posted 14 June 2005 - 12:17 PM

QUOTE (Zackzr @ Jun 14 2005, 11:14)
I'm sorry for my ignorance on this topic (I have never had to mess with Mip Maping before), but where can I find another "tweaker"? I have searched google for over an hour and have found nothing. What should I search for?

I am having no problems with the game so far anywhere except for the same problem you had in San Fierro. I don't really see it anywhere else, only in San Fierro, but it is very annoying, and would be great if I could remedy this problem.

Here you can find some tweakers for ATi, and here for NVIDIA. I hope that this will help...

Unfortunatly, description is not in English, but you can use translator.

tacka19
  • tacka19

    Player Hater

  • Members
  • Joined: 12 Jun 2005

#12

Posted 14 June 2005 - 02:13 PM

u mnie działa! smile.gif

works 4 me!

Denny8303
  • Denny8303

    Player Hater

  • Members
  • Joined: 28 May 2004

#13

Posted 14 June 2005 - 06:42 PM

It still doesn't work for me, i tried Cool Bits and RivaTuner and neither worked, i did as you said and disabled User MipMaps, i even tried adjusting my MipMap level and to no avail the black textures remain.

It's probably some misc dumb setting i need to enable/disable too. In case anybody is wondering, i'm using 71.89 Forceware Drivers on a 128MB Nvidia Geforce FX 5700 Ultra (non-OEM), DirectX 9.0c, all driver settings at default.

Aeutius
  • Aeutius

    Player Hater

  • Members
  • Joined: 12 Jun 2005

#14

Posted 14 June 2005 - 11:22 PM

Maybe this is important - i have old drivers (56.72). After installing new ones(anything above 56.72) graphic in my SA beacames completly weird, so i had to unistall them.

GomerThePyle
  • GomerThePyle

    Player Hater

  • Members
  • Joined: 10 Jun 2005

#15

Posted 14 June 2005 - 11:28 PM

What exactly does mipmap do?

Denny8303
  • Denny8303

    Player Hater

  • Members
  • Joined: 28 May 2004

#16

Posted 15 June 2005 - 03:07 AM

QUOTE (Aeutius @ Jun 14 2005, 23:22)
Maybe this is important - i have old drivers (56.72). After installing new ones(anything above 56.72) graphic in my SA beacames completly weird, so i had to unistall them.

Yes it is. I've tried three newer drivers such as 71.89, 76.50 and now 77.50 and none work using your fix. Those are some really old drivers you have though, i'm not sure i'd be worth going back that far just for one game and not have them work well on other newer games. I may try it though to see if it does work with them drivers.

gtasanandreasmaster
  • gtasanandreasmaster

    SAN ANDREAS !!!!!!!!!!&a

  • BUSTED!
  • Joined: 13 Jan 2005

#17

Posted 15 June 2005 - 07:10 AM

or wow thankz man this has got rid of my awfull black roads

Denny8303
  • Denny8303

    Player Hater

  • Members
  • Joined: 28 May 2004

#18

Posted 15 June 2005 - 07:39 AM

It worked! I downloaded the 56.72 drivers and disabled user mipmaps and sure enough, worked great. Thank you for you assistance.

But the question i have now is it safe to keep drivers this old on my PC even for newer games? I mean the 56.72 drivers aren't exactly new or anything. In fact, they just added support for my video card in this driver set. I didn't really see any performance difference going from the newest drivers to these.

Alxwin
  • Alxwin

    Player Hater

  • Members
  • Joined: 10 Jun 2005

#19

Posted 15 June 2005 - 11:53 AM

Thx Aeutius!!!! biggrin.gif biggrin.gif
Black roads eliminated!! sly.gif

Aeutius
  • Aeutius

    Player Hater

  • Members
  • Joined: 12 Jun 2005

#20

Posted 15 June 2005 - 12:35 PM

QUOTE (Denny8303 @ Jun 15 2005, 07:39)
But the question i have now is it safe to keep drivers this old on my PC even for newer games? I mean the 56.72 drivers aren't exactly new or anything. In fact, they just added support for my video card in this driver set. I didn't really see any performance difference going from the newest drivers to these.

I am not sure of it, but i think that it should be quite safe. I never updated drivers for nearly one year, and i don't had any problems with them smile.gif

Anyway, i am glad that i could help smile.gif

kevuwk
  • kevuwk

    Snitch

  • Members
  • Joined: 26 Oct 2004

#21

Posted 15 June 2005 - 12:41 PM

was just passing through (mainly for sa-mp) and i thought i would check here for this, disabled user mipmap and it did nothing so thought i'd check incase this happened to anyone else (it was definately disabled) so i noticed people downgrading drivers and i tried it and it worked, well done to the people for 'daring' to downgrade drivers, never the best thing to do, but it worked fine

Cran.
  • Cran.

    910 reprisent

  • Members
  • Joined: 20 Apr 2004

#22

Posted 15 June 2005 - 01:34 PM

Hey, if you have a pretty powerful comp, and don't want to downgarde your drivers putting AF will pretty much get rid of it. Haven't seen any of it on x16.

mattstone_2000
  • mattstone_2000

    Player Hater

  • Members
  • Joined: 15 Jun 2005

#23

Posted 15 June 2005 - 02:52 PM

I have this problem too. (see pic below)

user posted image

It didn't happen to start with. But then I re-installed my Omega forceware drivers, and now as well as the black roads I also have the mipmap option greyed-out in the game. Odd. It also makes no difference for me if I increase the draw distance, or alter mipmapping or antroscopic filtering in my driver settings.

The NVHardPage utlity doesn't work for me - same problem as the people on the previous page. Anyone know of any similar programs to change the mipmapping?

Aeutius
  • Aeutius

    Player Hater

  • Members
  • Joined: 12 Jun 2005

#24

Posted 15 June 2005 - 03:05 PM

@mattstone_2000

Tried downgrading drivers to 56.72? What graphic card you have?

mattstone_2000
  • mattstone_2000

    Player Hater

  • Members
  • Joined: 15 Jun 2005

#25

Posted 15 June 2005 - 03:31 PM

QUOTE (Aeutius @ Jun 15 2005, 15:05)
@mattstone_2000

Tried downgrading drivers to 56.72? What graphic card you have?

I have a GF 4 ti4200 (64mb), running on a 1Ghz AMD Athlon, 512mb RAM, system.

I might try the driver downgrade, but I am slightly anxious about using such dated drivers. Will I suffer in terms of FPS in exchange for correcting the black road problem?

Aeutius
  • Aeutius

    Player Hater

  • Members
  • Joined: 12 Jun 2005

#26

Posted 15 June 2005 - 04:45 PM

QUOTE (mattstone_2000 @ Jun 15 2005, 15:31)
Will I suffer in terms of FPS in exchange for correcting the black road problem?

Hmmm...

Personally i don't feel any diffrence, but i dont know how it will look like in your PC. Anyway - i think that you should at least try. If installing old drivers wont help, you can always reinstall new ones :-)


mattstone_2000
  • mattstone_2000

    Player Hater

  • Members
  • Joined: 15 Jun 2005

#27

Posted 15 June 2005 - 05:25 PM

Okay, I've just tried the 56.72 drivers, and it improves the black roads a lot. However, there must have been at least a 20-30% decrease in fps. sad.gif

I think I might just have to put up with it, as my wimpy processor isn't going to be able to handle too much tweaking without the game becoming unplayably slow.

Denny8303
  • Denny8303

    Player Hater

  • Members
  • Joined: 28 May 2004

#28

Posted 15 June 2005 - 05:37 PM

QUOTE (Aeutius @ Jun 15 2005, 12:35)
I am not sure of it, but i think that it should be quite safe. I never updated drivers for nearly one year, and i don't had any problems with them smile.gif

Okay, just checking, personally i haven't had troubles with them yet so i'll keep them for now, hopefully R* comes out with a patch to fix this and the other misc bugs. I wonder if this will fix my mipmap problem in Unreal Tournament using the U4e weapons as well (the original UT, not 2004) we shall soon see i guess.

But that's something else entirely, here have a cookie.gif

scalliano
  • scalliano

    Ice Cold Killa

  • Members
  • Joined: 31 Jul 2004

#29

Posted 15 June 2005 - 08:07 PM

All I can say is, YOU F***ING DANCER!!!! Nice work mate! It even unlocks the mipmapping option in SA's internal menu. NICE ONE!!!

SimonS
  • SimonS

    Don't push the Mario Men!

  • Members
  • Joined: 30 Jul 2002

#30

Posted 15 June 2005 - 09:54 PM

Not everyone uses Nvidia
What about the ATI guys?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users