Jump to content

» «

Technical FAQ (bugs, workarounds, etc)

  • This topic is locked This topic is locked
217 replies to this topic
  • MaximumGain

    Player Hater

  • Members
  • Joined: 05 Nov 2005


Posted 18 June 2006 - 03:33 AM

QUOTE (katanamaster @ May 25 2006, 18:03)
Little more info:

I installed on my PC, but same thing, crashes after intro.

I have:
WinXP media center
Intel P4 3.0 GHz
MSI gaming MoBo (dont have the model memorised sorry)
ATI Radeon 9800 Pro 128MB
SB Live Audigy 5.1 surround (I hardly use it, Im using my logitec headphones most of the time, USB)
And alot of other stuff that's not important.
I disabled the onboard sound (nforce chipset) so there shouldnt be a problem there.

Im about to give up and my friend to get a refund. I have the error report: I skipped the module report because it was long.

Application exception occurred:
App: C:\Program Files\Rockstar Games\GTA San Andreas\gta_sa.exe (pid=4948)
When: 5/25/2006 @ 10:41:55.812
Exception number: c0000005 (access violation)

*----> System Information <----*
Computer Name: U-C68A754D00A84
User Name: Savage
Terminal Session Id: 0
Number of Processors: 2
Processor Type: x86 Family 15 Model 2 Stepping 9
Windows Version: 5.1
Current Build: 2600
Service Pack: 2
Current Type: Multiprocessor Free
Registered Organization: U.S. Martial Arts
Registered Owner: Jason Scribner

*----> Task List <----*
0 System Process
4 System
740 smss.exe
796 csrss.exe
824 winlogon.exe
872 services.exe
884 lsass.exe
1056 Ati2evxx.exe
1072 svchost.exe
1148 svchost.exe
1252 svchost.exe
1348 svchost.exe
1448 svchost.exe
1648 spoolsv.exe
1796 ehRecvr.exe
1816 ehSched.exe
1896 Omniserv.exe
2036 svchost.exe
536 OPXPApp.exe
400 mcrdsvc.exe
1020 dllhost.exe
1432 alg.exe
4216 Ati2evxx.exe
4304 Explorer.EXE
4520 scureapp.exe
4528 VCDDaemon.exe
4552 fdm.exe
4564 Help.exe
4948 gta_sa.exe
6044 drwtsn32.exe
*----> State Dump for Thread Id 0x1394 <----*

eax=00000000 ebx=00000000 ecx=00000000 edx=00000000 esi=00b6bd44 edi=0000001b
eip=004dd5a3 esp=0022fcd8 ebp=77d50a92 iopl=0 nv up ei ng nz ac pe cy
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00200293

*** ERROR: Module load completed but symbols could not be loaded for C:\Program Files\Rockstar Games\GTA San Andreas\gta_sa.exe
function: gta_sa
004dd57d 0000 add [eax],al
004dd57f 0000 add [eax],al
004dd581 00803fc78424 add [eax+0x2484c73f],al
004dd587 c8000000 enter 0x0,0x0
004dd58b 0000 add [eax],al
004dd58d 0000 add [eax],al
004dd58f 895c2440 mov [esp+0x40],ebx
004dd593 8b8424f4000000 mov eax,[esp+0xf4]
004dd59a 83f865 cmp eax,0x65
004dd59d 8b0df800bd00 mov ecx,[gta_sa+0x7d00f8 (00bd00f8)]
FAULT ->004dd5a3 0fbe1401 movsx edx,byte ptr [ecx+eax] ds:0023:00000000=??
004dd5a7 899424ac000000 mov [esp+0xac],edx
004dd5ae 899c24ec000000 mov [esp+0xec],ebx
004dd5b5 db8424ac000000 fild dword ptr [esp+0xac]
004dd5bc d88424f8000000 fadd dword ptr [esp+0xf8]
004dd5c3 d95c2410 fstp dword ptr [esp+0x10]
004dd5c7 0f87a4160000 jnbe gta_sa+0xdec71 (004dec71)
004dd5cd 0fb6802ced4d00 movzx eax,byte ptr [eax+0x4ded2c]
004dd5d4 ff2485a0ec4d00 jmp dword ptr [gta_sa+0xdeca0 (004deca0)+eax*4]
004dd5db 53 push ebx
004dd5dc 6a3b push 0x3b

EDIT: when i sent the error report microsoft led me to take2's support page for San Andreas. They told me to download the patch, but when i tried to update it, it said it "couldn't find old file. A same file was found and no updates were made".

I'm having this exact same problem! I've re-installed 3 times, de-fragged, gone through error-checking, everything. What can we do to fix this?

  • MaximumGain

    Player Hater

  • Members
  • Joined: 05 Nov 2005


Posted 25 June 2006 - 06:44 AM

At my wits end. Originally installed the game in the late summer of '05. Worked beautifully until May 06. Now the game will load showing the R*, NVidia, and San Andreas logo, but will crash right after.

WinXP Professional SP2 (5.1, Build 2600)
GeForce FX 5200 128MB
AMD Athlon XP 2200+, MMX, 3DNow, ~1.8GHZ
1024 RAM

Drivers are updated
System has been defragged three times
GTA San Andreas has been uninstalled and re-installed 5 times
Error check performed on all disks

Error signature:
AppName: gta_sa.exe AppVer: ModName: wmvcore.dll
ModVer: Offset: 0007aa82

  • ciroman


  • Members
  • Joined: 11 Jun 2005


Posted 08 July 2006 - 03:35 PM

now i have the same problem, everyone says to update the drivers, but its never the drivers fault(atleast graphics), i dunno for the sound card, it may be the soundcard cuz i had crashes with some games from the beginning i bought my computer, but apparently noone has the solution, and everyone that's "trying" to solve the problem dont have the problem themselves and they say UPDATE THE DRIVERS, UNINSTALL THE GAME, WTF!!!!!!! Uninstalling the game doesnt work, neither does updating the drivers, and all of this takes like 3 hours to do!

So apparently what you guys have to do is buy a new graphics card recommend 6800 - 7800, but dont buy SE's and LE's

EDIT: oh, and these 6800 and 7600 are pretty cheap, so its not a big problem to buy them

  • Rhenan

    Player Hater

  • Members
  • Joined: 25 Jul 2006


Posted 25 July 2006 - 04:00 AM

I've just got a problem I've not seen before. I can't buy any new clothes! basically I enter a shop, go into the changing room and select a new item to preview.. the problem is Carl never comes out of the changing room and I can't cancel out. The only thing is to re-load my previous save.. but even then if I try again and I can't buy new clothes.

any ideas?

  • Headgib

    Player Hater

  • Members
  • Joined: 25 Jul 2006


Posted 25 July 2006 - 08:27 PM

Well, after a long time of trying. I'm still having my sound problem with GTA SA. I tried every suggestion I have seen and they SEEM to have helped with it all but the Rain Bug. It seems like the game doesn't have enugh sound channels or somthing. I don't know.

I have a Mobo with nForce and Realtek and my drivers have been updated for quite awile.

If anyone has any new suggestions for me i'd love to hear them. I'm going to go nuts.

Oh and, hi biggrin.gif. First post on the Forum


3.06 GHz Intel Pentium 4 (Wish I had AMD tounge.gif) Processer.
NVIDIA 6200 PCI-Express Turbo Cache Video Card.
512MB of RAM ( Getting another Gig of ram put in soon biggrin.gif)
Realtek HD Audio Onboard Sound.

Probably going to be a new addition soon


Downgrading my sound quality in DXDIAG didn't seem to help either... And I don't want to lose any audio quality or positioning anyway.

Oh and i'm using headphones.

  • Silver9990

    Fatal error: Call to undefined function mysql_connect()

  • Members
  • Joined: 15 Aug 2006


Posted 15 August 2006 - 06:48 AM Edited by Silver9990, 16 August 2006 - 04:49 AM.

Operating system: Windows 2000 SP4
Video/Graphics card: nVidia GeForce 2 MX400 Pro-T/64 MB AGP 4x
Processor: PIV 1.6 GHz
RAM: 256 DDR
DirectX 9.0c

I've read that people have been able to run this game with a GeForce 2 card, how? The game loads fine up until it gets to the menu (or lack of) and just crashes.

  • Silver9990

    Fatal error: Call to undefined function mysql_connect()

  • Members
  • Joined: 15 Aug 2006


Posted 17 August 2006 - 05:47 AM

Never mind, I just got an nVidia GeForce 4 MX440 and the game now runs fine, except for the occasional crash while usubg cheats.

  • csgamegodd

    Player Hater

  • Members
  • Joined: 18 Sep 2006


Posted 18 September 2006 - 09:35 AM

hello there guys, im stuck in the infamous I RAN THE GAME ONCE, AND IT DIDN'T WORK AGAIN problem. I currently have 5 pcs where San Andreas was still running a week ago but now, they fall one by one.

i just noticed something weird in one of my pcs that i have here. i have not played san andreas since 3 days and when i opened it back, the eax.dll, ogg.dll stream configuration pad, vorbis.dll, vorbisfile.dll and gta_sa.exe were gone for unknown reasons. i tried copying the files that i mentioned ago from the 5 pcs i had but it still gives the same problem. I RAN THE GAME ONCE, AND IT DIDN'T WORK AGAIN. i tried running in the remaining pcs but i have no idea why in my 5 pcs, all of them had the I RAN THE GAME ONCE, AND IT DIDN'T WORK AGAIN problem in the same time.

the error log windows gave:

AppName: gta_sa.exe  AppVer:  ModName: ntdll.dll
ModVer: 5.1.2600.2180  Offset: 00001010

i have reformatted a pc here and boosted up everything but still i earn the same problem.

first pc(head pc specs):

Asus P4V8MX-X Series Motherboard
256mb DDR memory
Asus V9400 128mb video card
and a healthy hard drive with lots of spaces
windows xp professional sp2

remaining pc(client pc specs):

Asrock P4VM800
Inno 3d FX5200 128mb video card
256mb DDR memory
and a healthy hard drive with lots of spaces
windows xp professional sp2

also, on the head pc, i have no other background programs running. no limewire, no alcohol, no daemon tools and alike. but on the remaining pcs, they only have avg on background.

i have tested chrisy_mac's(http://www.gtaforums...howtopic=196303) method but it gave no way to me.

ehh, is it worthy to buy a new copy of gta: san andreas again? im thinking of wasting credits just to play san andreas now.

  • Zhubanov

    Player Hater

  • Members
  • Joined: 04 Nov 2006


Posted 04 December 2006 - 01:04 PM

Hey guys, I have some problem too.
I have nVidia Geforce 7300 SE (64/256 MB TC)
and smoke is green.. dont know why.. It seems that all, what have to be gray or black is just green. Thanks for help
(in 32 bit mode its ok)

  • axesays

    Player Hater

  • Members
  • Joined: 12 Dec 2006


Posted 12 December 2006 - 12:54 PM

My GTA application has been crashing ever since the update carried out by my OS (Win XP prof)..the prob that i used to face was that the application would crash after showing the credits..i have been trying innumerable solution posted on the net but without much luck..but one night while i was sleeping CJ came into my dream and uttered the magic word "load up ya drive..homie"...i woke up and to my amusement found out that i haven't mounted the cd image of the game while trying to run the application..silly me..such utter carelessness..i had a good laugh..no prob with the application now..needless to say..CJ..you rock..

  • CRS_AaronG

    Player Hater

  • Members
  • Joined: 19 Dec 2006


Posted 19 December 2006 - 03:24 AM

I'm not sure I understand what you mean by load the CD image. Please enlighten me as I'm one of the many people having the crash problem. I gotta get this game playin.

  • Cyphus

    Player Hater

  • Members
  • Joined: 30 Dec 2006


Posted 30 December 2006 - 12:50 AM

I have a big problem... When i start a game, the beginning cutscene, and all other cutscenes stop after about 1 second and goes to where the cutscene would finish. So i get no story or anything. I just bought the UK DVD version.
Please help. I really want to play this game.

  • Cooter

    Player Hater

  • Members
  • Joined: 03 Jan 2007


Posted 03 January 2007 - 10:13 AM


I just got this game for Christmas and was banging my head against the keyboard for hours because the game would freeze up just about every time I tried to Jack a car, or enter buildings and houses. [CTRL][ALT][DELETE] didnít work, and there was no way [ALT][TAB] or [ALT][F4] would work either. I had to cut the power and hard boot my computer many times.

I tried everything mentioned on this thread except disabling my Antivirus. Everything is working fine now. I have played it for many hours without any real problems.

I hope this might help some people out.

  • CRS_AaronG

    Player Hater

  • Members
  • Joined: 19 Dec 2006


Posted 12 January 2007 - 03:11 AM

Yeah, well, from what I noticed, when I explored the DVD-Rom, it's missing the audio streams. This is probably why people can't install it and it wont load pas the San Andreas picture. I'm calling support and if they fix it, I'll get back to you.

  • kaileingod

    Player Hater

  • Members
  • Joined: 19 Feb 2007


Posted 22 February 2007 - 10:10 AM

please help me ive got this problem where gta will load but then it will show an error report no black screen nothing else at all the error report shows some file in temp which is only there for as long as i have the error report open for it wont load beyond this point please help me my dvd drivers are up to date

  • joejoe_wagstaff

    Player Hater

  • Joined: 04 Mar 2007


Posted 06 March 2007 - 05:31 PM

I had the problem with the crashing after the splash screen, its because the graphics card is useless. So im buying a new computer because laptops are aweful.

  • Jerry_03

    I like GTA.

  • Members
  • Joined: 13 Mar 2007


Posted 17 March 2007 - 07:27 AM

okay, ive been trying to fix theis problem for about a week now and im getting frustrated.

the problem is the infamous, crash to desktop after the splash screen, before the main menu. it gives me no error message, just a a crash to desktop.

Heres my system specs:
-Win XP SP1
-NVIDIA GeForce FX 5200 128mb
-Intel Pen 4 Processor 2.80Ghz
-512mb RAM
-GTA SA Second Edition if that matters

ive tried almost everything listed in this FAQ that is applicable to the crash to desktop. ive read most of the replies in this thread that concerns the crash. ive googled it and tried those suggestions ive found. ive tried 3d analyzer, as seen in this thread. none of it is working.

i did try the win98 compatibility mode it didnt work. i also tried windows 2000 compatibility mode it didnt work either. i have administrative privileges on this account that ive used to try and run GTA San Andreas. ive tried launching GTA SA with another user account that had password and admin. and never installed any mods

and how do i view the log file "AnalysisLog.sr0" that is created by right clicking the gta_sa.exe>clicking on launch analysis.

This is the first time i installed GTA San Andreas and it was without the audio tracks (limited install). when i have time i will uninstall it and reinstall it with audio tracks (full install) and see if that works.

if it doesnt im guessing its my video card (I have the latest video card drivers and directx). but ive heard of some people run GTA SA on older carders than mine sad.gif

Any help is greatly appreciated.

  • Jerry_03

    I like GTA.

  • Members
  • Joined: 13 Mar 2007


Posted 18 March 2007 - 12:59 PM

well i finally had time to reinstall GTA SA. and as i said earlier, this time i did the full install with the audio tracks and now its working! biggrin.gif

freddy wycheck
  • freddy wycheck

    Player Hater

  • Members
  • Joined: 06 May 2007


Posted 06 May 2007 - 08:39 PM

man...sorry i gotta complain real quick

I see that everyone tells what kind of operating system, graphics card, processor, and ram info all up...but since this topic is about audio...wouldn't it be common sense to tell us what kind of sound card you are using? no offense or anything to those who didn't, and thanks to those who have...but I've been on this forum for dayssssssssssssss looking up on info for my problem

I have:
2.0 Intel pentium 4 processor
EMU 1212M soundcard (emu is a division of creative labs...but i dont see how i'm going to make this work)

i dont even know what graphics card i'm using to be honest...it's a stock card...in control pannel it says som'm about intel graphics (82845G/GL Graphics Controller properties) and my game does run kinda slow...but than again i got 40 gigs of memory and it's filled to around 95% or som'm close to that...and the cp is 6 years old...though it's a descent HP still.

I really never considered my soundcard being a problem with playing a video game, especially since i have a high-grade sound card. but the problem is, this soundcard I dont think really runs direct x 9.0 or is compatible with it, and i'm not sure where to find out...I'd try and look it up, but surfing the web has become so retarded lately because of all the spam sites through google and the viruses on my cp. I'm average when it comes to computer knowledge, but mainly i just understand audio specs and all that. I'm wondering if there's someway i can bypass or manipulate the direct x 9 and get my soundcard to pick up the game's audio signal. the soundcard supports WDM, and the drivers are up to date.

Is there anyone out there that can help me solve this problem? is there a mod that will reroute the audio to a normal WDM signal or anything like that???

also, another little helpful hint, when starting the game and when the untro of the rockstar logos comes up, i hear the spraypaint and scribble sound effects. I guess that isn't going through directx9 or whatever...

I'm hoping there's a simple solution...though i doubt there is


freddy wycheck
  • freddy wycheck

    Player Hater

  • Members
  • Joined: 06 May 2007


Posted 06 May 2007 - 08:46 PM

woooow...ok so i solved the problem right before my previous post and didn't even realize...I know my stock soundcard that I'm not using right now is a realtek...so i thought why not try updating it's drivers like it was suggested in the beginning of this topic (or atleast i know it was mentioned in this thread) but i assumed it wouldn't work so I went ahead and posted my problem...i go to check out GTA to see if my new settings would work and I heard the intro music and i was in shock, my jaw literally dropped.

!!!!there should be an addition to this thread in the beginning stating that anyone using a different soundcard (as in a professional recording/music production card) from their stock card should try the realtek updated drivers, because it was the solution to my problem, and i can gaurantee there's many others who have had this problem, but just gave up trying to fix it after researching all the info.

just my opinion...and thanks for the help!!!


  • nalex

    Player Hater

  • Members
  • Joined: 03 May 2007


Posted 18 May 2007 - 12:08 AM Edited by nalex, 18 May 2007 - 12:29 AM.

How can I save my game settings?
When I redefine controls and turn off my game it goes back to default when I turn it back on.
I'm playing eng version of SA on PC.

  • TonyResta

    Tony Resta

  • Members
  • Joined: 01 Mar 2006


Posted 03 June 2007 - 05:31 PM

Ok i have a fix that works for the Black Roads Bug:

Now, replace the texture of the road that is having this black road problem (in my case all of bloody san andreas) and it will magically go away, i dont know why, but it fixes it. heres a demonstration of the fix:


user posted image
user posted image


user posted image
user posted image

  • gtacharles1984

    Player Hater

  • Members
  • Joined: 02 Nov 2005


Posted 16 June 2007 - 06:17 PM

Hi I have the following problem

Operating system: Windows Vista Home Premium
Video/Graphics card type + graphics memory: Intel GMA 950. Graphics memory 224 MB
Processor: Intel Core 2 CPU T5600 @1.83 GHz
RAM (random access memory): 1 GB

My laptop is a Dell XPS M1210. The situation is that when I get to the main screen (the one with options, begin game etc). the screen is blurry, like not stable and it shows a bunch of letters on top of it.

My directX is 10, can U please help me????


  • tfandtftd

    Player Hater

  • Members
  • Joined: 17 Jun 2007


Posted 18 June 2007 - 10:29 PM

biggrin.gif i found the answer if nothing works then:

1) download daemon tools
2)then mount the gta sa image
3)put all opitions on and play... biggrin.gif biggrin.gif biggrin.gif

  • gtacharles1984

    Player Hater

  • Members
  • Joined: 02 Nov 2005


Posted 20 June 2007 - 02:23 PM

Where can I get the daemon tools and do what you propose?



  • younes024

    Player Hater

  • Members
  • Joined: 27 Jun 2007


Posted 28 June 2007 - 09:58 AM Edited by younes024, 28 June 2007 - 10:05 AM.

the game worked fine before,but now the bar loads half and then crashes and goes to my desktop

  • smithy96

    Player Hater

  • Members
  • Joined: 28 Jun 2007


Posted 30 June 2007 - 02:05 AM

QUOTE (younes024 @ Jun 28 2007, 09:58)
the game worked fine before,but now the bar loads half and then crashes and goes to my desktop

same here can people please help us with this

Wheelie Stunt
  • Wheelie Stunt

    Player Hater

  • Members
  • Joined: 28 Nov 2004


Posted 31 July 2007 - 09:47 PM

I have a new solution I had never heared of...

m2) Q: GRAND THEFT AUTO: San Andreas does not start when I launch it, it just returns to the desktop?

I just changed my video card and it ran well for two days and all of the sudden Not San Andreas, nor Vice City load...?....I tryed all the solutions I could apply to my case but none worked, but I finally made it work.... I had two controllers installed in my system an USB-PS adapter and a PrinterPort-PS adapter....this is a no-no. I uninstalled the PrinterPort adapter (NTPAD) and now everything works 100%.

Thank you for this great thread colgate.gif

  • tfandtftd

    Player Hater

  • Members
  • Joined: 17 Jun 2007


Posted 12 August 2007 - 10:40 AM

My gta sa game wont work for ages it takes ages to load it goes fine until the
screen before the menu and takes an our to load then it finally work plz in need help.

cryani.gif cryani.gif cryani.gif

contact lukerules38@hotmail.com

  • tfandtftd

    Player Hater

  • Members
  • Joined: 17 Jun 2007


Posted 18 August 2007 - 12:08 AM

guess what i put on the downgrader patch and now my game is fixed and also get multiplayer when it starts to work[FONT=Impact][COLOR=red]

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users